Subject: Re: Status update

From: Justin Clift <[email-masked]>
Date: Sat, 30 Aug 2003 23:48:43 +0800

Hi Andreas,

This definitely looks like a good start.  Found it difficult to get the 
German version of the site to load automatically (Mozilla probably 
needed a restart after changing the language selection, but I had too 
many other windows open with interesting things in them to want to close 
them...).

Is there a strategy in place for creating news and events in languages 
other than English?

We'd probably want to manage the events and news a bit seperately from 
each other... or at least have a "language" field for each news/event so 
it only displays the relevant ones.

This might or might not have been considered already though, with me 
having missed the conversation...

;-)

Regards and best wishes,

Justin Clift

Andreas GrabmXller wrote:

> Hi,
> 
> I think the new multilingual website system is working now (well, the technical side works, I have not added all pages and files yet). You can find it on http://wwwdevel2.postgresql.org
> 
> It would be good to get some comments / suggestions on the code now... you can find it at /home/www.postgresql.com/andreas/public_html or view it on the web at http://svn.gamecrashnet.de/repos/pgsql_org/
> 
> Some comments on how the system works:
> 
> Every request goes through some RewriteRules in the .htaccess file. If the files exists in the cache directory, this one is delivered (for performance reasons). If the is for a file in the /admin, /layout or the /files directory, nothing happens. Every other request gets redirected to the script /system/handler.php (or /system/handleform.php which handles every dynamic request) where the pages get built and delivered dynamically.
> 
> There is a script in the /tools directory called "rebuildcache" written in PHP, this can rebuild parts or or the whole cache directory. just call it without arguments to get the help. The cache directory contains all static pages and elements, so this can be used to mirror the whole website (all dynamic contents get linked to postgresql.org statically).
> 
> Is there a problem with this? Or is something missing?
> 
> Mit freundlichen Grüßen
> Andreas Grabmüller
> 
> --
> LetzPlay.de
> | Freemail:       http://www.letzplay.de/mail
> | Forenhosting: http://www.letzplay.de/foren
> ---------------------------(end of broadcast)---------------------------
> TIP 8: explain analyze is your friend

---

From: "Dave Page" <[email-masked]>
Date: Sat, 30 Aug 2003 22:34:11 +0100

> -----Original Message-----
> From: Andreas Grabmüller [mailto:[email-masked]] 
> Sent: 30 August 2003 14:22
> To: [email-masked]
> Subject: [pgsql-www] Status update
> 
> 
> Hi,
> 
> I think the new multilingual website system is working now 
> (well, the technical side works, I have not added all pages 
> and files yet). You can find it on http://wwwdevel2.postgresql.org

Hi Andreas,

Looks very good! Nice work. Yuo probably noticed already, but the page design has been updated slightly on the live site - that shouldn't be difficult to update however.

The golden question though, is how does it handle mirroring? Currently, we mirror all non-php pages, excluding a select few (things like the buildscripts). None of the mirrors have any special configuration, or even PHP these days. Is this going to cause any problems, or will it work?

Regards, Dave.

---

From: "Dave Page" <[email-masked]>
Date: Mon, 8 Sep 2003 14:58:54 +0100

> Sent: 30 August 2003 22:55
> To: Dave Page; [email-masked]; [email-masked]
> Subject: Re: [pgsql-www] Status update
> 
> 
> Hi Dave,
> 
> It *should* work fine - there are many .htm files in the 
> cache directory, also the layout and files directory. The 
> only thing missing is a nice index page and they can simply 
> mirror the cache directory. The only pages not 
> cached/mirrored currently are download.htm and mirrors.htm as 
> the mirrors-near-you-feature need php.

Hi Andreas,

Sorry for the delay, however I've been extremely busy recently.

It looks good to me from here - I have rsync'd a copy, and that seems OK. I take it the idea is that the tools/rebuildcache script will replace the current scripts that build the whole site? How quickly does it run - the current stuff takes only a few minutes.

If you can sort a mirrorable index page, and bring the content/design up to date then I think we're ready to go.

What does everyone else think? I'd like to hear more opinions before making such a large change to the site live.

Regards, Dave.

---

From: "Dave Page" <[email-masked]>
Date: Mon, 8 Sep 2003 19:56:31 +0100

> Sent: 08 September 2003 17:28
> yes, the rebuildcache script is made to build the whole site. 
> In my last test it has taken about one minute to rebuild 
> everything except the documentation (which takes really long) 
> in two languages. But I don't think it is necessary to 
> rebuild the docs very often?

Currently the whole site is done hourly. It certainly doesn't have to be that regular for the docs, though I think the front page should be to pick up new events etc.

> I'm currently working on getting the new design working. As 
> we have problems with the different length of the words in 
> the different languages, I'm replacing the style= parts of 
> the code with a class= and putting that formatting 
> information into postgresql_en.css and postgresql_de.css so 
> we can use different sizes for every language...

OK. What about a slight redesign to allow the wrapping to occur without messing up the formatting? Alternatively, Robert was looking at making a non-fixed width version of the site which might solve this problem.

Regards, Dave.

---

From: "Dave Page" <[email-masked]>
Date: Mon, 8 Sep 2003 20:37:07 +0100

> From: Jeroen Ruigrok/asmodai [mailto:[email-masked]] 
> Sent: 08 September 2003 20:16
> To: Andreas Grabmüller
> Cc: Dave Page; [email-masked]
> -On [20030908 21:12], Andreas Grabmüller 
> ([email-masked]) wrote:
> >Well, I'm not very good in designing, but if you give me something I 
> >will implement it ;)
> 
> Sorry for piping in here guys,
> 
> but I've recently redone the tendra.org site (be aware, the 
> IPv6 address points to the new machine and isn't working yet) 
> and would like to help on designing a bit more usable 
> postgresql.org site.
> 
> Could someone be so kind to inform me what is being done at 
> the moment, because I have some ideas I want to work out and 
> present to you people over the course of the coming days/weeks.

Hi Jeroen 

The major project right now is Andreas' baby - namely to recode the site in an translatable and easily maintainable format. Further info is best left to Andreas as I'm not familiar with the details of his implementation.

Regards, Dave.

---

From: Robert Treat <[email-masked]>
Date: 08 Sep 2003 18:57:25 -0400

On Mon, 2003-09-08 at 15:20, Andreas Grabmüller wrote:
> ----- Original-Nachricht -----
> Von: "Dave Page" <[email-masked]>
> An: <[email-masked]>, <[email-masked]>
> Datum: Monday, September 08, 2003 09:15 PM
> Betreff: [pgsql-www] Status update
> 
> > > > OK. What about a slight redesign to allow the wrapping to occur 
> > > > without messing up the formatting? Alternatively, Robert 
> > > was looking 
> > > > at making a non-fixed width version of the site which might 
> > > solve this 
> > > > problem.
> > > > 
> > > > Regards, Dave.
> > > 
> > > Well, I'm not very good in designing, but if you give me 
> > > something I will implement it ;)
> > 
> > Sorry, I just don't have time right now. Go with your current idea for now if you prefer - we can always revisit the problem in the future.
> > 
> > :-)
> > 
> > Regards, Dave.
> 
> Okay, then I will do that for now...
> 

Unfortunately I am slammed right now too, but I'd much rather see an
implementation that no longers uses fixed widths than separates our css
files into different langs... I had somewhat stopped waiting for your
lang changes to get committed before working further on it... Andreas,
if I show you what I was working on do you have an interest in
implementing it? 

Robert Treat
-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL