Subject: Re: progress update, some questions

From: "Dave Page" <[email-masked]>
Date: Wed, 21 Apr 2004 13:53:13 +0100

> -----Original Message-----
> From: Alexey Borzov [mailto:[email-masked]] 
> Sent: 21 April 2004 13:34
> To: [email-masked]
> Subject: [pgsql-www] progress update, some questions
> 
> Greetings.
> 
> I almost finished the work on user-level form submits 
> (surveys, bugs, doc comments, events and news) and have a few 
> questions.
> 
> 1) Is 'active' field in 'events' table really needed? Maybe 
> just consider the events with end date in the future as valid?

No, that field is now obsolete.

> 2) Bug submit through the website just increments some 
> sequence but the bug itself is not stored in the database. Is 
> this the expected behaviour? What came out of a lengthy 
> discussion about a "real" bug tracker?

Yes, that is the intended behaviour for the moment.

> 3) There is *no* moderation at all for the doc comments, I 
> suppose? You know why PHP's have such a good signal-to-noise 
> ratio? Here is the
> reason: http://lists.php.net/group.php?group=php.notes

There is no moderation, though I believe some of the docs guys go
through them before any releases to incorporate anything useful. 

Feel free to add some moderation if you like - an email to the list with
a link to an 'approve' script in /admin would do the job I guess.

Regards Dave.

---

From: Robert Treat <[email-masked]>
Date: Wed, 21 Apr 2004 13:10:58 -0400

> a link to an 'approve' script in /admin would do the job I guess.

Something I've been thinking of adding to our current admin stuff is an 
automatic email of actual approvals of news/events; I see they do something 
similar on the php docs by emailing out any changes, I'd really like to have 
that feature included if we add moderation tech to our docs. 

Robert Treat
-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL

---

From: Alexey Borzov <[email-masked]>
Date: Thu, 22 Apr 2004 00:15:53 +0400

Hi!

> that feature included if we add moderation tech to our docs. 

Before I actually start working on admin pages: what exactly do you want sent to 
the list?
1) News items/events added (like it is done now).
2) Approvals of news/events (automatically, unlike now).
3) Added doc comments.
4) Approved/deleted doc comments.

---

From: Robert Treat <[email-masked]>
Date: 22 Apr 2004 16:41:14 -0400

> 2) Approvals of news/events (automatically, unlike now).

definitely we need the above two

> 4) Approved/deleted doc comments.

The only concern I would have about these would be to make sure that we
have enough qualified people to handle these appropriatly here. Peter,
you do a lot of the doc oriented stuff, do you have any input on the
above two?  Would it be better if they went to the docs list? 

Robert Treat

---

From: Alexey Borzov <[email-masked]>
Date: Fri, 23 Apr 2004 16:43:39 +0400

Hi!

> above two?  Would it be better if they went to the docs list? 

BTW, in such a case there will immediately be a need to give different 
access rights to different people...