Subject: Re: [webmaster] Problem with 'report a bug form'

From: "Dave Page" <[email-masked]>
Date: Tue, 25 May 2004 08:29:25 +0100

Can someone take a look at this problem reported by David please (the
bug form that is, not the JDBC issue)? I'm pretty swamped right now :-(

Regards, Dave.

> -----Original Message-----
> From: David Brownlee [mailto:[email-masked]] 
> Sent: 22 May 2004 18:15
> To: [email-masked]
> Subject: [webmaster] Problem with 'report a bug form'
> 
>  	Submit does not appear to work:
> 
>  	Contents were:
> 
> 
> In AbstractJdbc2ResultSet:parseQuery can end up leaving a ; 
> on the end of a tablename, which when later used in 
> isUpdateable() will choke.
> The following 'fixes' it:
> 
> --- org/postgresql/jdbc2/AbstractJdbc2ResultSet.java.orig     
>   2004-05-21 
> 12:54
> :29.000000000 +0100
> +++ org/postgresql/jdbc2/AbstractJdbc2ResultSet.java
> @@ -1448,7 +1450,7 @@ public abstract class AbstractJdbc2Resul
>                          {
>                                  if 
> (name.toLowerCase().equals("from"))
>                                  {
> -                                       tableName = st.nextToken();
> +                                       tableName =
> st.nextToken().replaceAll(";
> ", "");
>                                          tableFound = true;
>                                  }
> 
> This was found while writing a small java tool to copy the 
> contents of one database to another, which can be provided to 
> demonstrate the problem on request. Would have attached it 
> here if there had been an option :)
> 
> -- 
>  			   David Brownlee -- [email-masked]
> 
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 1: subscribe and unsubscribe commands go to 
> [email-masked]
>

---

From: Robert Treat <[email-masked]>
Date: 26 May 2004 11:18:40 -0400

David, what made you think that the submission didn't work? I show your
report in the archives at
http://archives.postgresql.org/pgsql-bugs/2004-05/msg00130.php

Robert Treat

On Tue, 2004-05-25 at 03:29, Dave Page wrote:
> ---------------------------(end of broadcast)---------------------------
> TIP 2: you can get off all lists at once with the unregister command
>     (send "unregister YourEmailAddressHere" to [email-masked])

-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL