Subject: Two issues involving unsubscribe

From: Josh Berkus <[email-masked]>
Date: Tue, 4 Apr 2006 11:42:38 -0700

Marc, all:

First off, I'd love to see some unsubscribe links available at 
www.postgresq.org/community/lists.   Currently you have to drill down via 
the archives to get to the unsub links; this confuses a lot of users ( I 
know I didn't find it on the first try) and as a result I end up fielding 
about a dozen "how do I unsubscribe" questions a week.

Second, (this is for Marc) I'd like to know what's possible in the way of 
banning certain addresses from subscribing, either to specific lists or to 
all lists.  What I want to ban is:
1) anyone from uol.com.br or other domains which use email-back security;
2) certain people who cronically put on vacation notices without suspending 
their subscriptions;
3) users like the one today who sent me a profanity-filled request to 
unsubscribe.

It seems like majordomo has tools to do some of the above, but they seem to 
be per-list only, and to require some knowledge of the filter syntax.  
Marc?

-- 
Josh Berkus

---

From: "Marc G. Fournier" <[email-masked]>
Date: Tue, 4 Apr 2006 16:20:03 -0300 (ADT)

> be per-list only, and to require some knowledge of the filter syntax.

Hell no, and fairly easy ... we have a slew of them right now ... for more 
details, look at the access_rules documentation, but here is what is in 
place right now across all lists ... I even have one in place for the 
@uol.com.br like you requested ages back ... if its not working, though, 
I'll look into the 'why', as its possible I have ordering wrong:

configset DEFAULT access_rules <<ENDAAB
post
deny, reason="The message is too big"
$body_length_exceeded

post
deny, reply=NONE
$taboo_spamassassin > 6

post
consult, reply=NONE
$taboo_spamassassin

post
deny, reply=NONE
$taboo_virus_subject

post
deny, reply=NONE
$taboo_subject

post
deny, reason="Not a valid mailing list"
$taboo_to_header

post
deny, reply=NONE
$addrcomment =~ /Mail Delivery System/i || $addrcomment =~ /Mail Delivery Subsystem/i || $addrcomment =~ /virus/i

post
deny, reply=NONE
$addrcomment =~ /Policy Filter/i || $addrcomment =~ /Forum Access/i || $addrcomment =~ /DrWeb-DAEMON/i || $addrcomment =~ /Content Filter/i

post
deny, reply=NONE
/mailer-daemon/i OR /virus/i OR /listserv/i OR /postmaster/i OR /mdaemon/i

post
deny, reply=NONE
$host =~ /^svr1.postgresql\.org$/ AND NOT @

post
deny, reply=NONE
$host =~ /^forum\.postgresql\.org$/ AND NOT @

post
deny, reply=NONE
$dup

post
unset=dup_checksum, unset=dup_partial_checksum
ALL

subscribe
deny
/@uol.com.br/
ENDAAB

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: Josh Berkus <[email-masked]>
Date: Tue, 4 Apr 2006 12:23:09 -0700

Marc,

> Hell no, and fairly easy ... we have a slew of them right now ... for
> more details, look at the access_rules documentation, but here is what
> is in place right now across all lists ... I even have one in place for
> the @uol.com.br like you requested ages back ... if its not working,
> though, I'll look into the 'why', as its possible I have ordering wrong:

Unfortunately, it's not working.  We have 3 uol.com.br people subscribed 
right now, I know because I got all their bounce messages.  ;-b

-- 
--Josh

Josh Berkus
Aglio Database Solutions
San Francisco

---

From: David Fetter <[email-masked]>
Date: Tue, 4 Apr 2006 12:26:00 -0700

On Tue, Apr 04, 2006 at 11:42:38AM -0700, Josh Berkus wrote:
> www.postgresq.org/community/lists.   Currently you have to drill
> down via the archives to get to the unsub links; this confuses a lot
> of users ( I know I didn't find it on the first try) and as a result
> I end up fielding about a dozen "how do I unsubscribe" questions a
> week.

I get a few fewer.  I've committed a change to
template/en/community/lists.html that should make things a little
clearer.

> 1) anyone from uol.com.br or other domains which use email-back security;

Amen!

> 2) certain people who cronically put on vacation notices without suspending 

Meh.

> 3) users like the one today who sent me a profanity-filled request to 

Yes, she's really something else. :P

Cheers,
D
-- 
David Fetter <[email-masked]> http://fetter.org/
phone: +1 415 235 3778        AIM: dfetter666
                              Skype: davidfetter

Remember to vote!

---

From: "Marc G. Fournier" <[email-masked]>
Date: Tue, 4 Apr 2006 16:44:08 -0300 (ADT)

> right now, I know because I got all their bounce messages.  ;-b

'k, what list?  I just checked pgsql-announce, where they usually are, and 
nothing is there ... checked -general and -hackers to, nadda ... and I'm 
using 'grep -i', just in case its as something like UOL.com.br ..

----

---

From: Josh Berkus <[email-masked]>
Date: Tue, 4 Apr 2006 12:46:17 -0700

Marc,

> 'k, what list?  I just checked pgsql-announce, where they usually are,
> and nothing is there ... checked -general and -hackers to, nadda ... and
> I'm using 'grep -i', just in case its as something like UOL.com.br ..

Announce.  Craparooni, maybe they're using mail forwarding?    I should 
have saved those.  Will make a list next time I send an announce e-mail.

In the meantime, can you unsubscribe [email-masked] and ban her 
from resubscribing?

-- 
--Josh

Josh Berkus
Aglio Database Solutions
San Francisco

---

From: Devrim GUNDUZ <[email-masked]>
Date: Tue, 04 Apr 2006 22:50:28 +0300

Hi,

On Tue, 2006-04-04 at 11:42 -0700, Josh Berkus wrote:
> www.postgresq.org/community/lists.   

What about another form named "unsubscribe" which is similar to
subscribe form and just has unsub option?

Regards,
-- 
The PostgreSQL Company - Command Prompt, Inc. 1.503.667.4564
PostgreSQL Replication, Consulting, Custom Development, 24x7 support
Managed Services, Shared and Dedicated Hosting
Co-Authors: PL/php, plPerlNG - http://www.commandprompt.com/

---

From: "Marc G. Fournier" <[email-masked]>
Date: Tue, 4 Apr 2006 16:54:14 -0300 (ADT)

On Tue, 4 Apr 2006, Josh Berkus wrote:

> Announce.  Craparooni, maybe they're using mail forwarding?

Would be my guess :(  Makes it all the more fun, eh? :)

> In the meantime, can you unsubscribe [email-masked] and ban her 

Done:

subscribe
deny
/@uol.com.br/i || /[email-masked]/i

----