Subject: BUG #6639: Manual uses boldface where it says italic, and monospace where it says boldface

From: [email-masked]
Date: Mon, 14 May 2012 21:41:59 +0000

The following bug has been logged on the website:

Bug reference:      6639
Logged by:          Ian
Email address:      [email-masked]
PostgreSQL version: 9.1.3
Operating system:   GNU/Linux
Description:        

The URL http://www.postgresql.org/docs/9.1/interactive/notation.html lays
out the notation used in the rest of the book, but it appears to be out of
date with the stylesheet, as the differences noted in the subject apply.

---

From: Peter Eisentraut <[email-masked]>
Date: Tue, 15 May 2012 21:36:30 +0300

> date with the stylesheet, as the differences noted in the subject apply.

Indeed.  I've been wondering for a while why some things look so odd
with the new stylesheet, but that page really summarizes it quite well.
Someone on the web team should fix that.

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 29 Aug 2012 21:29:49 -0400

> date with the stylesheet, as the differences noted in the subject apply.

Where are you seeing this?  PDF, web version?  An example?

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + It's impossible for everything to be true. +

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 30 Aug 2012 08:55:57 -0400

> Someone on the web team should fix that.

I can confirm that this is messed up:

	http://www.postgresql.org/docs/9.2/static/notation.html

The word 'italic' is in bold.  Would someone fix this?

---

From: Peter Eisentraut <[email-masked]>
Date: Tue, 04 Dec 2012 06:51:49 -0500

> Someone on the web team should fix that.

It's still broken.  Could someone from the web team fix this, or point
out where the source files are so someone else can fix it?

-- 
Sent via pgsql-www mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-www

---

From: Magnus Hagander <[email-masked]>
Date: Tue, 4 Dec 2012 12:58:45 +0100

> out where the source files are so someone else can fix it?

The stylesheet is where it has always been -
http://git.postgresql.org/gitweb/?p=pgweb.git;a=tree;f=media/css;h=ee7073d2e7e99fcf4dc09e4ff21ae8c6a21e15f2;hb=53cd5a83f519f64ba04d3bccc6b667e70850675d.
Most of the docs specific stuff is in
http://git.postgresql.org/gitweb/?p=pgweb.git;a=blob;f=media/css/docs.css;h=3b272f6979054d4a0fe6d217c1e90d286b7f81dc;hb=53cd5a83f519f64ba04d3bccc6b667e70850675d.

The other option would be to actually change the text for that page,
and keep the stylesheet. I think the stylesheet was originally adapted
to make it look better on the web - but that was long ago enough that
I don't remember it. It would be easy enough to override specifically
the notation.html file when the docs are loaded on the website.

Thom's the one who's been doing work on the CSS here most recently, so
he's probably the best one to give further pointers.

--
 Magnus Hagander
 Me: http://www.hagander.net/
 Work: http://www.redpill-linpro.com/