Subject: Proposed changes to security.html

From: Josh Berkus <[email-masked]>
Date: Wed, 06 Feb 2013 12:01:42 -0800

Folks,

I'd like to make two changes to the security.html page:

1) change all references from "contrib modules" to "extensions".  Put a
note on the bottom of the page explaining that they are the same thing.

2) create a second page, security-old.html.  This page would archive the
references to security issues patched on versions no longer under
support (i.e. 8.2 and earlier).

-- 
Josh Berkus
PostgreSQL Experts Inc.
http://pgexperts.com

-- 
Sent via pgsql-www mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-www

---

From: Dave Page <[email-masked]>
Date: Wed, 6 Feb 2013 20:08:02 +0000

> support (i.e. 8.2 and earlier).

No objection here.

--
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Tom Lane <[email-masked]>
Date: Wed, 06 Feb 2013 16:41:28 -0500

> support (i.e. 8.2 and earlier).

At this point, shouldn't 8.3 also go to the "old" page?

			regards, tom lane

---

From: Josh Berkus <[email-masked]>
Date: Wed, 06 Feb 2013 17:57:46 -0800

> At this point, shouldn't 8.3 also go to the "old" page?

*After* the next update release, yes.   I was figuring I'd wait for a
couple weeks after that, and then archive it.

-- 
Josh Berkus
PostgreSQL Experts Inc.
http://pgexperts.com

---

From: Magnus Hagander <[email-masked]>
Date: Thu, 7 Feb 2013 13:41:17 +0100

> couple weeks after that, and then archive it.

Yeah, seems reasonable to keep it around for a while.

--
 Magnus Hagander
 Me: http://www.hagander.net/
 Work: http://www.redpill-linpro.com/

---

From: Stefan Kaltenbrunner <[email-masked]>
Date: Thu, 14 Feb 2013 21:58:12 +0100

> support (i.e. 8.2 and earlier).

+1 one on both - do you have a proposed wording or even better a patch
for those changes?

Stefan

---

From: Josh Berkus <[email-masked]>
Date: Thu, 14 Feb 2013 14:48:32 -0800

> +1 one on both - do you have a proposed wording or even better a patch

I'll submit a patch.  I've just been kind of busy.

-- 
Josh Berkus
PostgreSQL Experts Inc.
http://pgexperts.com

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 01 Mar 2013 17:33:38 -0500

> note on the bottom of the page explaining that they are the same thing.

What would be the point of that, other than introducing the use of less
accurate language?

---

From: Josh Berkus <[email-masked]>
Date: Fri, 01 Mar 2013 16:22:46 -0800

> What would be the point of that, other than introducing the use of less

Oh, right, we have some contrib modules which are not extensions.
However, the term "contrib" is confusing and not very helpful.  Maybe I
should use the term "Additional Supplied Modules" (shorthand "modules"),
which is what we use in the docs?

-- 
Josh Berkus
PostgreSQL Experts Inc.
http://pgexperts.com

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 01 Mar 2013 23:16:27 -0500

> which is what we use in the docs?

That might be worthwhile consideration for introductory or marketing
material, say, but for the purpose of tracking security issues,
"contrib" is perfectly clear: If you are installing from source, it is
code that lives under contrib/.  If you are installing from binary, it
is code that is in the postgresql-contrib package (usually).  Calling it
anything other than "contrib" cannot possibly make that more clear.

---

From: Josh Berkus <[email-masked]>
Date: Sun, 03 Mar 2013 12:06:37 -0800

> anything other than "contrib" cannot possibly make that more clear.

Yeah, I suppose the security page is not the place to address this.  We
have a larger project problem in using three different bits of
terminology for mostly the same set of software.  We can fix the
security page once we fix the terminology in general.

-- 
Josh Berkus
PostgreSQL Experts Inc.
http://pgexperts.com