Subject: Spam filtering for mailing lists

From: "Greg Sabino Mullane" <[email-masked]>
Date: Fri, 27 Jan 2006 12:56:35 -0000

Could we implement some sort of spam filtering on the mail server
for gborg? The dbdpg-general list is being flooded with spam, and
even a simple SpamAssassin filter with a relatively high number
would drop the number by quite a bit. I'm having to clear 100+
messages out of the mailman queue every few days now.

- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200601270750
http://biglumber.com/x/web?pk=2529DF6AB8F79407E94445B4BC9B906714964AC8

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 27 Jan 2006 14:35:15 +0100

> messages out of the mailman queue every few days now.

What's the problem?  Just leave them there and let them expire.

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Fri, 27 Jan 2006 13:50:13 -0000

> What's the problem?  Just leave them there and let them expire.

(1) As far as I know, they don't "expire".

(2) There are legitimate messages that need to be approved
occasionally. If there weren't, we could simply drop all
messages from non-subscribers.

- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200601270848
http://biglumber.com/x/web?pk=2529DF6AB8F79407E94445B4BC9B906714964AC8

---

From: Kenneth Marshall <[email-masked]>
Date: Fri, 27 Jan 2006 07:55:34 -0600

Speaking of subscribing, how does one subscribe to avoid the
moderation delay? I receive the mailings but all of my postings
are delayed.

Ken

On Fri, Jan 27, 2006 at 01:50:13PM -0000, Greg Sabino Mullane wrote:
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> -----BEGIN PGP SIGNATURE-----
> 
> iD8DBQFD2iS5vJuQZxSWSsgRAmuWAJ463YX4FvUBvaZUH5MiDji6tDZ6LQCgyMVw
> EuU0JRP67eI6nKlZdvc39VI=
> =Wc5M
> -----END PGP SIGNATURE-----
> 
> 
> 
> ---------------------------(end of broadcast)---------------------------
> TIP 6: explain analyze is your friend

---

From: "Marc G. Fournier" <[email-masked]>
Date: Fri, 27 Jan 2006 10:05:02 -0400 (AST)

Done ... email now goes throgh both GreyListing *and* Amavisd, which is 
setup for anti-spam and virus ...

On Fri, 27 Jan 2006, Greg Sabino Mullane wrote:

> iD8DBQFD2hcsvJuQZxSWSsgRAjDzAKCg5BJdOatAC9sH6+fkW3/Ba/uGqgCeODJ3
> pamBQWb23Qrz1qalt9vkMlU=
> =ilgF
> TIP 2: Don't 'kill -9' the postmaster
>

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: "Marc G. Fournier" <[email-masked]>
Date: Fri, 27 Jan 2006 10:05:57 -0400 (AST)

> messages from non-subscribers.

Ummm, one thing to note, we don't have spamassassin set to auto-kill 
anything, you have to setup some sort of filter on your end for that ... 
with Majordomo2, we have it as an access_rule, but I don't know how to do 
it with mailman ...

----

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Fri, 27 Jan 2006 14:32:31 -0000

> setup for anti-spam and virus ...

Thank you much.

> it with mailman .

Mailman has a way to do this. If not, I'll let you know. :)

- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200601270929
http://biglumber.com/x/web?pk=2529DF6AB8F79407E94445B4BC9B906714964AC8

---

From: "Larry Rosenman" <[email-masked]>
Date: Fri, 27 Jan 2006 08:49:55 -0600

Greg Sabino Mullane wrote:
>> Done ... email now goes throgh both GreyListing *and* Amavisd, which
>> is setup for anti-spam and virus ...
> 
> Thank you much.
> 
>> anything, you have to setup some sort of filter on your end for that
>> ... with Majordomo2, we have it as an access_rule, but I don't know
>> how to do it with mailman .
> 

http://www.jamesh.id.au/articles/mailman-spamassassin/

and what version of Mailman?

LER

-- 
Larry Rosenman                     http://www.lerctr.org/~ler
Phone: +1 512-248-2683                 E-Mail: [email-masked]
US Mail: 430 Valona Loop, Round Rock, TX 78681-3893

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Fri, 27 Jan 2006 15:02:37 -0000

> moderation delay? I receive the mailings but all of my postings

The information on the dbdpg-general list, including how to subscribe,
can be found here:

http://gborg.postgresql.org/mailman/listinfo/dbdpg-general

If you have any problems subscribing, please email me off-list.

- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200601271000
http://biglumber.com/x/web?pk=2529DF6AB8F79407E94445B4BC9B906714964AC8

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 31 Jan 2006 12:51:00 -0500 (EST)

> with Majordomo2, we have it as an access_rule, but I don't know how to do 

Yes, I noticed that while spamassasin marks email as spam, it still
forwards it to the recipient.  I had to add a rule in my spamassasin
filter to delete those marked as spam.

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Wed, 1 Feb 2006 15:48:57 -0000

>> with Majordomo2, we have it as an access_rule, but I don't know how to do

I've got it working within Mailman, and it seems to be working well: the
queue this morning has 2 spams and 1 real message, which is a vast improvement
as the old ratio was more like 70:1.

The dbdpg-commits list still seems stuck, however. I'm ccing the admin
for that list as well.

- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200602011046
http://biglumber.com/x/web?pk=2529DF6AB8F79407E94445B4BC9B906714964AC8