Subject: New News Entry

From: [email-masked] (World Wide Web Owner)
Date: Thu, 4 Dec 2003 17:05:08 -0400 (AST)

A new entry has been added to the news database.

Database Admin: http://www.postgresql.org/admin/edit_news.php?166

Submitted by: [email-masked]
Headline: PostgreSQL is cover page on SQL Magazine
Summary:

PostgreSQL is on the cover of SQL Magazine, a well-know developer magazine in Brazil. It contains articles on Data Types (Eduardo Stern), Functions (Paulo Oliveira) and Transactions (Alex Sandro de Souza Siqueira and Carlos Eduardo Smanioto), and an exclusive interview with Bruce Momjiam.

Story:

<P>PostgreSQL is on the cover of the 7th edition of SQL Magazine, a well-know developer magazine in Brazil. It contains three articles on PostgreSQL about Data Types (Eduardo Stern), Functions (Paulo Oliveira) and Transactions (Alex Sandro de Souza Siqueira and Carlos Eduardo Smanioto), and an exclusive interview with Bruce Momjiam.</p>
<p> 
More information can be found on <a href=\"http://www.sqlmagazine.com.br/revista/sql7/revista07.html\">www.sqlmagazine.com.br</a>
</p>

---

From: "Dave Page" <[email-masked]>
Date: Thu, 4 Dec 2003 22:15:34 -0000

Thanks, approved.

> -----Original Message-----
> From: World Wide Web Owner [mailto:[email-masked]] 
> Sent: 04 December 2003 20:40
> To: [email-masked]
> Subject: [pgsql-www] New News Entry
> 
> Database Admin: http://www.postgresql.org/admin/edit_news.php?164
> 
> Submitted by: [email-masked]
> Headline: PostgreSQL 7.3.5 Update Released
> Summary:
> 
> After several fixes were backpatches to the 7_3_STABLE 
> branch, we have now released a 7.3.5.
> 
> Story:
> 
>  As the list of Changes since 7.3.4 is quite small, they follow:
> <p>
>      * Force zero_damaged_pages to be on during recovery from WAL<br>
>      * Prevent  some  obscure  cases  of  \"variable not in 
> subplan target
>        lists\"<br>
>      * Force  stats  processes  to  detach  from  shared 
> memory, ensuring
>        cleaner shutdown<br>
>      * Make PQescapeBytea and byteaout consistent with each 
> other (Joe)<br>
>      * Added missing SPI_finish() calls to 
> get_tuple_of_interest() (Joe)<br>
>      * Fix  for  possible foreign key violation when rule 
> rewrites INSERT<br>
>        (Jan)
>      * Support qualified type names in PL/Tcl\'s spi_prepare 
> command (Jan)<br>
>      * Make  pg_dump  handle  a  procedural  language  
> handler located in
>        pg_catalog<br>
>      * Make  pg_dump  handle  cases  where a custom opclass 
> is in another
>        schema<br>
>      * Make pg_dump dump binary-compatible casts correctly (Jan)<br>
>      * Fix  insertion  of  expressions  containing  
> subqueries  into rule
>        bodies<br>
>      * Fix  incorrect  argument  processing  in  clusterdb  
> script (Anand
>        Ranganathan)<br>
>      * Fix problems with dropped columns in plpython triggers<br>
>      * Repair  problems  with  to_char()  reading  past  end 
> of its input
>        string (Karel)<br>
>      * Fix GB18030 mapping errors (Tatsuo)<br>
>      * Fix  several problems with SSL error handling and 
> asynchronous SSL
>        I/O<br>
>      * Remove  ability  to bind a list of values to a single 
> parameter in
>        JDBC (prevents possible SQL-injection attacks)<br>
>      * Fix some errors in HAVE_INT64_TIMESTAMP code paths<br>
>      * Fix  corner case for btree search in parallel with 
> first root page
>        split
> <p>
> This version, as with most minor versions, does not require a 
> dump/reload to put into place.
> <p>
> As always, this release is available on all our mirrors, on 
> our <a 
> href=\"http://www.postgresql.org/mirrors-www.html\">Download 
> Page</a> <p> And, thanks to David Fetter, it is also <a 
> href=\"http://bt.postgresql.org\">available via BitTorrent</a>
> 
> 
> 
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 2: you can get off all lists at once with the unregister command
>     (send "unregister YourEmailAddressHere" to 
> [email-masked])
>

---

From: "Dave Page" <[email-masked]>
Date: Thu, 4 Dec 2003 22:15:48 -0000

Thanks, approved. 

> Sent: 04 December 2003 20:57
> Database Admin: http://www.postgresql.org/admin/edit_news.php?165
> 
> Headline: dbExperts Launches Replication System
> Summary:
> 
> dbExperts is releasing to the market the <i>dbExperts HA 
> Replication</i>. This replication system is based on the ACID 
> and Distributed Transactions standards, and allows the use of 
> PostgreSQL in High-Avaiablility 24x7 operation, Data Clusters 
> and Data Centralization. 
> 
> Story:
> 
> <p>dbExperts is releasing to the market the <i>dbExperts HA 
> Replication</i>. This replication system is based on the ACID 
> and Distributed Transactions standards, and allows the use of 
> PostgreSQL in High-Avaiablility 24x7 operation, Data Clusters 
> and Data Centralization. </p> <p>Already available as a 
> Product+Service+Support Contract package in Brazil, and 
> soon-to-be released on the US Market early 2004, this 
> solution is being used in production scale in some areas of 
> the Brazialian Governent since 2002, and is now is being 
> releasead to the market</p> <p>All the system is based on 
> portable C and PL/PGSQL code, and can work on any platform 
> (Linux, Windows, MacOSX, FreeBSD, HPUX, AIX, etc), either on 
> the master or the slave side. </p> <p>The replication uses 
> asyncronous concepts, and can be used on any kind of 
> single-master, multi-slave distributed database.</p> <P>More 
> information (in Portuguese) can be found on dbExperts 
> brazilian site on <a 
> href=\"http://www.dbexperts.com.br/replicacao\">www.dbexperts.
> com.br/replicacao</a>. </p>
> 
> 
> 
> 
> TIP 3: if posting/reading through Usenet, please send an appropriate
>       subscribe-nomail command to [email-masked] so 
> that your
>       message can get through to the mailing list cleanly
>

---

From: "Dave Page" <[email-masked]>
Date: Thu, 4 Dec 2003 22:16:08 -0000

Thanks, approved.

> Sent: 04 December 2003 21:05
> PostgreSQL is on the cover of SQL Magazine, a well-know 
> developer magazine in Brazil. It contains articles on Data 
> Types (Eduardo Stern), Functions (Paulo Oliveira) and 
> Transactions (Alex Sandro de Souza Siqueira and Carlos 
> Eduardo Smanioto), and an exclusive interview with Bruce Momjiam.
> 
> Story:
> 
> <P>PostgreSQL is on the cover of the 7th edition of SQL 
> Magazine, a well-know developer magazine in Brazil. It 
> contains three articles on PostgreSQL about Data Types 
> (Eduardo Stern), Functions (Paulo Oliveira) and Transactions 
> (Alex Sandro de Souza Siqueira and Carlos Eduardo Smanioto), 
> and an exclusive interview with Bruce Momjiam.</p> <p> More 
> information can be found on <a 
> href=\"http://www.sqlmagazine.com.br/revista/sql7/revista07.ht
> ml\">www.sqlmagazine.com.br</a>
> </p>
> 
> 
> 
> TIP 9: the planner will ignore your desire to choose an index 
> scan if your
>       joining column's datatypes do not match
>