Subject: New News Entry

From: [email-masked] (World Wide Web Owner)
Date: Thu, 18 Nov 2004 00:20:21 +0000 (GMT)

A new entry has been added to the news database.

Database Admin: http://www.postgresql.org/admin/edit_news.php?242

Submitted by: [email-masked]
Headline: FmPro Migrator 2.57 Adds Repeating Fields Extraction Feature for FileMaker to PostgreSQL Conversions
Summary:

Manually extracting FileMaker repeating fields into a relational database structure can be a time consuming process. FmPro Migrator easily extracts FileMaker repeating fields into a separate database table when performing FileMaker to PosgreSQL Conversions.

Story:

11-17-2004 - Fremont, CA - .com Solutions Inc. releases FmPro Migrator 2.57 Enterprise Edition for MacOS X and Windows - New Release Adds Repeating Fields Extraction Feature for PostgreSQL Database Conversions.

.com Solutions Inc., a developer of multi-platform database migration and development tools, has released FmPro Migrator 2.57 for MacOS X and Windows with a new repeating fields extraction feature for PostgreSQL database migrations. 

Many FileMaker databases include non-relational data elements called repeating fields. These fields store multiple values within each field and are associated with the main database record by the FileMaker database engine. Manually extracting these repeating fields into a relational database structure can be a time consuming and error-prone process. FmPro Migrator easily extracts FileMaker repeating fields into a separate database table in which the records are related to the main table by the primary key. Each iteration of a FileMaker repeating field is inserted as a new record within the repeating fields table.

FmPro Migrator standardizes and automates FileMaker database migration procedures including data type matching, field to column renaming, table creation, FileMaker field size determination and data transfer for 8 different database servers. Supported databases include MySQL, Oracle (8, 8i-9i, 10g), Access, SQL Server, Sybase, DB2, PostgreSQL and FrontBase.

FmPro Migrator Features include:

-- Repeating Fields Extraction PostgreSQL - Data from FileMaker repeating fields is now extracted into individual records within a repeating fields table related to the primary database table. Any number of non-container field repeating values are easily extracted to the child table and related to the primary table record by the primary key. Differing numbers of repeating field values are supported for each individual record within the primary database table.

-- Repeating Field Table Creation SQL Code Created Automatically - Table creation SQL code is automatically generated for each repeating field within the FileMaker database. Each repeating field table also includes primary key and foreign key constraint code to insure data integrity.

-- Drop Column Script Created for PostgreSQL - Once the repeating fields data has been migrated to the new repeating fields table, the unused columns are no longer needed within the main PostgreSQL database table. These columns are easily removed with a drop columns script which is created by FmPro Migrator. The automatic creation of this script by FmPro Migrator reduces the possibility of the DBA making errors by writing this script manually.

-- MacOS X and Windows Compatibility - FmPro Migrator runs on MacOS X and Windows, thus enabling developers to use their preferred platform for creating the migration scripts. 

FmPro Migrator is available for MacOS X and Windows. A free demo version of FmPro Migrator may be downloaded from www.fmpromigrator.com/downloads/index.html. For more info please see: www.fmpromigrator.com/products/fmpro_migrator

About .com Solutions Inc.
.com Solutions Inc. develops multi-platform graphical applications supporting FileMaker, Oracle, MySQL, Access, SQL Server, Sybase, DB2, PostgreSQL and FrontBase developers. FmPro Migrator ( www.fmpromigrator.com ) migrates FileMaker databases to and from FileMaker. Installgen automates over 100 Oracle install procedures on Solaris, Windows, Linux and MacOS X. Repgen generates Oracle replication scripts on Solaris, Windows, Linux and MacOS X. For more information about .com Solutions Inc., please visit www.dotcomsolutionsinc.net.

---

From: Josh Berkus <[email-masked]>
Date: Wed, 17 Nov 2004 17:36:19 -0800

Folks,

> Headline: FmPro Migrator 2.57 Adds Repeating Fields Extraction Feature for
> FileMaker to PostgreSQL Conversions Summary:

I vote to turn this down.    FmPro has already had their one news entry.   The 
can have maybe an -Announce.

--Josh

-- 
__Aglio Database Solutions_______________
Josh Berkus		       Consultant
[email-masked]	 www.agliodbs.com
Ph: 415-752-2500	Fax: 415-752-2387
2166 Hayes Suite 200	San Francisco, CA