Subject: New News Entry

From: [email-masked] (World Wide Web Owner)
Date: Tue, 23 Dec 2003 10:28:45 -0400 (AST)

A new entry has been added to the news database.

Database Admin: http://www.postgresql.org/admin/edit_news.php?169

Submitted by: [email-masked]
Headline: PostgreSQL 7.4.1 Released
Summary:

Its been almost 4 weeks since PostgreSQL 7.4 was released, and, as with
all new releases, several bugs have been identified as administrators
migrate their production databases up from older releases.

Story:

Its been almost 4 weeks since PostgreSQL 7.4 was released, and, as with
all new releases, several bugs have been identified as administrators
migrate their production databases up from older releases.

As the list of Changes since 7.4 is fairly small, they are included in
this email:

     * Fixed bug in \"CREATE SCHEMA\" parsing in ECPG (Michael)
     * Fix compile error when \"--enable-thread-safety\" and \"--with-perl\"
       are used together (Peter)
     * Fix for subqueries that used hash joins (Tom)
     * Fix free space map compaction bug (Tom)
     * Fix for Borland compiler build of libpq (Bruce)
     * Fix netmask() and hostmask() to return the maximum-length masklen
       (Tom)
     * Several \"contrib/pg_autovacuum\" fixes
     * Allow compile of \"contrib/cube\" under Cygwin (Jason Tishler)
     * Fix Solaris use of password file when no passwords are defined
       (Tom)
     * JDBC fix for thread problems, other fixes
     * Fix for bytea index lookups (Joe)
     * Fix information schema for bit data types (Peter)
     * Force zero_damaged_pages to be on during recovery from WAL
     * Prevent some obscure cases of \"variable not in subplan target
       lists\"
     * Make PQescapeBytea and byteaout consistent with each other (Joe)
     * Escape bytea output for bytes > 0x7e(Joe)
     * Added missing SPI_finish() calls to dblink\'s
       get_tuple_of_interest() (Joe)
     * New Czech FAQ
     * Fix information schema view constraint_column_usage for foreign
       keys (Peter)
     * ECPG fixes (Michael)
     * Fix bug with multiple IN subqueries and joins in the subqueries
       (Tom)
     * Alllow COUNT(\'x\') to work (Tom)
     * Install ECPG include files for Informix compatibility into
       separate directory (Peter)
     * Fix SSL memory leak (Neil)
     * Prevent \"pg_service.conf\" from using service name as default
       dbname (Bruce)
     * Fix local ident authentication on FreeBSD (Tom)

This version, as with most minor versions, does not require a dump/reload
to put into place.  That said, there are some changes to the information
schema that require a DROP/reload of that *specific* schema ... please
read the HISTORY file for instruction on how to do this.

As always, this release is available on all our mirrors, viable at:

        http://www.postgresql.org/mirrors-www.html

And, thanks to David Fetter, is also available via BitTorrent at:

        http://bt.postgresql.org

---

From: Archeron <[email-masked]>
Date: Tue, 23 Dec 2003 09:12:03 -0800

Hey all,
  Nothing serious, but a minor spelling glitch in that post.
 Alllow (count\'x\')... has one too many l's. 

Cheers and Merry Xmas/Happy New Year all.
 -Wade

On December 23, 2003 07:32, Robert Treat wrote:
> good point, updated and now clickable.
>
> Robert Treat
>
> On Tue, 2003-12-23 at 09:53, Andreas Grabmüller wrote:
> > Shouldn't it be mirrors-ftp.html instead of mirrors-www.html?
> >
> > Mit freundlichen Grüßen
> > Andreas Grabmüller
> >
> > ----- Original-Nachricht -----
> > Von: "[email-masked] (World Wide Web" <[email-masked]>
> > An: [email-masked]
> > Datum: Tuesday, December 23, 2003 03:32 PM
> > Betreff: [pgsql-www] New News Entry
> >
> > >      * Fix compile error when \"--enable-thread-safety\" and
> > > \"--with-perl\" are used together (Peter)
> > >      * Fix netmask() and hostmask() to return the maximum-length
> > > masklen (Tom)
> > > This version, as with most minor versions, does not require a
> > > dump/reload to put into place.  That said, there are some changes to
> > > the information schema that require a DROP/reload of that *specific*
> > > schema ... please read the HISTORY file for instruction on how to do
> > > this.
> > >
> > > ---------------------------(end of
> > > broadcast)--------------------------- TIP 9: the planner will ignore
> > > your desire to choose an index scan if your joining column's datatypes
> > > do not match
> >
> > --
> > LetzPlay.de
> >
> > | Freemail:       http://www.letzplay.de/mail
> > | Forenhosting: http://www.letzplay.de/foren
> >
> > ---------------------------(end of broadcast)---------------------------
> > TIP 1: subscribe and unsubscribe commands go to [email-masked]

-- 
This year I'm resolving to eat healthier, by eating vegans.

/"\   ASCII Ribbon Campaign  .
\ / - NO HTML/RTF in e-mail  .
 X  - NO Word docs in e-mail .
/ \ -----------------------------------------------------------------

---

From: Robert Treat <[email-masked]>
Date: 23 Dec 2003 16:20:24 -0500

Fixed, thanks.

Robert Treat

On Tue, 2003-12-23 at 12:12, Archeron wrote:
> TIP 6: Have you searched our list archives?
> 
>                http://archives.postgresql.org

-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL