Subject: New News Entry

From: [email-masked] (World Wide Web Owner)
Date: Tue, 16 Nov 2004 07:04:11 +0000 (GMT)

A new entry has been added to the news database.

Database Admin: http://www.postgresql.org/admin/edit_news.php?240

Submitted by: [email-masked]
Headline: phpPgAdmin 3.5 Released
Summary:

A new major version of phpPgAdmin is now available. phpPgAdmin is a web-based administration tool for all 7.x and the new 8.0 version of PostgreSQL.

Story:

A new major version of phpPgAdmin is now available. phpPgAdmin is a web-based administration tool for all 7.x and the new 8.0 version of PostgreSQL.

Major emphasis on this release is in supporting all the new 8.0 features.

New features include:

* Context-sensitive online help system
* Use language preferencies from browser (Markus Bertheau, Nicola Soranzo)
* Tablespace support for 8.0
* Support cancelling backend processes in 8.0
* Allow setting privileges on databases
* Allow setting schema search path in SQL window
* Allow filtering find results by object type
* Show function arguments in find results
* Support 8.0\'s named function arguments
* \"Sticky\" navigation.  phpPgAdmin will now remember while tab you are
  looking at (eg. \'Indexes\') when you change which table you are viewing.
* New fast navigation bar.  A breadcrumb style navigation bar for fast
  jumping between areas.
* Much improved grant/revoke feature
* Allow creating and viewing composite types
* pg_dumpall integration.  Now you can download the entire cluster via
  phpPgAdmin.
* Show line numbers when viewing functions
* Syntax highlighting for PL/SQL, PL/PgSQL, PL/PHP, PL/Ruby, PL/Java,
  PL/J, PL/Python and PL/Perl functions, thanks to Jacob D. Cohen\'s
  BSD-licensed highlighting code on rafb.net
* Add page navigation links at the bottom as well as the top of the page
  when browsing results.
* Support for 8.0\'s alter column type
* Support for 8.0\'s add columns with defaults and not null

New translations include:

* Romanian
* Arabic
* Hebrew
* Ukrainian
* Mongol

Download it now:

http://phppgadmin.sourceforge.net/?page=download

---

From: Michael Glaesemann <[email-masked]>
Date: Tue, 16 Nov 2004 16:38:36 +0900

> A new major version of phpPgAdmin is now available. phpPgAdmin is a 
> web-based administration tool for all 7.x and the new 8.0 version of 
> PostgreSQL.

Congrats, Chris! Already downloaded and installed! Looks spiffy!

Michael Glaesemann
grzm myrealbox com