Subject: New News Entry

From: [email-masked] (World Wide Web Owner)
Date: Mon, 23 Aug 2004 14:53:08 -0300 (ADT)

A new entry has been added to the news database.

Database Admin: http://www.postgresql.org/admin/edit_news.php?219

Submitted by: [email-masked]
Headline: Update Releases 7.2.5, 7.3.7, 7.4.5 Available, Recommended.
Summary:

The PGDG has released patch versions for the last 3 versions of PostgreSQL.   As the patches affect database recovery, upgrading is strongly recommended. (more ...)

Story:

Over the past week, we have bundled and released new versions of 7.2, 7.3 and 7.4 to address a couple of potentially critical bugs that were recently identified.

For all three versions, these releases address the following:

      * Prevent possible loss of committed transactions during crash.
	Due to insufficient interlocking between transaction commit and checkpointing, it was possible for transactions committed just before the most recent checkpoint to be lost, in whole or in part, following a database crash and restart.

Specific to 7.4, the following has also been fixed:

      * Repair possible crash during concurrent btree index insertions
        This patch fixes a rare case in which concurrent insertions into a btree index could result in a server panic. No permanent damage  would result, but it\'s still worth a re-release. The bug does not exist in pre-7.4 releases.

Due to the seriousness of the first bug, as relates to data integrity, it is strongly recommended that administrators upgrade their database servers at their earliest convience.

None of these releases require a dump-n-reload in order to address the problems.

It should be noted that, for those looking to upgrade from a 7.4.0/7.4.1 server to 7.4.5, that there a dump-n-reload is *recommended* (but not required) to address a fix introduced between 7.4.1 and 7.4.2.  Please refer to the 7.4.5 HISTORY file for information on how this can be accomplished without a dump-n-reload, as there are steps that can be followed for this.

Please download <a href =\"http://www.postgresql.org/mirror-ftp.html\"> from one of our mirror sites</a>, or <a href=\"http://bt.postgresql.org\">from  Bittorrent.</a>

As always, please report any bugs to [email-masked]

---

From: Devrim GUNDUZ <[email-masked]>
Date: Mon, 23 Aug 2004 20:57:01 +0300 (EEST)

Hi,

Thanks, approved.

Regards, Devrim

On Mon, 23 Aug 2004, World Wide Web Owner wrote:

> ---------------------------(end of broadcast)---------------------------
> TIP 3: if posting/reading through Usenet, please send an appropriate
>       subscribe-nomail command to [email-masked] so that your
>       message can get through to the mailing list cleanly
> 

-- 
Devrim GUNDUZ	       
devrim~gunduz.org				devrim.gunduz~linux.org.tr 
			http://www.tdmsoft.com
			http://www.gunduz.org