Subject: Re: [webmaster] Fw: Re: Fwd: Mirroring PostgreSQL.org in Israel]

From: "Dave Page" <[email-masked]>
Date: Fri, 31 Oct 2003 21:38:46 -0000

Hi Aric, 

I have added www2.il.postgresql.org to our mirror system. The DNS record
and rsync access will be automatically setup within the next few hours.
The system does not currently allow rsync access to subnets so I have
just added the 2 ip addresses specified below.

To get started, please create a virtual host on your server with the
hostname www2.il.postgresql.org. Note that apache can get upset if you
try this before the DNS record is in place. Once that is running, please
use rsync to populate your server with a copy of the content. This
should be run on a daily basis to keep up to date. We normally recommend
a command line something like:

rsync -avz --delete rsync.postgresql.org::pgsql-www
/path/to/vhost/docroot

Alternatively, you might try:

rsync -vzrltD --delete rsync.postgresql.org::pgsql-www
/path/to/vhost/docroot

Which was recommended to me today (I'd appreciate some feedback if you
try that). Once you have rsync'd, the system will automatically add your
mirror to our listings.

Re: the ftp mirror, unfortunately we cannot handle uid/pwd in the URLs
at present, but thanks for the offer anywy :-)

If you have any problems, please let me know.

Regards, Dave.

> -----Original Message-----
> From: Aric Fedida [mailto:[email-masked]] 
> Sent: 30 October 2003 03:11
> To: [email-masked]; [email-masked]
> Subject: [webmaster] Fw: Re: [pgsql-www] Fwd: Mirroring 
> PostgreSQL.org in Israel]
> 
> 
> Hi guys!
> 
> 
> > > IP address of mirror server
> 
> 192.115.107.100
> 
> > > Port number if non-standard
> 
> 80
> 
> > > Hostnames/ip addresses of 1 or 2 machines that you will 
> use to rsync 
> > > the site. For most sites this will be the same as the server.
> 
> 192.115.107.99 and 192.115.107.100
> I actually have the entire 192.115.107.* subnet.
> Maybe just allow 192.115.107.0/24 ?
> 
> > > In addition, ftp mirrors may have a path to the mirrored content.
> 
> I don't have anonymous FTP, however I can create a simple 
> default user/pass that can be public.
> (like ftp://pg:[email-masked]/)
> 
> > > In order for website mirrors to work, you must be able to setup a 
> > > virtual host on your server.
> 
> That's not an issue. Simply give me the virtual hostname to setup.
> 
> > > Please let us know what type of mirror (or both) you wish 
> to host, 
> > > and what the appropriate details are.
> 
> I'll host any mirror required. So far I understand the 
> options are http and ftp.
> So I can mirror both. However notice my remark about anon ftp...
> 
> 
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 1: subscribe and unsubscribe commands go to 
> [email-masked]
>

---

From: Robert Treat <[email-masked]>
Date: 05 Nov 2003 08:23:29 -0500

Hey Dave,

I'm not seeing this listed in either the ftp or web mirror pages. Is it
that the mirror isn't active yet or that we don't have an Israeli flag
to make it display? 

Robert Treat

On Fri, 2003-10-31 at 16:38, Dave Page wrote:
> ---------------------------(end of broadcast)---------------------------
> TIP 4: Don't 'kill -9' the postmaster

-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL

---

From: "Aric Fedida" <[email-masked]>
Date: Wed, 5 Nov 2003 16:14:20 -0800

I am actually using the mirror all the time. It's definitely active.
Probably just hasn't been added yet.

	Aric

-----Original Message-----
From: Robert Treat [mailto:[email-masked]] 
Sent: Wednesday, November 05, 2003 5:23 AM
To: Dave Page
Cc: Aric Fedida; [email-masked]
Subject: Re: [webmaster] Fw: Re: [pgsql-www] Fwd: Mirroring PostgreSQL.org
in Israel]

Hey Dave,

I'm not seeing this listed in either the ftp or web mirror pages. Is it that
the mirror isn't active yet or that we don't have an Israeli flag to make it
display? 

Robert Treat