Subject: Re: Another update on 'portal'

From: "Dave Page" <[email-masked]>
Date: Sat, 14 Feb 2004 09:32:24 -0000

> -----Original Message-----
> From: Alexey Borzov [mailto:[email-masked]] 
> Sent: 14 February 2004 08:34
> To: Dave Page
> Cc: [email-masked]
> Subject: Re: [pgsql-www] Another update on 'portal'
> 
> Well, it took you almost a week *not* to answer to the 
> previous --- polite --- email and less than an hour to answer 
> to the current one. See my point?

Not really. As I imagine many other ppl do, I set aside time on Fridays
to tie up outstanding items. Also like many of us, I have a job, family
and studies to worry about as well and don't always have time to answer
immediately.

> I consulted the pgsql-www archives and looked at some other 
> lists and have seen
> *lots* of polite website suggestions safely and comfortably ignored.

Not on pgsql-www I doubt. On other lists maybe, but then, *this* is the
web list, not them.

> Thus the srategy of writing politely definitely does not work 
> with PostgreSQL website team, and I see no real reason to 
> pursue it.

The strategy of writing to the right list and being polite does work.
The problem is that people do not forget when you annoyed them the week
before, so vanishing for a while and then coming back as if nothing
happened ain't gonna help.

Now, let's get this straight. Polite please from now on, and if no-one
responds to a message try a polite 'hey guys, I emailed but no one
responded' message. Any further unpleasentness may result in an
unsubscription.

Now, let's not discuss this any further and get back to developing the
website in whatever free time we can find.

Regards, Dave.

---

From: Alexey Borzov <[email-masked]>
Date: Sat, 14 Feb 2004 13:03:36 +0300

Hi!

> website in whatever free time we can find.

OK, thanks for another lesson in style.

Now back to developing:
1) Have you reviewed the changed 'portal' I posted?
2) Have you downloaded and reviewed the code?
3) What is your opinion? Are you ready to give me CVS access to pgweb and access 
to development server?
4) Is there any checklist for rolling out the "new" website?
5) Are you familiar with Jakob Nielsen's writings?
6) Do you know any professional web-designers?

---

From: "Dave Page" <[email-masked]>
Date: Sat, 14 Feb 2004 15:20:33 -0000 (GMT)

> 1) Have you reviewed the changed 'portal' I posted?

Yes, as I said in my earler reply.

> 2) Have you downloaded and reviewed the code?

No, I have not had time - that is why I asked Andreas for his opinion.

> 3) What is your opinion? Are you ready to give me CVS access to pgweb
> and access  to development server?

No. CVS access and user accounts are only given to people following
continued good quality work over a period of time.
> 4) Is there any checklist for rolling out the "new" website?

No - that depends very much on what is required to rollout any new code.

> 5) Are you familiar with Jakob Nielsen's writings?

Nope.

> 6) Do you know any professional web-designers?

Yes. Why?

Regards, Dave.

---

From: "Marc G. Fournier" <[email-masked]>
Date: Sat, 14 Feb 2004 14:09:00 -0400 (AST)

On Sat, 14 Feb 2004, Robert Treat wrote:

> Dave, I'm thinking we could probably put his code on a new virtual test
> domain, though I'd like to look through the code more before we get to that
> step, but it seems like a good next step...

In preparation for this, Alexey, is there anything that we need to have
installed?  Specific modules that will be needed?

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: Alexey Borzov <[email-masked]>
Date: Sat, 14 Feb 2004 22:01:30 +0300

Hi!

> installed?  Specific modules that will be needed?

Well, the only thing that comes to mind is that gettext module should be 
compiled into PHP.

Then PEAR should be installed as well (as HTML_Template_Sigma package is used). 
This can be done locally, but PHP 4.2+ is required nonetheless.

---

From: Alexey Borzov <[email-masked]>
Date: Sat, 14 Feb 2004 22:15:17 +0300

Hi!

Andreas Grabmüller wrote:
> When I saw Alexeys posts, I decided to not answer them - it's difficult for me to have an objective opinion as I simply don't like the way Alexey came in and said "everything you do sucks, what I do is the only right way you can do that". That makes me think "what the hell does that guy want from us?". However, let me try it.

You are unfair to yourself. While the code I inherited could use some 
optimisations (and I did optimise some parts of it) I mostly had just to 
refactor the existing code, it already worked OK.

> I have reviewed the code and it looks good - most of it seems to work, much of my code has been optimized.
> 
> I can't say if this code is good or this code is bad. He did the changes he stated in his mail, and they seem to work and the code techincally looks good (at least better than mine). The question is, do we want to have this changes? I like the template usage and the new path format page.html.{ln}. I personally don't like the usage of gettext as for me this seems to be overhead - before we had a php file containing all variables, now we have several .po etc. files which have to be edited by special software (I think?). All this is just a question of the personal point of view.

Yes, it is the matter of taste. The benefit of having .po files instead of .php 
files is (like I see it):
1) .po files are generated automatically and thus it is more difficult to have 
the translations that are out of sync due to programmer error.
2) It is not difficult to edit the .po files. There is some special software, 
but I just used the same PHPEdit to prepare the Russian translation, as if I was 
editing the plain text files.

---

From: Alexey Borzov <[email-masked]>
Date: Sat, 14 Feb 2004 22:21:15 +0300

Hi!

Robert Treat wrote:
> and people who we know we can work with in a non-abrasive manner.

Got the point. ;]

> step, but it seems like a good next step...   

Yes, that's exactly what I want right now --- look through my code.

> I am. Actually I used to be the user experience advocate for a large recruting 
> company.  I've noticed It's tough to convince developers to go with his 
> recomendations sometimes :-)

I wanted to know whether the people on this maillist are aware of "usability" 
stuff. 'Cause unfortunately the current website badly breaks some of the 
well-respected guidelines.

> maybe he has money to hire some one?  :-)

No, I don't. ;] But I think that there are some people on the maillists (or some 
personal acquaintances) who would be willing to contribute their work for free.

---

From: "Marc G. Fournier" <[email-masked]>
Date: Sat, 14 Feb 2004 15:54:24 -0400 (AST)

> This can be done locally, but PHP 4.2+ is required nonetheless.

Done ... and we run PHP 4.3.4 w/gettext by default, so you should be okay
there also ...

t1# pear install HTML_Template_Sigma
downloading HTML_Template_Sigma-1.0.2.tgz ...
...done: 25,765 bytes
install ok: HTML_Template_Sigma 1.0.2

----

---

From: Alexey Borzov <[email-masked]>
Date: Sun, 15 Feb 2004 10:31:08 +0300

Hi!

> install ok: HTML_Template_Sigma 1.0.2

OK then. Now what should we do: will you give me access to the box or should I 
prepare the sources for installation and send them to someone?