Subject: Re: Mirror how-to?

From: "Dave Page" <[email-masked]>
Date: Wed, 18 Feb 2004 10:35:44 -0000

> -----Original Message-----
> From: Devrim GUNDUZ [mailto:[email-masked]] 
> Sent: 18 February 2004 10:29
> To: Dave Page
> Cc: PostgreSQL WWW Mailing List; [email-masked]
> Subject: RE: [pgsql-www] Mirror how-to?
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> Hi Dave,
> 
> On Wed, 18 Feb 2004, Dave Page wrote:
> 
> <snip> 
> > www.tr doesn't currently exist, but is reserved for Gazi University.
> > Likewise, ftp4.tr is reserved for Idea Internet.
> 
> Ok, got it.
> 
> Anyway, the first try for rsync is ok now.
> 
> http://www.postgresql.web.tr/ looks perfect. I'll wait for 
> the DNS to announce the mirror to local lists.

Excellent - thanks!

/D

---

From: "Dave Page" <[email-masked]>
Date: Thu, 19 Feb 2004 12:38:35 -0000

> From: David Costa [mailto:[email-masked]] 
> Sent: 19 February 2004 08:43
> To: Dave Page
> Cc: PostgreSQL WWW Mailing List
> Subject: Re: [pgsql-www] Mirror how-to?
> 
> 
> 
> Hi Dave,
> just thinking lout, but on php.net they do limit 2 mirrors per country
> (4 for USA as the only exception I think).
> They do that for bandwidth purposes.
> 
> Furthermore, the php webmasters have a script to monitor when 
> a mirror goes down. If the downtime is over 1-2 days they 
> will remove it from the list and email the mirror owner.

Yes, we have a similar system.

> In your case they get automagically deleted from the live 
> list (as far as I understand) which is a good thing(r) I might 
> suggest that we email (I can help you with this, if needed) 
> the offline mirrors.

Hmm, that is a potentially tricky. /mirrors-ftp.php and -www.php both
include only mirrors that have sync'ed in the last 48 hours, however the
DNS build script includes all hosts that have sync'ed within 7 days
iirc. The main reason is to prevent dropping DNS records for sites that
are only offline for a short while.

The best bet would probably be to add a flag to the mirrors table. If
the last sync time goes past 48 hours ago, and the flag is not set, then
an email is sent and the flag set for that mirror to prevent further
messages. Whenever a mirror is sync'ed it's flag is unset.

That would require a script, and mods to the database (the unsetting of
the flag could be handled by a suitable trigger).

> I can also have the switch.ch Sunsite to mirror postgresql. 
> This might come handy because, as far as I can see, you do 
> not have a mirror in Switzerland. (Nothing urgent thou..)

There are, but they are both offline since 2004-02-01 :-(

Regards, Dave.