Subject: Re: Mirror how-to?

From: "Dave Page" <[email-masked]>
Date: Thu, 19 Feb 2004 08:28:34 -0000

> -----Original Message-----
> From: elein [mailto:[email-masked]] 
> Sent: 19 February 2004 04:11
> To: Devrim GUNDUZ
> Cc: Dave Page; PostgreSQL WWW Mailing List
> Subject: Re: [pgsql-www] Mirror how-to?
> 
> Can I take this and publish it more or less as is (perhaps 
> with the rsync command line, too, though) in an article 
> General Bits to promote more mirroring?

The final version is online now at
http://www.postgresql.org/mirrors-howto.html. Feel free to publish it,
but I must admit to starting to think that maybe we have enough mirrors
now - as I type there are 77 ftp mirrors and 49 web mirrors that are
active, and a lot more that are currently offline for whatever reason.
That's starting to be a lot of bandwidth just to keep them sync'ed up
and we know from a previous stats exercise that some of them get very
few hits. 

What do others think?

Regards Dave.

---

From: David Costa <[email-masked]>
Date: Thu, 19 Feb 2004 09:43:03 +0100

> and we know from a previous stats exercise that some of them get very

Hi Dave,
just thinking lout, but on php.net they do limit 2 mirrors per country 
(4 for USA as the only exception I think).
They do that for bandwidth purposes.

Furthermore, the php webmasters have a script to monitor when a mirror 
goes down. If the downtime is over 1-2 days they
will remove it from the list and email the mirror owner.

In your case they get automagically deleted from the live list (as far 
as I understand) which is a good thing®
I might suggest that we email (I can help you with this, if needed) the 
offline mirrors.

I can also have the switch.ch Sunsite to mirror postgresql. This might 
come handy because, as far as I can see,
you do not have a mirror in Switzerland. (Nothing urgent thou..)

Eventually there could be an "official rule" to limit the number of 
mirrors in a said country.

For the hits, I think that the general server load will be properly 
distributed when we will adopt the ip-2-country redirection. It would 
also be nice if the mirrors will keep at least one link
pointing to the mirror site in their own website (as we do on dotgeek). 
This will also help as a sort of promotion.

ta muchly
David Costa

>
> What do others think?
>
> Regards Dave.
>
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 4: Don't 'kill -9' the postmaster

---

From: elein <[email-masked]>
Date: Thu, 19 Feb 2004 10:33:25 -0800

If we really do not need more mirrors, it is not important
to publish this info.  A while back Marc, if I recall, was
soliciting more mirrors.  That is why I was suggesting it.
If we've reached our bandwidth limits, then it is not
an issue.

--elein 

On Thu, Feb 19, 2004 at 08:28:34AM -0000, Dave Page wrote:
> ---------------------------(end of broadcast)---------------------------