Subject: Re: Archives Search Broken

From: "Dave Page" <[email-masked]>
Date: Mon, 8 Mar 2004 14:09:44 -0000

> -----Original Message-----
> From: Dave Page 
> Sent: 08 March 2004 10:05
> To: Josh Berkus; [email-masked]
> Subject: Re: [pgsql-www] Archives Search Broken
> 
>  
> 
> > -----Original Message-----
> > From: Josh Berkus [mailto:[email-masked]]
> > Sent: 07 March 2004 22:53
> > To: [email-masked]
> > Subject: [pgsql-www] Archives Search Broken
> > 
> > Guys,
> > 
> > ASPSeek appears to be kaput.   Try this search:
> > 
> > http://archives.postgresql.org/s.cgi?q=Tablespaces&cs=utf-8&st
> > =7&ul=http%3A%2F%2Farchives.postgresql.org%2Fpgsql-hackers%2F%
> > 25&dt=back&dp=1m&o=0&ps=20
> > 
> > Returns nothing, even though there are approx 100 posts on 
> tablespaces 
> > in the last couple weeks.
> 
> Yes, very odd. I've emailled John about this.

Though strangely it now seems to work...

/D

---

From: Josh Berkus <[email-masked]>
Date: Mon, 8 Mar 2004 08:32:42 -0800

Dave,

> Though strangely it now seems to work...

I still get nothing.  I've tried on both Konqueror & Firefox in case it's a 
browser issue.   Odd thing is, the search returns in about 0.5 seconds ... 
which is *awfully* fast considering I'm on wireless.   It's like it's not 
even running a search, just immediately returning "no results".

AHA!   Found the problem, I think.   I was assuming that "in the last month" 
meant "in the last 30 days".    I think ASPSeek interprets "in the last 
month" to mean *this* month, i.e. March.   This would explain the results I'm 
getting for several queries.

-- 
-Josh Berkus

______AGLIO DATABASE SOLUTIONS___________________________
                                        Josh Berkus
   Complete information technology 	[email-masked]
    and data management solutions 	(415) 565-7293
   for law firms, small businesses 	 fax 651-9224
    and non-profit organizations. 	San Francisco

---

From: Robert Treat <[email-masked]>
Date: 08 Mar 2004 14:05:54 -0500

> getting for several queries.

I've been bitten by that before myself...though I didn't know it since I
gave up and went to a different search engine after a couple of
attempts.  I tend to agree with Josh's interpretation that in the last
month implies the last 30 days or some such similar timeframe. Can we
change the wording on that to maybe "in the current month" or "in this
month" or if we can get fancy just print the month name... "in March"..
though we'd need to rebuild any referencing pages once a month....  

Robert Treat
-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL

---

From: "Dave Page" <[email-masked]>
Date: Mon, 8 Mar 2004 19:33:41 -0000 (GMT)

It's rumoured that Robert Treat once said:
>> I still get nothing.  I've tried on both Konqueror & Firefox in case
>> it's a  browser issue.   Odd thing is, the search returns in about 0.5
>> seconds ...  which is *awfully* fast considering I'm on wireless.
>> It's like it's not  even running a search, just immediately returning
>> "no results".
>>
>> AHA!   Found the problem, I think.   I was assuming that "in the last
>> month"  meant "in the last 30 days".    I think ASPSeek interprets "in
>> the last  month" to mean *this* month, i.e. March.   This would
>> explain the results I'm  getting for several queries.

Nah, that's not it I don't think. It looks more to me like it's not
picking up newer posts - even if u pick last 3 months the newest it finds
is January.
I'll take a look tomorrow.

Regards, Dave.

---

From: "Marc G. Fournier" <[email-masked]>
Date: Mon, 8 Mar 2004 17:46:42 -0400 (AST)

> though we'd need to rebuild any referencing pages once a month....

Or, if possible, change it to a .php file and have it auto-changed via
simple php code ...

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664