Subject: Re: Update on 'portal' changes

From: "Dave Page" <[email-masked]>
Date: Mon, 8 Mar 2004 17:05:27 -0000

> -----Original Message-----
> From: Alexey Borzov [mailto:[email-masked]] 
> Sent: 08 March 2004 17:03
> To: Dave Page
> Cc: [email-masked]
> Subject: Re: [pgsql-www] Update on 'portal' changes
> 
> 
> Speaking of which, what is the real reason for keeping the 
> current website and the "next-generation" one in one project?
> 
> Maybe a better approach would be to register a separate 
> project for the next-generation website (I think this was 
> already proposed here)?

Because the project is for all the websites, not just the one you are
working on.

We *have* created a separate CVS module which should be more than enough
segregation.

Regards, Dave.

---

From: Alexey Borzov <[email-masked]>
Date: Mon, 08 Mar 2004 20:11:25 +0300

Hi!

> Because the project is for all the websites, not just the one you are

OK, let's paraphrase: what is the reason for having one project for all websites 
instead of one project per website? I got the impression that *different* 
developers work on different websites...

> We *have* created a separate CVS module which should be more than enough

Can CVS write access be given for this module only?

---

From: Josh Berkus <[email-masked]>
Date: Mon, 8 Mar 2004 09:45:48 -0800

Alexey,

> developers work on different websites...

Well, GForge/GBorg is seperate.  Techdocs should be generated by Bricolage.   
PGFoundation is apparently going to be seperate.  Advocacy should be going 
away as soon as the foundation gets its act together.   General Bits is 
hosted & adminned by Elein.   

What else is there?

-- 
-Josh Berkus
 Aglio Database Solutions
 San Francisco

---

From: Alexey Borzov <[email-masked]>
Date: Mon, 08 Mar 2004 23:49:27 +0300

Hi!

Josh Berkus wrote:
>>OK, let's paraphrase: what is the reason for having one project for all 
> 
> websites 
> 

Well, currently pgweb project has "This project is the development home of the 
PostgreSQL website, www.postgresql.org" as description, but its CVS has 
directories for current www.postgresql.org (www), techdocs, advocacy and dir for 
a "new" postgresql.org (portal).

I'd rather work on the "new" code in a separate project, where there would be no 
problems related to giving me CVS access to current code and where it would be 
possible to use available issue trackers.

BTW, why doesn't gborg accept new members?
http://gborg.postgresql.org/member/memjoin.php

---

From: Josh Berkus <[email-masked]>
Date: Mon, 8 Mar 2004 12:55:36 -0800

Alexey,

> http://gborg.postgresql.org/member/memjoin.php

Ooops!  This was temporary while we were copying users to the new PGFoundry; 
it needs to be turned back to regular with a warning.

-- 
-Josh Berkus

______AGLIO DATABASE SOLUTIONS___________________________
                                        Josh Berkus
   Complete information technology 	[email-masked]
    and data management solutions 	(415) 565-7293
   for law firms, small businesses 	 fax 651-9224
    and non-profit organizations. 	San Francisco

---

From: Chris Ryan <[email-masked]>
Date: Mon, 8 Mar 2004 13:20:06 -0800 (PST)

I'll echo the 'Ooops!'. Turned back on. Any suggestions about what
the message should be? Additionally project submissions were disabled.
Should these be turned back on as well?

Chris Ryan

--- Josh Berkus <[email-masked]> wrote:
> ---------------------------(end of
> broadcast)---------------------------
> TIP 7: don't forget to increase your free space map settings

__________________________________
Do you Yahoo!?
Yahoo! Search - Find what you’re looking for faster
http://search.yahoo.com

---

From: Josh Berkus <[email-masked]>
Date: Mon, 8 Mar 2004 13:24:43 -0800

Chris,

> Should these be turned back on as well?

No, I think new projects should say:

"We are currently planning on migrating from GBorg to a new development 
platform.   We expect to have the new site online in about a week.   Please 
hold your new project idea until then.   Contact josh (at) postgresql (dot) 
org for more information if you need it."

The new warning on GBorg members should wait until pgFoundry is live, and then 
say:

WARNING: members who join GBorg at this point will have to join pgFoundry 
seperately.

-- 
-Josh Berkus

---

From: Robert Treat <[email-masked]>
Date: 08 Mar 2004 18:16:48 -0500

> Well, GForge/GBorg is seperate.  Techdocs should be generated by Bricolage.  

speaking of do you have a status update on that?  a couple of weeks back
i mentioned doing an overhaul to the techdocs code in cvs and you said
not to bother since it was going away... well, it's still there, so can
I push forward with my cvs changes or are you pretty close to being
done?
 
> away as soon as the foundation gets its act together.   

Actually Advocacy is waiting on the next generation portal stuff... not
the foundation stuff. 

General Bits is 
> hosted & adminned by Elein.   

And it's a completely separate and independent site from the PostgreSQL
web teams sites... kind of like the plpgsql cookbook and oleg and
teodors fts search site. 

> What else is there?

"developer" which many are hoping to fold back into the main site once
the next generation portal is done. 

not to mention "archives" and search.... both of which should probably
be put under cvs at some point...

Robert Treat
-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL