Subject: Web code ...

From: "Marc G. Fournier" <[email-masked]>
Date: Mon, 10 May 2004 16:16:55 -0300 (ADT)

Our Database server is being pounded right now with >500 connections for
just 186_gborg and 186_pgsql ... figuring to take a quick look at the
code, can someone explain to me a few things?

in /usr/local/www/www.postgresql.org/www/globals.php, there are two
pconnects:

line 220:
  $db = @pg_pconnect($PortalDB);

  if (!$db) {
    header("Location: /unavailable.html\n\n");
    die;
  }

line 263:
$db = @pg_pconnect($GborgDB);

if (!$db)
{
        echo "We are currently experiencing technical difficulies, please
stand by.";
        die();
}

am I missing something, or does the second pconnect overwrite the first?
and, if so, doesn't that then leave a 'dangling' connection, or does it
know better?

Then, in index.php, you do *another* pconnect at line 3:

  $db = pg_pconnect($PortalDB);

and you have it all over the place from what I can tell here:

www# grep pconnect *
bugsub.php:  $db = pg_pconnect($PortalDB);
event-archive.php:  $db = pg_pconnect($PortalDB);
event.php:  $db = pg_pconnect($PortalDB);
globals.php:  $db = @pg_pconnect($PortalDB);
globals.php:$db = @pg_pconnect($GborgDB);
index.php:  $db = pg_pconnect($PortalDB);
mirrors-ftp.php:  $conn = @pg_pconnect($PortalDB);
mirrors-www.php:  $conn = @pg_pconnect($PortalDB);
news-archive.php:  $db = pg_pconnect($PortalDB);
news.php:  $db = pg_pconnect($PortalDB);
submission.php:  $db = pg_pconnect($PortalDB);
survey.php:  $db = pg_pconnect($PortalDB);

why not just one pconnect in global.php that everythign shares?

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: "Dave Page" <[email-masked]>
Date: Tue, 11 May 2004 10:01:12 +0100

> -----Original Message-----
> From: Marc G. Fournier [mailto:[email-masked]] 
> Sent: 10 May 2004 20:17
> To: [email-masked]
> Subject: [pgsql-www] Web code ...
> 
> 

There is now...

Regards, Dave.