Subject: Re: PGSQL-WINDOWS mailing list?

From: "Dave Page" <[email-masked]>
Date: Fri, 13 Aug 2004 08:13:20 +0100

> -----Original Message-----
> From: Robert Treat [mailto:[email-masked]] 
> Sent: 13 August 2004 06:48
> To: Marc G. Fournier
> Cc: Dave Page; Josh Berkus; PostgreSQL www
> Subject: Re: [pgsql-www] PGSQL-WINDOWS mailing list?
> 
> On Thursday 12 August 2004 18:16, Marc G. Fournier wrote:
> > On Thu, 12 Aug 2004, Dave Page wrote:
> > > The problem is, how do we make them read stuff without, 
> umm, making 
> > > them read stuff?
> >
> > If someone wants to submit text changes for the 'welcome 
> message' that 
> > is sent out when someone subscribes, maybe pointinng them 
> to various 
> > sources of info, that might help ... ?
> >
> 
> We don't currently have an FAQ for each list, maybe we should 
> start with that and mail that out whenever someone subscribes. 

Definitely not a bad idea to do anyway, but I'm thinking more along the
lines of helping ppl before they even get to the lists.

Regards, Dave.

---

From: Michael Glaesemann <[email-masked]>
Date: Fri, 13 Aug 2004 17:57:26 +0900

> lines of helping ppl before they even get to the lists.

Would it make sense to trim the faqs a bit? There's a lot of 
information in there, and people might be hesitant to dive into them. 
Of course, they *should* look at the faq, as there's a lot of good 
stuff in there, but then again, people should read the docs too.

Also, if you subscribe via the web interface, there's a link to view 
the faq, even before you subscribe. However, there are currently no 
faqs for the lists. This is a pretty visible place where people have 
the opportunity to read the faq, and often they're joining the list 
because they have a question. Perhaps we could head them off a few 
questions there?

Michael Glaesemann
grzm myrealbox com

---

From: Josh Berkus <[email-masked]>
Date: Fri, 13 Aug 2004 09:38:20 -0700

Guys,

> lines of helping ppl before they even get to the lists.

Unfortunately, I discussed the *best* way with Gavin Sherry yesterday -- which 
would be to have a "PostgreSQL on Windows" book.  But that would have had to 
been started about 6 months ago.  :-(   Still, if anyone here knows anyone 
who can write such a book, I can get you published.

Regarding Tom's comment, perhaps we should entertain the idea of Web Forums?  
For whatever reason, we found out at OOo that web forums (with enough speed, 
of course) hold up better under a load of 100 to 500 posts per day than 
mailing lists do, at least in terms of usability.

One of the Perl people is working on a combo web forum/mailing list software, 
but unfortunately the project just started ...

-- 
Josh Berkus
Aglio Database Solutions
San Francisco

---

From: Josh Berkus <[email-masked]>
Date: Fri, 13 Aug 2004 11:20:03 -0700

People,

> > lines of helping ppl before they even get to the lists.

Hmmmm ... I'm also thinking that we need an HTML PostgreSQL+Windows tutorial 
linked from the main page or at least the Documentation page.

-- 
-Josh Berkus
 "A developer of Very Little Brain"
 Aglio Database Solutions
 San Francisco

---

From: "Marc G. Fournier" <[email-masked]>
Date: Fri, 13 Aug 2004 15:47:51 -0300 (ADT)

Right now, I think its pretty safe to say that things are looking like the 
release will be *at least* 2 months away .. do we have a TODO list of what 
should be done by then, in preparation?  For instance, you mention below a 
Tutorial, but does one exist right now that can be linked in, or does one 
need to be created?

> linked from the main page or at least the Documentation page.

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 13 Aug 2004 23:04:32 -0400 (EDT)

> Tutorial, but does one exist right now that can be linked in, or does one 

We have:

---------------------------------------------------------------------------

                               P O S T G R E S Q L

                          8 . 0  O P E N    I T E M S

Current version at ftp://momjian.postgresql.org/pub/postgresql/open_items.

Changes
-------
* Win32
	o binary version stamps
	o signal safe socket handler
	o query cancel in psql (?)
        o Report correct errno codes from native Windows system calls
	o Shorten timezone for %t log_line_prefix
	o start pg_autovacuum easily
	o fix pitr file copy syntax
* fix dbsize and oid2name for tablespaces
* allow libpq to check parameterized data types
* make pgxs install the default
* add xid to log_line_prefix for PITR
* add psql tab completion for tablespaces
* cleanup FRONTEND use in /port, malloc, elog

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: "Marc G. Fournier" <[email-masked]>
Date: Sat, 14 Aug 2004 00:18:41 -0300 (ADT)

>> Tutorial, but does one exist right now that can be linked in, or does one

Oops, sorry, you mis-understood the question ... I was more looking at 
what the thread was talking about insofar as mailing lists, web sites, etc 
... stuff from the support side, not the technical :)

----

---

From: Tom Lane <[email-masked]>
Date: Fri, 13 Aug 2004 23:29:31 -0400

> 	o fix pitr file copy syntax

Isn't this done?

> * fix dbsize and oid2name for tablespaces

I thought you committed a dbsize patch already.

> * allow libpq to check parameterized data types

What is this?

Also, we have a number of unresolved pg_dump bugs (it's not improbable
that we might have to back out the patch to manage ownership via ALTER
OWNER) and I've been noticing quite a lot of Windows users reporting
that it can't recognize their timezone, which says that we're going to
need yet another re-think of that issue :-(

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 13 Aug 2004 23:33:44 -0400 (EDT)

> > 	o fix pitr file copy syntax

Yep, fixed.

> I thought you committed a dbsize patch already.

Yep, dbsize removed.

> > * allow libpq to check parameterized data types

Uh, that was related to Jan's thing about adding a libpq protocol
capability so libs can find the data type of prepared queries.

> that we might have to back out the patch to manage ownership via ALTER

Yes, I am tracking those but am not sure how to even explain them.

> need yet another re-think of that issue :-(

Added:

        o Fix users who's timezones are not recognized