Subject: Re: [#14748606] comp.databases.postgresql hierarchy

From: "Dave Page" <[email-masked]>
Date: Wed, 29 Sep 2004 08:32:41 +0100

Hi Google Team,

Thank you for your reply. The comp.databases.postgresql.* hierarchy has
been there for many years now. I am unaware of any duplicates, however,
if someone has replicated the hierarchy elsewhere, then it is that copy
that should be removed.

With regard to the traffic level, as one of the PostgreSQL webmasters I
can see over 350,000 posts in our private archives over the last 8 years
or so - on average that works out at over 100 messages per day for the
hierarchy; a figure that is probably substantially higher than that now
given that the groups started with very little traffic and have grown
and grown over the years.

I would appreciate it if you would review the decision to suspend this
hierarchy.

Regards, Dave.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: 29 September 2004 01:04
> To: Dave Page
> Subject: Re: [#14748606] comp.databases.postgresql hierarchy
> 
> Hi Dave, 
> 
> Thank you for your note. Typically when groups are tagged as 
> 'no longer archived' it is because there are duplicated 
> groups or the groups do not have substantial traffic.
> 
> If newsgroups are classified as 'no longer archived' they 
> can't be posted to through Google. However, we can review 
> groups for re-classification if petitioned by users.
> 
> Regards,
> The Google Team
> 
> Original Message Follows:
> ------------------------
> From: "Dave Page" <[email-masked]>
> Subject: comp.databases.postgresql hierarchy
> Date: Sat, 25 Sep 2004 22:47:08 +0100
> 
> Hi,
> 
> I found today that groups.google.com is no longer archiving the
> comp.databases.postgresql.* hierarchy of newsgroups. This is 
> an extremely important hierarchy to myself and to countless 
> other PostgreSQL users who rely on these groups for 
> discussion of the databases use and development, as evidenced 
> by the hundreds of message that can be posted on a daily basis.
> 
> I therefore respectfully ask that you reconsider your 
> decision to suspend archiving of this group hierarchy.
> 
> Regards, Dave.
> 
> --
> Dave Page
> Network & Systems Manager
> The Vale Housing Association
> 
>

---

From: [email-masked]
Date: Wed, 29 Sep 2004 13:55:01 -0700

Hi Dave, 

Thank you for the information you provided in your reply. We really
appreciate your feedback, and we'll keep it in mind as we work to improve
Google Groups.

Regards,
The Google Team

Original Message Follows:
------------------------
From: "Dave Page" <[email-masked]>
Subject: RE: [#14748606] comp.databases.postgresql hierarchy
Date: Wed, 29 Sep 2004 08:32:41 +0100

Hi Google Team,

Regards, Dave.

---

From: Josh Berkus <[email-masked]>
Date: Thu, 30 Sep 2004 09:47:16 -0700

Dave,

> appreciate your feedback, and we'll keep it in mind as we work to improve

This looks to me like they cut us off for ulterior reasons and are avoiding 
the topic.   Does it look that way to anyone else?

Is it time to hunt up members of the community who have contacts at google, or 
start an e-mail petition drive?

-- 
Josh Berkus
Aglio Database Solutions
San Francisco

---

From: "Marc G. Fournier" <[email-masked]>
Date: Thu, 30 Sep 2004 13:52:37 -0300 (ADT)

> the topic.   Does it look that way to anyone else?

I kinda read it as a 'form letter' response ...

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: Josh Berkus <[email-masked]>
Date: Thu, 30 Sep 2004 10:07:30 -0700

Marc,

> I kinda read it as a 'form letter' response ...

Is it possible that our lists-to-newsgroups gateway is broken?   Before I 
start getting pushy with Google, I want to make sure it's not our problem.

-- 
Josh Berkus
Aglio Database Solutions
San Francisco

---

From: Tom Lane <[email-masked]>
Date: Thu, 30 Sep 2004 13:12:49 -0400

> start getting pushy with Google, I want to make sure it's not our problem.

No, if you visit say

http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&group=comp.databases.postgresql.hackers

it says very clearly "This group is no longer archived".  They did cut
us off, for reasons they have not made clear.

			regards, tom lane

---

From: Josh Berkus <[email-masked]>
Date: Thu, 30 Sep 2004 10:42:00 -0700

Tom,

> us off, for reasons they have not made clear.

Certainly.   But one of the reasons they could cut us off is "inactivity", 
which would certainly occur if mailing list messages were no longer going 
through to the newsgroups.

Can someone check on NNTP to see that stuff is still gettng posted to the 
newsgroups?

-- 
--Josh

Josh Berkus
Aglio Database Solutions
San Francisco

---

From: "Marc G. Fournier" <[email-masked]>
Date: Thu, 30 Sep 2004 14:49:00 -0300 (ADT)

> start getting pushy with Google, I want to make sure it's not our problem.

Its actually redundant ... Oliver, in France, is running one also, same 
hierarchy, same message-ids, so that there are no duplicates .. so both 
would have to be broken at the same time ...

----

---

From: Josh Berkus <[email-masked]>
Date: Thu, 30 Sep 2004 10:54:41 -0700

Google Staff:

Our webmaster has brought it to my attention that you have stopped archiving 
comp.databases.postgresql.* for no apparent reason.    The staff he 
previously spoke with claimed that the stoppage was due to "duplication or 
inactivity", but:

1) There are no other sources for the PostgreSQL newsgroups anywhere on 
Google;
2) All of these lists are *extremely* active: for example, 
comp.databases.postgresql.hackers has had about 140 posts this week.

We have also checked to see if there might be some problem with the 
perpetuation of the postgresql newsgroups but our members are unable to 
discover any.

The e-mail exchanged with out webmaster implies that the Google staff is not 
interested in this problem and has no interest in doing anything to correct 
it.   I am sure that this must be a mistaken impression; could you please 
respond with some indication of how soon this is likely to be resolved?

-- 
--Josh Berkus

Josh Berkus
PostgreSQL Project Core Team
www.postgresql.org

---

From: Josh Berkus <[email-masked]>
Date: Thu, 30 Sep 2004 10:56:17 -0700

People:

E-mail sent to Google.    If we don't see any action in a couple of days, then 
I'll ask all of our community to e-mail them with requests to fix it.   That 
will certainly get their attention.

-- 
--Josh

Josh Berkus
Aglio Database Solutions
San Francisco

---

From: Tom Lane <[email-masked]>
Date: Thu, 30 Sep 2004 14:01:42 -0400

> would have to be broken at the same time ...

I don't believe that they really cut us off for inactivity, because they
have postings up through 16 Sept and we know that the cutoff occurred
then or within a very few days afterwards.

A different semi-legitimate reason for a cutoff is that, so far as I
know, the comp.databases.postgresql newsgroups never went through the
formal vote process to be recognized as legitimate mainstream
newsgroups.  Back when I was a netnews administrator for CMU, it was
common practice to refuse to carry groups that hadn't passed such a
vote, and I imagine it still is.  I haven't heard that Google is getting
strict about this (and they sure didn't mention it in their comments)
but if they are then we don't have much of a leg to stand on.

			regards, tom lane

---

From: Josh Berkus <[email-masked]>
Date: Thu, 30 Sep 2004 11:06:36 -0700

Tom,

> but if they are then we don't have much of a leg to stand on.

If that's the case, then, they should inform us and we can start a campaign.   
But right now we're getting the brushoff and we need to get their attention.

BTW, how would we go about organizing a legitimacy vote?   Who votes on this?

-- 
--Josh

Josh Berkus
Aglio Database Solutions
San Francisco

---

From: Tom Lane <[email-masked]>
Date: Thu, 30 Sep 2004 14:43:30 -0400

> BTW, how would we go about organizing a legitimacy vote?   Who votes on this?

I haven't paid attention to that stuff in nigh ten years, but there
is/was a very well-defined procedure to go through to propose a new
recognized newsgroup, and at least one newsgroup that deals solely in
processing such proposals.  Google for "newgroup vote" or some such and
you'll probably find all the details you could want.

			regards, tom lane

---

From: Josh Berkus <[email-masked]>
Date: Sat, 2 Oct 2004 16:22:57 -0700

Google Team,

Thank you for restoring archiving of the PostgreSQL newsgroups.   Our many 
users who rely on Google Groups to search for answers are delighted to have 
it back.

Thanks!

-- 
--Josh Berkus

Josh Berkus

(all opinions expressed are my own; I do not speak
 for the Project unless specifically noted.)