Subject: FTP mirror problems

From: "Greg Sabino Mullane" <[email-masked]>
Date: Sun, 7 Nov 2004 18:54:39 -0000

A bad link in the ftp source directory inspired me to check
the rest of it out:
 
* Main README file needs updating. The URL is given as:
 
http:/www.postgreSQL.org
 
but should be:
 
http://www.postgresql.org/
 
The copyright notice inside it is very old. There is no explanation
of the directory structure or telling people where to find things.
 
* README.cvsup is very old, possibly incorrect
 
* README.dist-split might want to mention the new "bz" and "md5" files.
 
* We are keeping some very old versions around: 1.08, 1.09, the entire 6
series. Is there any reason for this? For that matter, is there any reason
to keep around lesser versions in a tree, especially ones that were replaced
due to security bugs? Perhaps only keep the latest few versions and put a
note in the readme to point to "archives.postgresql.org" or something?
 
At the very least, a warning that some of the versions on the site have
serious security flaws would be warranted.
 
* /dev/interfaces seems to have only an old version of libpqxx
 
* /dev/contrib only contains earthdistance - why?
 
* /projects/gborg has some very old versions of some of the projects
therein. Is there a process to update these?
 
* The directory symlinked from /win32 should have a README. Perhaps
even a top-level README.WIN32 in anticipation of a lot of Windows users.
 
* The /src directory is missing 7.2.6 and 7.3.6
 
* /src/7.3.5 points to the wrong place (missing a "v")
 
* /source/7.2.5/v7.2.5 is a bogus link
 
* The use of HISTORY file is sporadic in the releases. Particularly,
all the latest branches are missing it.
 
* Why are we still using FTP mirrors? Most open source projects seem
to be using HTTP for download mirrors these days, and I for one would
find that more convenient.
 
* Specific mirror problems.
 
I went through and tested each of the ftp mirrors that appeared on the
page today. Some problems are probably transitory (e.g. timeouts) but
if anyone closer geographically (I'm in US) could test those, it would be
appreciated. No comment next to a mirror indicated that everything looked ok.
 
ftp4.ar
ftp.au
ftp2.au
ftp3.au: incorrect home directory
ftp.at
ftp.be
ftp.ba
ftp.br: connection refused
ftp2.br
ftp3.bg
ftp3.ca
ftp4.ca
ftp.cl
ftp.co
ftp2.cr
ftp.cz
ftp2.cz
ftp2.dk
ftp.ee
ftp.fr
ftp2.fr
ftp5.fr: connection refused
ftp.de
ftp2.de
ftp3.de
ftp7.de
ftp.gr
ftp2.gr
ftp.hk
ftp.hu: timeout + connection reset by peer
ftp3.hu
ftp2.is
ftp5.id: extra (old) dirs "NT_Support_Files" and "CVSup"
ftp7.id
ftp.ie
ftp2.ie
ftp2.il
ftp.it
ftp2.it
ftp5.it: connection refused
ftp6.it
ftp.jp
ftp.kr
ftp3.kr: has a ":80" in the url; when removed, works fine
ftp.lv
ftp.nl: times out
ftp.eu (listed as Netherlands, but goes against the naming scheme)
ftp2.nl
ftp4.nl
ftp.nz
ftp.no
ftp6.pl
ftp7.pl
ftp8.pl
ftp.pt: wrong home directory; usually times out too
ftp.pr
ftp6.ro
ftp.ru
ftp2.ru: incorrect login error
ftp3.ru
ftp5.ru: times out
ftp2.sk: extra (old) dirs "NT_Support_Files", "CVSup", plus many version symlinks
ftp4.es: times out
ftp5.es
ftp.se
ftp2.ch
ftp.tw
ftp3.tw
ftp5.tw
ftp6.tr
ftp2.uk
ftp3.us
ftp5.us: times out
ftp8.us
ftp9.us
ftp10.us: has many bogus ".message" files throughout
ftp13.us
ftp21.us
ftp22.us
ftp23.us: incorrect login error
ftp24.us

- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200411071350

---

From: "Marc G. Fournier" <[email-masked]>
Date: Tue, 9 Nov 2004 14:21:52 -0400 (AST)

On Sun, 7 Nov 2004, Greg Sabino Mullane wrote:

>
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
>

Huh?  Just checked, the file hasn't been modified since Nov 15th, 2001, 
and the URL looks fine to me:

svr1# grep http README
         http://www.postgreSQL.org
svr1#

> * README.cvsup is very old, possibly incorrect

have you tested this?  I last updated on Nov 3rd of this year, to reflect 
the reverting of the repository to overall state ... so if its incorrect, 
nobody has told me so ...

> * README.dist-split might want to mention the new "bz" and "md5" files.

If you would like to submit a re-write, I'll put it into place ... I think 
mentioning the bz files seperately would just bulk up the file ... ppl 
would see the .bz when they go to the directory itself ...

> serious security flaws would be warranted.

Historical, but we could easily create a source/OLD directory to move them 
into, so they are less prominent?

> * /dev/contrib only contains earthdistance - why?

removed both contrib and interfaces ... libpqxx is on gborg now, and 
earthdistances is back in the regular dev packages anyway ..

> therein. Is there a process to update these?

they are auto-updated from the gborg site, so that will have to be taken 
up with Chris ...

> even a top-level README.WIN32 in anticipation of a lot of Windows users.

Please feel free to submit one for inclusion (or anyone else, for that 
matter ... I'm only picking you out since you are pointing them out 
*grin*) ...

> * The /src directory is missing 7.2.6 and 7.3.6

fixed ...

> * /src/7.3.5 points to the wrong place (missing a "v")

fixed, and confirmed the rest were all link'd to the 'v' version ...

> * /source/7.2.5/v7.2.5 is a bogus link

fixed ...

> ftp23.us: incorrect login error

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: Robert Treat <[email-masked]>
Date: 09 Nov 2004 16:13:41 -0500

> into, so they are less prominent?

IMHO they should be left as is. I've certainly had to make use of older
versions of the software in the past, and would not presume to know when
others won't want them in the future.  We keep a link to "latest" in the
main directory, and I'm willing to believe most people are capable of
figuring out which is the latest 7.3.x branch on their own (at least
until I see evidence to the contrary).  

Robert Treat  
-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Wed, 10 Nov 2004 00:11:47 -0000

> versions of the software in the past,
 
Yeah, but version 6? Or 1.08?!? :)
 
> and would not presume to know when others won't want them in the future.
 
Sure, but there is no reason to tax the mirrors by having them keep all
those old versions. They would still be available non-mirrored to those
who wanted them (with a good README pointing the way). Keep in mind that
some of the releases are security releases and we do not want people under
any circumstance to be using them. So I would keep (for example) the highest
revision for each minor version in the 7.x series, and have a note telling
them where to find the older ones, and what was fixed that caused the
revision to jump.
 
- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200411091912

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Wed, 10 Nov 2004 00:25:17 -0000

>        http://www.postgreSQL.org
 
I though we tended to discourage making the 'postgre' and the 'SQL'
distinct. Lowercasing and a trailing slash and its perfect.
 
[README.cvsup]
> have you tested this?
 
Nope, I misread the modification time. All is well.
 
[README.dist-split]
> If you would like to submit a re-write, I'll put it into place ... I
> think mentioning the bz files seperately would just bulk up the file
> ... ppl would see the .bz when they go to the directory itself ...
 
Perhaps not everyone is familar with the .bz and and .md5 extensions.
A minor point, however. Perhaps it could just get rolled in with the new
README?
 
Thanks for taking care of the rest of the items. I'll [re]write a README[.win32]
if I get a chance, but I am currently swamped.
 
- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200411091925

---

From: "Marc G. Fournier" <[email-masked]>
Date: Tue, 9 Nov 2004 21:01:55 -0400 (AST)

> Yeah, but version 6? Or 1.08?!? :)

Actually, we had to do data recovery for a client using 6.x this past year 
*shrug*

----