Subject: busted commit :Add the developer link to main menu and pointer page with developer links

From: Robert Treat <[email-masked]>
Date: Sat, 13 Nov 2004 08:16:45 -0500

Last night I went to check in the developer link integration bits and got this 
nasty bit of errors back. I see the changes to common.html seem to have gone 
in ok, but the file developer.html is now appearing in the root directory of 
cvs outside of all the modules!  We need someone to move the file into it's 
proper place. If that's not possible I can re-add the file, but we still need 
someone to delete the extraneous file from cvsroot.

error message below:

-bash-2.05b$ cvs commit ../common.html developer.html
 
Add the developer link to main menu and pointer page with developer links
CVS: ----------------------------------------------------------------------
CVS: Enter Log.  Lines beginning with `CVS:' are removed automatically
CVS:
CVS: Committing in .
CVS:
CVS: Modified Files:
CVS:    ../common.html
CVS: Added Files:
CVS:    developer.html
CVS: ----------------------------------------------------------------------
~
 ~
/tmp/cvsadDUFr: 11 lines, 413 characters.
Checking in ../common.html;
/usr/local/cvsroot/pgweb/portal/template/common.html,v  <--  common.html
new revision: 1.7; previous revision: 1.6
done
Use of uninitialized value in string eq at /usr/local/cvsroot/bin/activitymail 
line 473.
RCS file: /usr/local/cvsroot/pgweb/developer.html,v
done
Checking in developer.html;
/usr/local/cvsroot/pgweb/developer.html,v  <--  developer.html
initial revision: 1.1
done
cvs diff: [05:59:08] waiting for cvsuser's lock 
in /usr/local/cvsroot/pgweb/portal/template
Use of uninitialized value in string eq at /usr/local/cvsroot/bin/activitymail 
line 161.
Use of uninitialized value in concatenation (.) or string 
at /usr/local/cvsroot/bin/activitymail line 443, <STDIN> line 5.
Use of uninitialized value in concatenation (.) or string 
at /usr/local/cvsroot/bin/activitymail line 443, <STDIN> line 5.
Use of uninitialized value in string eq at /usr/local/cvsroot/bin/activitymail 
line 473.
Use of uninitialized value in substitution (s///) 
at /usr/local/cvsroot/bin/activitymail line 378.
Use of uninitialized value in string eq at /usr/local/cvsroot/bin/activitymail 
line 379.
Use of uninitialized value in string eq at /usr/local/cvsroot/bin/activitymail 
line 379.
Use of uninitialized value in concatenation (.) or string 
at /usr/local/cvsroot/bin/activitymail line 395.
Use of uninitialized value in concatenation (.) or string 
at /usr/local/cvsroot/bin/activitymail line 395.
Use of uninitialized value in concatenation (.) or string 
at /usr/local/cvsroot/bin/activitymail line 395.
Use of uninitialized value in concatenation (.) or string 
at /usr/local/cvsroot/bin/activitymail line 395.
cvs [diff aborted]: no such tag -r
  
cvs diff: [05:59:38] obtained lock in /usr/local/cvsroot/pgweb/portal/template

-- 
Robert Treat
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL

---

From: Chris Ryan <[email-masked]>
Date: Mon, 15 Nov 2004 05:18:19 -0800 (PST)

Robert,

    I moved the file out of the way. Please recommit and let me know if
you are still getting errors.

Chris Ryan

> Add the developer link to main menu and pointer page with developer
----------------------------------------------------------------------
> CVS: Enter Log.  Lines beginning with `CVS:' are removed
----------------------------------------------------------------------
> /usr/local/cvsroot/pgweb/portal/template

__________________________________ 
Do you Yahoo!? 
Check out the new Yahoo! Front Page. 
www.yahoo.com

---

From: Robert Treat <[email-masked]>
Date: Mon, 15 Nov 2004 09:08:14 -0500

Crap!  seems a cvs update wiped away the file from my local copy, and the 
backup copy of the file I thought I had is actually the wrong file... any 
chance you still have a copy of the file that was put in CVS? Otherwise I'll 
have to redo it.   :-(

Robert Treat