Subject: Re: Counting clicks, Download page?

From: "Dave Page" <[email-masked]>
Date: Mon, 22 Nov 2004 09:54:18 -0000

-----Original Message-----
From: [email-masked] on behalf of Josh Berkus
Sent: Mon 11/22/2004 12:32 AM
To: Gavin M. Roy
Cc: [email-masked]
Subject: Re: [pgsql-www] Counting clicks, Download page?
 
Gavin,

> If we agree that it's something that
> we'll ask/require our mirrors to use on a crontab,

> We can ask, but only a few will cooperate.  Our biggest mirrors are university 
> sites who won't run anything -- at least, that's what I've been told.

Yes, thats what I've found in the past. Only the smaller mirrors will help out - mainly because they're run by fans of the project. The bigger ones mirror tens or even hundreds of sites, and simply don't start mucking about with stats for us.

Regards, Dave

---

From: "Dave Page" <[email-masked]>
Date: Tue, 23 Nov 2004 09:48:55 -0000

> From: Alexey Borzov [mailto:[email-masked]] 
> Sent: 22 November 2004 11:00
> To: Dave Page
> Cc: [email-masked]; [email-masked]
> Hi,
> Dave Page wrote:
> > Nope, not as it stands. Virtually everything is static HTML 
> now for speed and mirror-ability. If you want to log ftp 
> mirror selections, then it'll need to go back to being a php 
> script on one server, giving us a single point of failure on 
> perhaps the second most important part of the site (next to 
> the front page).
> 
> In fact the mirror selection page now *should* be a dynamic 
> page on one server only (and that's the main reason I am so 
> concerned about that server's performance).

Don't worry about that - it's in hand.

>  In any other case 
> you'll *not* be able to use ip2country.

As I vaguely seem to recall stating at the time it was implemented. It's
only a minor convenience thing (seeing as most ppl know their own
country), and puts both load on the server, and creates a single point
of failure.

> But current implementation of mirror selection will not give 
> any useful
> stats: it will only show how many people went to an FTP 
> mirror, not whether they actually downloaded something.

Agreed.

Regards, Dave.

---

From: "Dave Page" <[email-masked]>
Date: Tue, 23 Nov 2004 09:51:03 -0000

> From: Marc G. Fournier [mailto:[email-masked]] 
> Sent: 22 November 2004 16:25
> To: Dave Page
> I thought that all mirrors had a requirement to have php 
> enabled? 

No, not for years. And many now don't.

Regards, Dave.