Subject: Re: Wanted: Volunteer web developer for small project on www.postgresql.org

From: "Dave Page" <[email-masked]>
Date: Wed, 28 Sep 2005 22:11:54 +0100

> -----Original Message-----
> From: Gevik babakhani [mailto:[email-masked]] 
> Sent: 28 September 2005 22:01
> To: Dave Page; [email-masked]
> Subject: RE: [pgsql-www] Wanted: Volunteer web developer for 
> small project on www.postgresql.org
> 
> Dave,
> 
> Perhaps I can be of help as I am waiting for Gavin to update the
> framework.org.

Great, thanks Gevik.

> What do you think about having to type a random word 
> generated in an image
> before being able to submit anything?

Yes, that's exactly what I think we need, however, I think we need to
add that in a separate step, rather than on the initial form because
they will be served by the static servers:

- Static server serves form (in most cases this will be part of a doc
page, so serving forms from wwwmaster really isn't an option).
- User fills form and submits it to the script on wwwmaster.
- Server temporarily stores the submission - perhaps in a session
variable.
- wwwmaster generates the random word and sends it to the user on a
simple confirmation form.
- User submits confirmation form, and their original submission is
processed from the temporary storage.

Sound reasonable?

Regards Dave

---

From: "Gevik babakhani" <[email-masked]>
Date: Thu, 29 Sep 2005 00:21:52 +0200

Sounds very good. I will give it a start by gathering some info on this.

> From: Dave Page [mailto:[email-masked]]
> Sent: Wednesday, September 28, 2005 11:12 PM
> To: Gevik babakhani; [email-masked]
> Subject: RE: [pgsql-www] Wanted: Volunteer web developer for small project
> on www.postgresql.org
> 
> 
>

---

From: Robert Bernier <[email-masked]>
Date: Wed, 28 Sep 2005 18:25:55 -0400

I suggest you research the ImageMagick suite. It should give you everything 
you need.

On Wednesday 28 September 2005 18:21, Gevik babakhani wrote:
> > Subject: RE: [pgsql-www] Wanted: Volunteer web developer for small
> > project on www.postgresql.org
> >
> ---------------------------(end of broadcast)---------------------------
> TIP 3: Have you checked our extensive FAQ?
>
>                http://www.postgresql.org/docs/faq