Subject: Re: [HACKERS] Web page down (ad server)

From: "Magnus Hagander" <[email-masked]>
Date: Tue, 22 Nov 2005 11:23:58 +0100

> > > Turns out it's related to the ads, so if I just adblock the ad 
> > > server I can see the page just fine. Kind of bad it's 
> needed however 
> > > :-)
> > > 
> > > I also tried to show the page in opera and it looks the 
> same as in 
> > > firefox.
> > 
> > Intersting. It works fine for me. Did you try multiple 
> times? (Since 
> > you tried a different browser, I assume you did).
> 
> Of course. Maybe it's was some dns problem (all the adresses 
> seemed to resolve, but maybe some adress have been updated 
> but not propagated to all dns servers, or something. What do I know?).
> 
> As I said, I could solve it just fine by using adblock so 
> it's not a problem for me. I just wanted to tell someone about it.
> 
> I did try like 50 times during 30 minutes. Every time it got 
> stuck waiting on 200.46.208.156.

Aaahh. I missed that parto f your screenshot!

That means ads.hub.org was down, and it would wait until it timed out.

Marc - can we make that check async? Since you're updating the code
anyway, because it breaks website XHTML complicancy? Need any help with
the code?

//Magnus

---

From: "Marc G. Fournier" <[email-masked]>
Date: Tue, 22 Nov 2005 08:37:17 -0400 (AST)

Stupid question Dennis ... what time was this?  Early afternoon my time, 
we had an 'out of disk space' condition that forced me to restart the 
vServers on that machine ... wasn't thinking timezones ;(

> anyway, because it breaks website XHTML complicancy? Need any help with

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: Dennis Bjorklund <[email-masked]>
Date: Tue, 22 Nov 2005 17:11:36 +0100 (CET)

On Tue, 22 Nov 2005, Marc G. Fournier wrote:

> vServers on that machine ...

Around '2005-11-22 9:00:00 CET'. That would be sometime in the middle of
the night US time. I'll try to remember to get a traceroute the next time.

It's working now so it's not like it's a big problem.

-- 
/Dennis Björklund

---

From: "Marc G. Fournier" <[email-masked]>
Date: Tue, 22 Nov 2005 15:34:15 -0400 (AST)

> It's working now so it's not like it's a big problem.

The problem is that the javascript in the banner code is doing a 
document.write(), which is a sync call ... if there is a break anywhere in 
the network, or the ads server goes down for maintenance, it jams up the 
works ...

Does anyone know enough about Javascript to know how to re-write it so 
that its async instead of sync? :(

----