Subject: Re: [HACKERS] Upcoming PG re-releases

From: "Magnus Hagander" <[email-masked]>
Date: Wed, 30 Nov 2005 19:33:49 +0100

Someone suggested earlier that we should drop the binaries for
nonsupported versions completely from the ftp site. Thoughts on this?

If not, they should at least go into OLD as well. But personally, I'm
for dropping them completely. If you're on something that old (heck, we
have 7.0 binaries..), you can still build from source.

Speaking of which, any reason not to drop the 8.1 beta win32 binaries?

//Magnus

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Marc G. Fournier
> Sent: Wednesday, November 30, 2005 7:31 PM
> To: Robert Treat
> Cc: [email-masked]; [email-masked]; 
> Tom Lane; Andrew Dunstan
> Subject: Re: [pgsql-www] [HACKERS] Upcoming PG re-releases
> 
> 
> Done, as well as moved all but the last two of each version after ...
> 
> 
> On Wed, 30 Nov 2005, Robert Treat wrote:
> 
> > On Wednesday 30 November 2005 11:40, Tom Lane wrote:
> >> Personally I expect to keep supporting 7.3 for a long 
> while, because 
> >> Red Hat pays me to ;-) ... and the EOL date for RHEL3 is a 
> long way away yet.
> >> The PG community may stop bothering with 7.3 releases 
> before that.  
> >> But I think Marc and Bruce figure "as long as the patches 
> are in our 
> >> CVS we may as well put out a release".
> >>
> >
> > Yeah, thats one of the reasons I am skeptical about having official 
> > policies on this type of thing.  If Sun decided they wanted to 
> > maintain 7.2 and were going to dedicate developers and 
> testing for it, 
> > would we really turn that away?  OK, I don't really want to 
> have this 
> > discussion again, but as of now I think we are all agreed 
> that 7.2 is unsupported.
> >
> >> We hashed all this out in the pghackers list back in August, but I 
> >> agree there ought to be something about it on the website.
> >>
> >
> > We've been kicking it around but haven't moved much on this...
> >
> > Marc, can you move the 7.2 branches in the FTP under the 
> OLD directory?
> > http://www.postgresql.org/ftp/source/
> >
> > We need to do the same with 7.2 documentation, moving them into the 
> > Manual Archive 
> http://www.postgresql.org/docs/manuals/archive.html.  
> > We can also change the caption on the main documentation 
> page to note 
> > these are manuals for the current supported versions.
> >
> > --
> > Robert Treat
> > Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL
> >
> > ---------------------------(end of 
> > broadcast)---------------------------
> > TIP 2: Don't 'kill -9' the postmaster
> >
> 
> ----
> Marc G. Fournier           Hub.Org Networking Services 
> (http://www.hub.org)
> Email: [email-masked]           Yahoo!: yscrappy             
>  ICQ: 7615664
> 
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 9: In versions below 8.0, the planner will ignore your desire to
>        choose an index scan if your joining column's datatypes do not
>        match
>

---

From: "Marc G. Fournier" <[email-masked]>
Date: Wed, 30 Nov 2005 14:39:03 -0400 (AST)

'k, moved it all into OLD as well ... haven't removed anything until more 
opt in on this ... I do agree that if you really want that old, you can 
build from scratch, but I'm also not the one that went to the trouble of 
building the binaries :)

>>        choose an index scan if your joining column's datatypes do not

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: Robert Treat <[email-masked]>
Date: 30 Nov 2005 13:59:35 -0500

> have 7.0 binaries..), you can still build from source.

I'm against the idea... the cost for us is minimal, and the hassle
involved in building from source is quite large. 

Robert Treat

---

From: Robert Bernier <[email-masked]>
Date: Wed, 30 Nov 2005 17:31:18 -0500

> > nonsupported versions completely from the ftp site. Thoughts on this?

I'm for keeping them in some sort of archive for historical reasons. My feeling is that somewhere down the road this will be a big deal.

Robert Bernier

---

From: Tom Lane <[email-masked]>
Date: Wed, 30 Nov 2005 17:39:37 -0500

"Joshua D. Drake" <[email-masked]> writes:
> On Wed, 2005-11-30 at 17:31 -0500, Robert Bernier wrote:

> We always have the CVS repo, so if we remove them... not big deal.

It's not necessarily that easy to rebuild old releases --- for instance,
modern versions of bison will spit up on our older grammar files, due to
carelessness about semicolons; and newer C compilers may complain about
things that older ones let pass, too.

Unless we're feeling short of disk space on the server, I'm for leaving
them there somewhere.  But definitely mark them old and not-recommended.

			regards, tom lane

---

From: "Joshua D. Drake" <[email-masked]>
Date: Wed, 30 Nov 2005 14:41:49 -0800

> Robert Bernier
> 
> ---------------------------(end of broadcast)---------------------------
-- 
The PostgreSQL Company - Command Prompt, Inc. 1.503.667.4564
PostgreSQL Replication, Consulting, Custom Development, 24x7 support
Managed Services, Shared and Dedicated Hosting
Co-Authors: PLphp, PLperl, ODBCng - http://www.commandprompt.com/

---

From: Richard Huxton <[email-masked]>
Date: Thu, 01 Dec 2005 10:06:12 +0000

> involved in building from source is quite large. 

I don't have a need for an old PG binary. But when I have needed really 
old binaries it's always been in the middle of the night, in front of a 
machine with a teletype terminal, in the dark, surrounded by wolves 
while a timer ticks into the red... Locating the right versions of 17 
different libraries and compiling from source is always my second choice.

If it's practical to keep them, I'd like to suggest doing so. If it's 
not practical, could we have a where_to_find_old_versions.txt file and 
open a project on sourceforge to keep them?

-- 
   Richard Huxton
   Archonet Ltd

---

From: Euler Taveira de Oliveira <[email-masked]>
Date: Thu, 1 Dec 2005 07:35:42 -0300 (ART)

> open a project on sourceforge to keep them?
What about an museum.postgresql.org to keep the old releases?

Euler Taveira de Oliveira
euler[at]yahoo_com_br

	
		
_______________________________________________________ 
Yahoo! doce lar. Faça do Yahoo! sua homepage. 
http://br.yahoo.com/homepageset.html

---

From: Peter Eisentraut <[email-masked]>
Date: Thu, 1 Dec 2005 13:09:58 +0100

> What about an museum.postgresql.org to keep the old releases?

That gave me a good laugh, but there is something to be said about moving all 
no longer supported releases (according to the criteria that are being 
discussed) to an unmirrored site, say, archive.postgresql.org.

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

---

From: Csaba Nagy <[email-masked]>
Date: Thu, 01 Dec 2005 13:20:49 +0100

Maybe "mausoleum" would be even better name :-D

Cheers,
Csaba.

On Thu, 2005-12-01 at 11:35, Euler Taveira de Oliveira wrote:
> TIP 1: if posting/reading through Usenet, please send an appropriate
>        subscribe-nomail command to [email-masked] so that your
>        message can get through to the mailing list cleanly

---

From: Richard Huxton <[email-masked]>
Date: Thu, 01 Dec 2005 12:37:41 +0000

> Maybe "mausoleum" would be even better name :-D

Come on people, it's clearly: elephants-graveyard.postgresl.org

-- 
   Richard Huxton
   Archonet Ltd

---

From: "Marc G. Fournier" <[email-masked]>
Date: Thu, 1 Dec 2005 13:00:59 -0400 (AST)

> discussed) to an unmirrored site, say, archive.postgresql.org.

That would be fairly trivial ... let me add it to the 'todo list' ... I 
take it that it would be safe to relegate the /pub/source/OLD stuff there 
too?

----