Subject: Re: Launching PostgreSQL KB Project Mark 2

From: "Dave Page" <[email-masked]>
Date: Fri, 2 Dec 2005 22:20:20 -0000

-----Original Message-----
From: "Joshua D. Drake"<[email-masked]>
Sent: 02/12/05 22:07:54
To: "Dave Page"<[email-masked]>
Cc: "[email-masked]"<[email-masked]>, "[email-masked]"<[email-masked]>, "[email-masked]"<[email-masked]>
Subject: Re: [pgsql-www] Launching PostgreSQL KB Project Mark 2

> When did you start wearing pants to the office ;)

Well, the British answer would be 'when the boxers started chafing (sp?)', but I guess the US-friendly version would have to be something like 'after scaring three ppl to death, and the boss decided the insurance was getting too high'

:-O

/D

-----Unmodified Original Message-----

> > > Does this mean I can't join all you hipsters on that other list now?
> 
> > That's "you squares".  ;-)
> 
> Hey, watch who you call square - I've got long hair *and* I wear jeans to the office :-p

When did you start wearing pants to the office ;)

> 
> /D
> 
> -----Unmodified Original Message-----
> Robert,
> 
> > Does this mean I can't join all you hipsters on that other list now?
> 
> That's "you squares".  ;-)
> 
-- 
The PostgreSQL Company - Command Prompt, Inc. 1.503.667.4564
PostgreSQL Replication, Consulting, Custom Development, 24x7 support
Managed Services, Shared and Dedicated Hosting
Co-Authors: PLphp, PLperl, ODBCng - http://www.commandprompt.com/

---

From: "Dave Page" <[email-masked]>
Date: Fri, 2 Dec 2005 22:54:17 -0000

-----Original Message-----
From: "Gavin M. Roy"<[email-masked]>
Sent: 02/12/05 22:29:52
To: "Robert Treat"<[email-masked]>
Cc: "Dave Page"<[email-masked]>, "Josh Berkus"<[email-masked]>, "[email-masked]"<[email-masked]>
Subject: Re: [pgsql-www] Launching PostgreSQL KB Project Mark 2

> I mentioned this to Josh off-list but I am concerned about  
> introducing yet another technology platform (.net) for PgSQL based  
sites.  

Yes, I raised this as well, however if only the backend cms is build on .net or something, and docs are pushed to us in the proper template format for the website, I'm less concerned. 

The 2 things I think are essential are:

- The user site should be fully integrated with the existing site so it mirrors etc.

- Anything that is actually on the main site is either pushed to us in template format, or built and integrated in php.

Regards, Dave

-----Unmodified Original Message-----
I mentioned this to Josh off-list but I am concerned about  
introducing yet another technology platform (.net) for PgSQL based  
sites.  Trying to track down an issue with borg the other day where  
something was exploited web software wise, (and seeing how much  
"stuff" was on the vm) I would say we should be concerned with  
consolidating, not expanding technology dependencies.  I know svr2 is  
getting cleaned up, but this is more of a philosophy thing.  Can  
Alexy's framework that runs the main pgsql site work for techdocs/ 
knowledge base?  If not what's wrong with it?  Framewerk is nearly  
mature enough to be used, but I won't have the time for the next 2  
months or more to head up or be a primary programmer on something  
like this.  I can however offer help and support on the project if  
Framewerk is going to be used.  If you're interested in knowing where  
things are at and what's outstanding for evaluation: http:// 
svn.framewerk.org/trac.cgi/wiki/Issues - I am proposing this because  
unlike moving to .net we already use PHP pretty much everywhere else  
(other than the existing techdocs).  I would also offer that unifying  
the technology used for all the official pgsql sites would be a very  
nice thing.

Regards,

Gavin

On Dec 2, 2005, at 2:08 PM, Robert Treat wrote:

> On Fri, 2005-12-02 at 16:58, Dave Page wrote:
>>
>>
>> From: "Josh Berkus"<[email-masked]>
>> Sent: 02/12/05 21:36:51
>> To: "Robert Treat"<[email-masked]>
>> Cc: "[email-masked]"<[email-masked]>
>>> Gee, and you wondered why I thought we need a seperate mailing  
>>> list?  This
>>> sort of response is *exactly* why.
>>
>> Trying desparately not to say "I told you so" I very much doubt  
>> you have got this response had you raised this here in the first  
>> place and not later when persuaded to do so.
>>
>> Now, perhaps we can put the rocky start to one side and get on  
>> with building a knowledgebase?
>>
>
> Apparently not on this list we can't...
>
>
> Robert Treat
> -- 
> Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL
>
>
> ---------------------------(end of  
> broadcast)---------------------------
> TIP 3: Have you checked our extensive FAQ?
>
>                http://www.postgresql.org/docs/faq

Gavin M. Roy
800 Pound Gorilla
[email-masked]

---

From: "Dave Page" <[email-masked]>
Date: Tue, 6 Dec 2005 08:25:45 -0000

> From: Josh Berkus [mailto:[email-masked]] 
> Sent: 06 December 2005 05:24
> To: Marc G. Fournier
> Cc: Robert Treat; Dave Page; [email-masked]
> Marc,
> > Basically, if Josh et al wish to develop a KB outside of 
> the community, 
> > there is nothing stopping the community from developing 
> their own within 
> > it *shrug*
> 
> IN WHAT WAY is pgFoundry "outside the community"?

It's kinda like discussing development of the JDBC driver on the
pgInstaller project site. It's a community site for sure, but it's quite
clearly still not the appropriate place the the JDBC part of the
community.

Do you remember the number of people for various places that were irked
by being told to go and discuss certain aspects of backend development
on the Bizgres list? This is pretty much the same problem, only it's
even harder to see how the Kenninsgres list *is* the right place to
decide (amongst other things) what CMS to use. It's akin to using the
Microsoft Office news group to discuss whether to use MS Word or KWord!

Regards, Dave.

---

From: "Dave Page" <[email-masked]>
Date: Tue, 6 Dec 2005 09:11:52 -0000

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Magnus Hagander
> Sent: 06 December 2005 08:57
> To: Marc G. Fournier
> Cc: [email-masked]
> Not at all. Work is progressing as we speak, and has for a 
> while (though
> it was temporarily interrupted when Gevik was working on it the first
> time - before taking the timeout).
> 
> But this is *just a techdocs replacement*, not a whizz-bang KB. It
> fulfills the techdocs requirements for easy editing and searching, and
> the communitys erquirements for easy maintenance. It does not fullfill
> all the other KB requiremetns (I'm sure, though I haven't 
> seen teh whole
> list since it's not finished - but there are definitly several that
> aren't). It places the bar a lot lower, making it easier to 
> get done...
> 
> No, there's still no ETA on it, but it shouldn't be too far off. The
> hardest part tends to be figuring out how the CSS stuff on our site is
> actually meant to work, because there are no docs about that.

Err, your work is the techdocs replacement. Gevik was working on the KB
interface (the treeview thingy, with CMS behind it).

Regards, Dave.

---

From: "Magnus Hagander" <[email-masked]>
Date: Tue, 6 Dec 2005 10:21:12 +0100

> > Not at all. Work is progressing as we speak, and has for a while 
> > (though it was temporarily interrupted when Gevik was working on it 
> > the first time - before taking the timeout).
> > 
> > all the other KB requiremetns (I'm sure, though I haven't seen teh 
> > whole list since it's not finished - but there are 
> definitly several 
> > that aren't). It places the bar a lot lower, making it 
> easier to get 
> > done...
> > 
> Err, your work is the techdocs replacement. Gevik was working 
> on the KB interface (the treeview thingy, with CMS behind it).

Yes. Thats what I meant :-) My work was interrupted while Gevik was
working on the initial PGDN stuff, when it looked like he would be done
fairly quickly. I resumed later, when it no longer looked to be as
quick.

//Magnus