Subject: Re: Searches resulting in 414 Request URI too long

From: "John Hansen" <[email-masked]>
Date: Sat, 21 Jan 2006 19:42:52 +1100

Should be fixed now,.... 

... John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Michael Fuhr
> Sent: Saturday, January 21, 2006 9:19 AM
> To: [email-masked]
> Subject: [pgsql-www] Searches resulting in 414 Request URI too long
> 
> A few times in the past day I've gotten 414 (Request URI too 
> long) errors while searching through the mailing list 
> archives.  I haven't figured out a 100% repeatable test case 
> yet, but you can eventually see what's happening by doing the 
> following:
> 
> 1. Go to http://archives.postgresql.org/
> 
> 2. Search for something (e.g., "foo").
> 
> 3. Move between result pages by clicking Next, Previous, or one of
>    the page numbers.  Do this several times and eventually the URI
>    gets excessively long.  Sometimes it happens right away but
>    sometimes it requires numerous clicks.
> 
> The A tags for the result pages' links go from something like
> 
> <a href="?q=foo&cs=utf-8&fm=on&gr=off&st=20&np=1">
> 
> to
> 
> <a 
> href="?q=foo&ul=http%3A%2F%2Farchives.postgresql.org%2Fpgsql-b
ugs%2F%25&cs=utf-8&fm=on&gr=off&st=20&np=2">
> 
> and then they get longer, with numerous instances of "ul=...".
> Eventually they get too long and the web server responds with
> 414 Request URI too long.
> 
> --
> Michael Fuhr
> 
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 6: explain analyze is your friend
> 
>

---

From: Michael Fuhr <[email-masked]>
Date: Sat, 21 Jan 2006 21:40:14 -0700

> Should be fixed now,.... 

Nope -- I'm still seeing the behavior I reported.  Sometimes it
takes a while, but eventually the links' query strings contain
several ul variables.  All I'm doing is clicking on Previous, Next,
and the page numbers.

-- 
Michael Fuhr