Subject: Searches resulting in 414 Request URI too long

From: Michael Fuhr <[email-masked]>
Date: Fri, 20 Jan 2006 15:19:10 -0700

A few times in the past day I've gotten 414 (Request URI too long)
errors while searching through the mailing list archives.  I haven't
figured out a 100% repeatable test case yet, but you can eventually
see what's happening by doing the following:

1. Go to http://archives.postgresql.org/

2. Search for something (e.g., "foo").

3. Move between result pages by clicking Next, Previous, or one of
   the page numbers.  Do this several times and eventually the URI
   gets excessively long.  Sometimes it happens right away but
   sometimes it requires numerous clicks.

The A tags for the result pages' links go from something like

<a href="?q=foo&cs=utf-8&fm=on&gr=off&st=20&np=1">

to

<a href="?q=foo&ul=http%3A%2F%2Farchives.postgresql.org%2Fpgsql-bugs%2F%25&cs=utf-8&fm=on&gr=off&st=20&np=2">

and then they get longer, with numerous instances of "ul=...".
Eventually they get too long and the web server responds with
414 Request URI too long.

-- 
Michael Fuhr

---

From: "John Hansen" <[email-masked]>
Date: Sun, 22 Jan 2006 22:33:34 +1100

Okay,...

Seems the apache module is faulty... :(
Switched to cgi while I hunt for the bug...

Let me know if the cgi has the same fault,. Tho it doesn't look like it...

... John

> -----Original Message-----
> From: Michael Fuhr [mailto:[email-masked]] 
> Sent: Sunday, January 22, 2006 3:40 PM
> To: John Hansen
> Cc: [email-masked]
> Subject: Re: [pgsql-www] Searches resulting in 414 Request 
> URI too long
> 
> On Sat, Jan 21, 2006 at 07:42:52PM +1100, John Hansen wrote:
> > Should be fixed now,.... 
> 
> Nope -- I'm still seeing the behavior I reported.  Sometimes 
> it takes a while, but eventually the links' query strings 
> contain several ul variables.  All I'm doing is clicking on 
> Previous, Next, and the page numbers.
> 
> --
> Michael Fuhr
> 
>