Subject: Re: search.postgresql.org

From: "Dave Page" <[email-masked]>
Date: Sat, 25 Mar 2006 23:10:37 -0000

-----Original Message-----
From: "Oleg Bartunov"<[email-masked]>
Sent: 25/03/06 20:49:25
To: "Dave Page"<[email-masked]>
Cc: "[email-masked]"<[email-masked]>, "[email-masked]"<[email-masked]>, "[email-masked]"<[email-masked]>
Subject: Re: [pgsql-www] search.postgresql.org

> Also, is't possible to group results by sites

It does, when appropriate.

>  ? This could soften effect of incorrect 
> ranking. At  www.pgsql.ru/db/pgsearch we > have no  manual weight correction and 
> trust authors of web pages.

The config being shown is the one used for the main www.postgresql.org site search, thus results from that site are favoured over external sites. The archives are ranked even lower because of the potential for additional noise.

www.pgsql.ru is a generic search where lack of weightings and trusting authors makes sense. search.postgresql.org provides site searches aimed at users coming from different perspectives of our site network and we compliment the site results with the external results for added value.

Regards, Dave

-----Unmodified Original Message-----
I don't understand all this thread. Manual intervention brings to nothing
all search engine ranking and usually produce very bad results.
Is't possible to use citations ?

Also, is't possible to group results by sites ? This could soften effect
of incorrect ranking. At www.pgsql.ru/db/pgsearch we have no manual 
weight correction and trust authors of web pages.

 	Oleg

On Sat, 25 Mar 2006, Dave Page wrote:

>
>
> -----Original Message-----
> From: "Joshua D. Drake"<[email-masked]>
> Sent: 25/03/06 16:53:27
> To: "Tom Lane"<[email-masked]>
> Cc: "PostgreSQL WWW"<[email-masked]>
> Subject: Re: [pgsql-www] search.postgresql.org
>
>> It seems to me that archives should be secondly only to
>> www.postgresql.org.
>
> I disagree - the web search is intended to favour factual sites over the archives which may contain incorrect info. If you want to search the archives only you still can.
>
>> Once the new techdocs is live and we get some solid
>> content on there, then we can push that up.
>
> That is on www so will have the same rating.
>
> /D
>
> -----Unmodified Original Message-----
>
>> Um, what other resources are rated higher?  If you'll pardon my
>> ignorance, what other resources is the search engine considering at all?
>
> Below is the weights. As John said earlier they just decide who's links
> show up first.
>
> It seems to me that archives should be secondly only to
> www.postgresql.org. Once the new techdocs is live and we get some solid
> content on there, then we can push that up.
>
> Thoughts?
>
>
>
> SiteWeight http://www.postgresql.org/ 100
> SiteWeight http://advocacy.postgresql.org/ 100
> SiteWeight http://jdbc.postgresql.org/ 100
> SiteWeight http://developer.postgresql.org/ 100
>
> # Authoritiative project site
> SiteWeight http://gborg.postgresql.org/ 75
> SiteWeight http://pgadmin.postgresql.org/ 75
> SiteWeight http://phppgadmin.sourceforge.net/ 75
> SiteWeight http://pgfoundry.org/ 75
>
> # User contributed stuff
> SiteWeight http://techdocs.postgresql.org/ 50
> SiteWeight http://archives.postgresql.org/ 50
>
> # Outside but reliable
> SiteWeight http://www.varlena.com/ 25
>
> # And the rest...
> SiteWeight http://www.postgresql.cl/ 0
> SiteWeight http://postgresql.ok.cz/ 0
> SiteWeight http://www.postgresql.jp/ 0
> SiteWeight http://www.postgresqlfr.org/ 0
> SiteWeight http://www.linuxshare.ru/ 0
> SiteWeight http://www.postgres.de/ 0
> SiteWeight http://www.pgsqldb.org/ 0
> SiteWeight http://www.postgresql.org.br/ 0
>
>
>
>
>

 	Regards,
 		Oleg
_____________________________________________________________
Oleg Bartunov, Research Scientist, Head of AstroNet (www.astronet.ru),
Sternberg Astronomical Institute, Moscow University, Russia
Internet: [email-masked], http://www.sai.msu.su/~megera/
phone: +007(495)939-16-83, +007(495)939-23-83

---------------------------(end of broadcast)---------------------------
TIP 9: In versions below 8.0, the planner will ignore your desire to
       choose an index scan if your joining column's datatypes do not
       match

---

From: Guillaume Smet <[email-masked]>
Date: Sun, 26 Mar 2006 11:17:55 +0200

> The config being shown is the one used for the main www.postgresql.org site search, thus results from that site are favoured over external sites. The archives are ranked even lower because of the p…

Speaking of that, I noticed a problem a few days ago related to the 
scope of the search.

You can reproduce it this way:
http://www.postgresql.org/docs/8.1/interactive/index.html

Search for alter table for example:
http://search.postgresql.org/www.search?ul=http%3A%2F%2Fwww.postgresql.org%2Fdocs%2F8.1%2Finteractive%2F%25&fm=on&cs=utf-8&q=ALTER+TABLE
You have 91 results and especially the results from the documentation.

But when you click on the search button again on the results page, the 
ul parameter is not here anymore and you have pretty bad results:
http://search.postgresql.org/www.search?cs=utf-8&fm=on&gr=on&o=0&ps=20&s=rate&q=ALTER+TABLE
We have only 15 results and the documentation is not there.

So we should probably keep the ul parameter in the new form when set in 
the query string but I don't understand why we don't have the doc 
results when ul is not there and I suspect the search should be global 
in this case.

Regards,

--
Guillaume

---

From: "Dave Page" <[email-masked]>
Date: Sun, 26 Mar 2006 18:29:21 +0100

-----Original Message-----
From: Guillaume Smet [mailto:[email-masked]]
Sent: Sun 3/26/2006 10:17 AM
To: Dave Page
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [pgsql-www] search.postgresql.org
 
> ul parameter is not here anymore and you have pretty bad results:

Hm, no, it does seem to vanish. John, is that one of those template formatting buglets?

> We have only 15 results and the documentation is not there.

What you see there is the site grouping coming into effect. The docs are all on www.postgresql.org, which due to the weightings does get listed first, however, it seems that Bruce's book are the 2 options it shows from there (probably they mention the complete phrase most often or similar). You then see a couple of results from each of the other sites with hits. Under each should be a 'Show more from this site' link. Click that on the www results, and you will see the documentation hits form other parts of that site.

Regards, Dave.