Subject: New Survey?

From: Josh Berkus <[email-masked]>
Date: Fri, 3 Aug 2007 10:11:56 -0700

Folks,

The survey currently up is way out of date.  Here's replacement suggestions.

It would also be great if David could announce new surveys in PWN.

===========
OS: it's been a while since we did a server OS survey:

Q: On what operating system are the largest or most of your production or 
chief development PostgreSQL servers running?

-- Red Hat Linux
-- Debian/Ubuntu
-- Other Linux
-- Windows
-- Solaris
-- FreeBSD
-- Other OS

==========
App type:

Q: What is the database task for which you primariy use PostgreSQL in 
production?

-- OLTP / e-commerce
-- Web content management
-- Web 2.0 applications
-- Data warehousing
-- Monitoring & Security
-- Several / all of the above
-- Do not use PostgreSQL in production

===========
Version:

Q: Which version of PostgreSQL are most of your servers currently deployed on?

-- 7.2 or earlier
-- 7.3
-- 7.4
-- 8.0
-- 8.1
-- 8.2
-- Latest CVS snapshot, yeah!

============
Upgrades

Q: When do you upgrade your main machines after a new PostgreSQL release?

-- I upgrade during beta
-- Immediately after .0 comes out
-- I wait for the .1 release
-- 1-3 months
-- 4-9 months
-- I'm generally 1 or 2 versions behind
-- Whenever my OS supports the new version
-- Never

-- 
Josh Berkus
PostgreSQL @ Sun
San Francisco

---

From: "Jonah H. Harris" <[email-masked]>
Date: Fri, 3 Aug 2007 13:17:49 -0400

> The survey currently up is way out of date.  Here's replacement suggestions.

As a first choice, I'd say the upgrade survey.  Second, I'd choose app-type.

-- 
Jonah H. Harris, Software Architect | phone: 732.331.1324
EnterpriseDB Corporation            | fax: 732.331.1301
33 Wood Ave S, 3rd Floor            | [email-masked]
Iselin, New Jersey 08830            | http://www.enterprisedb.com/

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 3 Aug 2007 14:20:07 -0400

> The survey currently up is way out of date.  Here's replacement suggestions.

I don't know where the survey is, but I hate those things online. 
They're dumb because the sample qualification is both self-selected
and unknown.  Can't we dump it?

A

-- 
Andrew Sullivan  | [email-masked]
A certain description of men are for getting out of debt, yet are
against all taxes for raising money to pay it off.
		--Alexander Hamilton