Subject: Mailing list slowness

From: "Joshua D. Drake" <[email-masked]>
Date: Fri, 12 May 2006 09:44:38 -0700

Hello,

I have been having some fairly significant slowness on the mailing lists 
so I thought I would take a look at the delivery path. Part of the 
problem appears to be on my servers, but also part on Marcs. Marc I 
promise to fix mine if you fix yours ;)

See below:

The seems to be some hefty penalties between a couple of points.

 From [email-masked]  Fri May 12 09:37:09 2006
Return-Path: <[email-masked]>
Received: from hosting.commandprompt.com (128.commandprompt.com 
[207.173.200.128])
	by projects.commandprompt.com (8.13.6/8.13.4) with ESMTP id k4CGb9B2019101
	for <[email-masked]>; Fri, 12 May 2006 09:37:09 -0700
May 2006 13:07:24 -0300 (ADT)
Received: from postgresql.org ([200.46.204.71])

-- 

            === The PostgreSQL Company: Command Prompt, Inc. ===
      Sales/Support: +1.503.667.4564 || 24x7/Emergency: +1.800.492.2240
      Providing the most comprehensive  PostgreSQL solutions since 1997
                     http://www.commandprompt.com/

---

From: "Marc G. Fournier" <[email-masked]>
Date: Fri, 12 May 2006 14:12:43 -0300 (ADT)

On Fri, 12 May 2006, Joshua D. Drake wrote:

> Hello,
>
> I have been having some fairly significant slowness on the mailing lists so I 
> thought I would take a look at the delivery path. Part of the problem appears 
> to be on my servers, but also part on Marcs. Marc I promise to fix mine if 
> you fix yours ;)

Not sure what you'd like me to fix, but the delay appears to be you 
receiving from mx3.hub.org (our Toronto server) ... according to what i'm 
reading in the headers below:

postgresql.org in Panama -> mx3.hub.org in Toronto -> ~1min
mx3.hub.org -> hosting.commandprompt.com -> ~11min

Mail Queue on mx3 is <200 requests ... and checking the logs, it looks 
like your Greylisting is the cause of that delay:

mx3# grep commandprompt /var/log/maillog | grep Greylisting | wc -l
      256

So ... what exactly would you like me to fix at my end? :)

> Received: from hosting.commandprompt.com (crazypenguins [127.0.0.1])
> 	by hosting.commandprompt.com (8.13.4/8.13.4) with ESMTP id 
> k4CGJvFT002278
> 	for <[email-masked]>; Fri, 12 May 2006 09:19:57 -0700
> Received: (from jd@localhost)
> 	by hosting.commandprompt.com (8.13.4/8.13.4/Submit) id k4CGJvQ1002274
> 	for [email-masked]; Fri, 12 May 2006 09:19:57 -0700
> Received: from mx3.hub.org (206-223-169-73.beanfield.net [206.223.169.73])
> 	by hosting.commandprompt.com (8.13.4/8.13.4) with ESMTP id 
> k4CGJvQ9002249;
> 	Fri, 12 May 2006 09:19:57 -0700
> Received: from postgresql.org (postgresql.org [200.46.204.71])
> 	by mx3.hub.org (Postfix) with ESMTP id 0579637BEBA;
> 	Fri, 12 May 2006 13:08:31 -0300 (ADT)
> X-Original-To: [email-masked]
> Received: from localhost (mx1.hub.org [200.46.208.251])
> 	by postgresql.org (Postfix) with ESMTP id A8C709FA1B0
> 	for <[email-masked]>; Fri, 12 
> ---------------------------(end of broadcast)---------------------------
> TIP 1: if posting/reading through Usenet, please send an appropriate
>      subscribe-nomail command to [email-masked] so that your
>      message can get through to the mailing list cleanly
>

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664