Subject: Re: [Fwd: 58A0-9E5C-CE89 : CONSULT from pgsql-slavestothewww (post)]

From: "Marc G. Fournier" <[email-masked]>
Date: Sat, 21 Apr 2007 15:26:30 -0300

'k, this is a GLOBAL setting, not a local to the list one ... I can remove the 
approve rule, but here is the complete list of them ... I've never modified 
these before, either adding or removing, these are teh default ones that get 
installed ... as you will note with most of htem, they are anchored to the 
right side, so it isn't just *any* approve:

Let me know ...

configset GLOBAL admin_body <<ENDAAB
/^accept$/i
/^reject$/i
/\bcancel\b/i
/\badd me\b/i
/\bdelete me\b/i
/\bremove\s+me\b/i
/\bchange\b.*\baddress\b/
/\bsignoff\b/i
/\bsubscribe\b/i
/^sub\b/i
/\bunsubscribe\b/i
/^unsub\b/i
/^\s*help\s*$/i
/^\s*info\s*$/i
/^\s*info\s+\S+\s*$/i
/^\s*lists\s*$/i
/^\s*which\s*$/i
/^\s*which\s+\S+\s*$/i
/^\s*index\s*$/i
/^\s*index\s+\S+\s*$/i
/^\s*who\s*$/i
/^\s*who\s+\S+\s*$/i
/^\s*get\s+\S+\s*$/i
/^\s*get\s+\S+\s+\S+\s*$/i
/^\s*approve\b/i
/^\s*passwd\b/i
/^\s*newinfo\b/i
/^\s*config\b/i
/^\s*newconfig\b/i
/^\s*writeconfig\b/i
/^\s*mkdigest\b/i
ENDAAB

- --On Saturday, April 21, 2007 17:40:50 +0100 Dave Page <[email-masked]> 
wrote:

> Here's one...
>
> -------- Original Message --------
> Subject: 58A0-9E5C-CE89 : CONSULT from pgsql-slavestothewww (post)
> Date: Sat, 21 Apr 2007 13:18:36 -0300
> From: [email-masked]
> Reply-To: [email-masked]
> To: [email-masked]
>
> __
> The following request:
>
>   "(post to pgsql-slavestothewww)"
>
> was sent to
> by World Wide Web Owner <[email-masked]>.
>
> The request requires your confirmation for the following reason(s):
>
>   GLOBAL ADMIN BODY:  /^\s*approve\b/i matched "Approve" at line number 4.
>
> To accept or reject this request, please do one of the following:
>
> 1. If you have web browsing capability, visit
>
> <http://mail.postgresql.org/mj/mj_confirm/domain=postgresql.org?t=58A0-9E5C-C
> E89>    and follow the instructions there.
>
> 2. Reply to [email-masked]
>    with one of the following two commands in the body of the message:
>
>     accept
>     reject
>
>    (The number 58A0-9E5C-CE89 must be in the Subject header)
>
> 3. Reply to [email-masked]
>    with one of the following two commands in the body of the message:
>
>     accept 58A0-9E5C-CE89
>     reject 58A0-9E5C-CE89
>
> 4. If you know the administrative password for the pgsql-slavestothewww
> list,
>    all pending requests can be managed by visiting
>
> <http://mail.postgresql.org/mj/mj_wwwadm/domain=postgresql.org/pgsql-slavesto
> thewww?func=showtokens>
>
> If you do not respond within 7 days, this token will expire,
> and the request will not be completed.
>
>

- ----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email . [email-masked]                              MSN . [email-masked]
Yahoo . yscrappy               Skype: hub.org        ICQ . 7615664

---

From: Alvaro Herrera <[email-masked]>
Date: Sat, 21 Apr 2007 21:12:27 -0400

> right side, so it isn't just *any* approve:

In my opinion they are too ambiguous to be used as expressions for
rejecting a mail to the list.

Maybe mj2 was recently upgraded to a new version that contained
an "improved" list of regexes to disallow?

> /\bsubscribe\b/i

So anyone who sends a mail with the word "subscribe" in it will have it
rejected?  That seems rather unexpected.  Note that it isn't anchored,
except by blanks so it seems just using the word in a sentence causes it
to fire, unless I'm missing something.

> /^\s*mkdigest\b/i

I think these should make an effort to find the arguments just beyond
the command and the end of line.  Really they should not be there at
all.  What purpose do they serve, beyond protecting lame list admins who
manage to send commands to the list itself instead of the request
address?

-- 
Alvaro Herrera                                http://www.CommandPrompt.com/
The PostgreSQL Company - Command Prompt, Inc.

---

From: "Marc G. Fournier" <[email-masked]>
Date: Sat, 21 Apr 2007 23:53:30 -0300

None of these messages are rejected ... they are only put over to the 
moderators queue for later processing ... that is what Dave is having a problem 
with, that he has to go in and approve them instead of them just going straight 
through ...

As to recent upgrade .. not in the past few weeks, no ...

- --On Saturday, April 21, 2007 21:12:27 -0400 Alvaro Herrera 
<[email-masked]> wrote:

> Marc G. Fournier wrote:
>
>> 'k, this is a GLOBAL setting, not a local to the list one ... I can remove
>> the  approve rule, but here is the complete list of them ... I've never
>> modified  these before, either adding or removing, these are teh default
>> ones that get  installed ... as you will note with most of htem, they are
>> anchored to the  right side, so it isn't just *any* approve:
>

- ----

---

From: Dave Page <[email-masked]>
Date: Sun, 22 Apr 2007 20:21:20 +0100

> with, that he has to go in and approve them instead of them just going straight 

And given that *all* of the moderation messages from the website include
the word 'approve'... I think you can see the irony :-)

I'm still confused about why this just started happening though.

/D

---

From: "Marc G. Fournier" <[email-masked]>
Date: Mon, 23 Apr 2007 01:08:00 -0300

- --On Sunday, April 22, 2007 20:21:20 +0100 Dave Page <[email-masked]> 
wrote:

>> moderators queue for later processing ... that is what Dave is having a
>> problem  with, that he has to go in and approve them instead of them just
>> going straight  through ...
>

I don't know ... my only thought is that at some point a configdefault was set 
on the access_rules for that last ... the only way that would matter is if we 
*had* put in a special rule, like we did for committers for @pgfoundry.org 
emails ...

I've just added:

post
allow
$host =~ /wwwmaster\.postgresql\.org/

to the access_rules for pgsql-slavestothewww ... see if that fixes it, I'm not 
sure if access_rules is parsed before or after the GLOBAL TABOO stuff, but if 
so, that will fix it without having to reduce that other list ...

- ----

---

From: Dave Page <[email-masked]>
Date: Mon, 23 Apr 2007 08:54:55 +0100

> so, that will fix it without having to reduce that other list ...

Hmm, I had a few this morning, but I think they were all slightly before 
this email. I'll let you know if I get any more - thanks.

/D