Subject: Re: Plr-general post from [email-masked] requires approval

From: Joe Conway <[email-masked]>
Date: Tue, 19 Jun 2007 08:50:22 -0700

[email-masked] wrote:
> As list administrator, your authorization is requested for the
> following mailing list posting:
> 
>     List:    [email-masked]
>     From:    [email-masked]
>     Subject: RE: [postgis-users] Combined Windows version of PostGIS/P-LR
>     Reason:  Post by non-member to a members-only list
> 
> At your convenience, visit:
> 
>     http://pgfoundry.org/mailman/admindb/plr-general
>         
> to approve or deny the request.

I've checked all through my saved mail, and I either never received, or 
inadvertently deleted, the message from pgfoundry regarding moderator 
password for this list. The password is also not the same as my 
pgfoundry login.

Can someone either give me access to moderate the PL/R lists, or approve 
this and other pending requests?

Thanks,

Joe

> 
> 
> ------------------------------------------------------------------------
> 
> Subject:
> RE: [postgis-users] Combined Windows version of PostGIS/P-LR
> From:
> "Obe, Regina" <[email-masked]>
> Date:
> Tue, 19 Jun 2007 09:48:16 -0400
> To:
> <[email-masked]>
> 
> To:
> <[email-masked]>
> CC:
> "PostGIS Users Discussion" <[email-masked]>, 
> <[email-masked]>
> 
> 
> Were you doing it from psql or PgAdmin III?  I'm thinking that when you cut and paste via PgAdmin III that it keeps in whatever linebreaks are in there and maybe psql strips it?
> 
> Actually its weird because when I did it the first time it worked, but for some reason consecutive times I couldn't recreate my success (but then I was directly cutting and pasting from the web page), until I discovered that if I stripped the line breaks it seemed to work consistently.
> 
> Thanks,
> Regina
> 
> -----Original Message-----
> From: Mike Leahy [mailto:[email-masked]] 
> Sent: Tuesday, June 19, 2007 9:43 AM
> To: Obe, Regina
> Cc: PostGIS Users Discussion; [email-masked]
> Subject: Re: [postgis-users] Combined Windows version of PostGIS/P-LR
> 
> Regina,
> 
> I'm copying this to the plr-general list ([email-masked]).
> 
> I can't say that I'm getting the same error.  I've installed the version
> from David's installer, and I did the exact same example from the PL/R
> docs that you're trying and it's working for me too.  Maybe there's an
> encoding problem in your case?
> 
> Mike
> 
> Obe, Regina wrote:
>>  
>> Unfortunately I'm not in the PL/R newsgroup yet and I don't have Joe's email address, so can someone pass this message along. I'm updating my  instruction docs accordingly to reflect this issue and still writing up some followup tutorials.
>>
>> When testing creating the median function as described in the docs using PgAdmin, I would get parse R errors when using it.  After some research (googling - others had the same problem) and refollowing my tracks (since I was able to get it right a couple of times, but not consistently).  I discovered it was the line breaks in the function that was causing the problem.
>>
>> I had to do this
>>
>> create or replace function r_median(_float8) 
>> 	returns float as 'median(arg1)' language 'plr';
>>
>>
>> instead of what is mentioned in the docs - this
>> create or replace function r_median(_float8) returns float as '
>>   median(arg1)
>> ' language 'plr';
>>
>> Evidentally R parser chokes when it runs into line breaks.
>>
>> Hope that helps,
>> Regina
>>
>>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of TECHER David
>> Sent: Monday, June 18, 2007 6:16 PM
>> To: [email-masked]; PostGIS Users Discussion
>> Subject: Re: [postgis-users] Combined Windows version of PostGIS/P-LR
>>
>> Mike Leahy a écrit :
>>> Hey all,
>>>
>>> I'm just wondering if this thread should move back to the plr-general
>>> list.  In particular, I think it would be good if Joe is able to add a
>>> link to the installer on the PL/R web page.  I just tried the installer,
>>> and it works great - nice work David.
>>>
>>> I did notice, however, that it claims to be installing PgRouting in the
>>> welcome screen, and it appears as PgRouting in the Windows uninstall
>>> list.  
>> Well I did the installer, last Saturday night and I was hurry.
>> You know when you haven't slept all a night, you don't see errors
>> thanks.
>>> Also, I think more than is needed is being added to the Path
>>> variable.  In my case, this is what gets added after the installer is done:
>>>
>>> "\;C:\Program Files\R\R-2.5.0\bin;C:\Program
>>> Files\PostgreSQL\8.2\bin;C:\Program Files\PostgreSQL\8.2\lib"
>>>
>>>   
>> I reduced it to
>>
>> \;C:\Program Files\R\R-2.5.0\bin
>>
>>> When I had installed PL/R manually, I seemed to be able to get away with
>>> adding just ";C:\Program Files\R\R-2.5.0\bin".  
>> Yes it is, you're right. But if you use a function like
>>
>> select load_r_typenames();
>>
>> pl/r needs to know what it you R_HOME environment variable.
>>> Also, if I happen to
>>> re-install PL/R, the entire string above will appear multiple times in
>>> the Path variable.  Is it possible for the installer to check for that?
>>>
>>>   
>> I've only been able to detect if R directory is present in PATH variable 
>> for the moment!
>> Not able to remove it for the moment from a previous install
>>
>> If you want, my Inno Setup script is available at
>>
>> http://www.davidgis.fr/download/plr-8.2.0.4-win32-src.zip
>>
>> If someone is used here to using Inno SetUp, no problem to improve it.
>>
>>> Regards,
>>> Mike
>>>
>>> TECHER David wrote:
>>>   
>>>> Hi Regina,
>>>>
>>>> Many thanks for these interesting link! Very excellent!
>>>>
>>>> I will wait for the next series of your articles!
>>>>
>>>> --david;
>>>>
>>>> Obe, Regina a écrit :
>>>>     
>>>>> Since Dave was doing his part, I figured I would help out the cause a
>>>>> little. R is pretty new to me too but looks like it could be very useful.
>>>>> I drafted up a quick getting started and included David's link in there.
>>>>> http://www.bostongis.com/PrinterFriendly.aspx?content_name=postgresql_plr_tut01
>>>>>
>>>>> Let me know any parts that seem unclear or where I went wrong. The
>>>>> steps seemed to work for me.
>>>>> Thanks,
>>>>> Regina
>>>>>
>>>>> ------------------------------------------------------------------------
>>>>> *From:* [email-masked] on behalf of
>>>>> TECHER David
>>>>> *Sent:* Sun 6/17/2007 2:53 AM
>>>>> *To:* PostGIS Users Discussion
>>>>> *Subject:* Re: [postgis-users] Combined Windows version of PostGIS/P-LR
>>>>>
>>>>> Dear Jan,
>>>>>
>>>>> I begun to use PL/R. As you know, I'm not a expert in R
>>>>>
>>>>> Compiling with PostgreSQL 8.2.4 on win32 ...no problem!
>>>>>
>>>>>
>>>>> These release is available at
>>>>>
>>>>> http://www.davidgis.fr/download/plr-8.2.0.4_0_win32.exe
>>>>>
>>>>> I've tryed to see here if
>>>>>
>>>>> first R 2.5.0 is available on the computer where you want to install it.
>>>>>
>>>>> else it stop!
>>>>>
>>>>> The installer updates the R_HOME environment variable
>>>>> and update the PATH in order to adding 'R_HOME'/bin directory
>>>>>
>>>>> Let me know if it works for you
>>>>>
>>>>> createdb testR
>>>>>
>>>>> psql -d testR -f / "path/to/your/postgresql/dir"/share/contrib/plr.sql
>>>>>
>>>>> psql testR
>>>>>
>>>>> select load_r_modules();
>>>>>
>>>>> select * from plr_environ();
>>>>>
>>>>> and so on
>>>>>
>>>>> --david;
>>>>>
>>>>> Jan Hartmann a écrit :
>>>>>       
>>>>>> I agree. A separate installer for PL/R would be the first thing to
>>>>>> create. Am I right that that would not be very difficult? After that,
>>>>>> though, I would very much like to have a *combined* version, with PL/R
>>>>>> and PostGIS both enabled. I am not sure how difficult that would be,
>>>>>> but, as I said, it would be a marvelous example of Open Source
>>>>>> software cooperation. The additional packages Mike mentioned don't
>>>>>> have to be installed prior to installing PL/R; you can install them in
>>>>>> the regular way in R (R INSTALL), and an existing PostgreSQL database
>>>>>> with PL/R will recognise them after a restart.
>>>>>>
>>>>>> BTW: deldir was a major reason for me to experimnt with a combined
>>>>>> version: the power of voronoi diagrams in a PostGIS database!
>>>>>>
>>>>>> Jan
>>>>>>
>>>>>> Mike Leahy wrote:
>>>>>>         
>>>>>>> David/Jan:
>>>>>>>
>>>>>>> Although PostGIS and PL/R can be complimentary tools, I think a
>>>>>>>           
>>>>> separate
>>>>>       
>>>>>>> installer (for now at least) would make the most sense for PL/R. At
>>>>>>> least that way there is still the option for other users to install
>>>>>>>           
>>>>> PL/R
>>>>>       
>>>>>>> without PostGIS, and vice-versa.
>>>>>>>
>>>>>>> At the same time, however, I can see how a including PL/R as an option
>>>>>>> in the PostGIS installer could be useful - particularly if a set of
>>>>>>> pre-defined functions were included with the setup that made use of
>>>>>>>           
>>>>> PL/R
>>>>>       
>>>>>>> for spatial statistical operations within PostGIS. But this might
>>>>>>>           
>>>>> get a
>>>>>       
>>>>>>> bit complicated, considering the requirements involved (e.g., having R
>>>>>>> installed, as well as packages installed in R - such as deldir for
>>>>>>> making voronoi polygons).
>>>>>>>
>>>>>>> Mike
>>>>>>>
>>>>>>> TECHER David wrote:
>>>>>>>           
>>>>>>>> Hi Jan,
>>>>>>>>
>>>>>>>> Before I made a mistake, all you want is only a win32-installer for
>>>>>>>> PL/R?
>>>>>>>>
>>>>>>>> because I think you know that's postgis win32-installer already
>>>>>>>>             
>>>>> exist?
>>>>>       
>>>>>>>> See http://www.postgis.org/download/windows/
>>>>>>>>
>>>>>>>> --david;
>>>>>>>>
>>>>>>>>
>>>>>>>> Jan Hartmann a écrit :
>>>>>>>>             
>>>>>>>>> Hi folks (sorry for crossposting),
>>>>>>>>>
>>>>>>>>> Joe Conway just announced that PL/R will soon be available for
>>>>>>>>> Windows. See the thread starting at:
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>               
>>>>> http://gborg.postgresql.org/pipermail/plr-general/2007-June/000235.html
>>>>>       
>>>>>>>>> PL/R is an implementation of the statistical package R within
>>>>>>>>> PostgreSQL. See:
>>>>>>>>>
>>>>>>>>> http://www.joeconway.com/plr/
>>>>>>>>> http://www.r-project.org <http://www.r-project.org/>
>>>>>>>>>
>>>>>>>>> It's installed the same way as postGIS, but until now only a Linux
>>>>>>>>> version was available. I have them both enabled on my server at SARA
>>>>>>>>> computing center, and the functionality is unbelievable. My own
>>>>>>>>> organisation, however, doesn't allow me to install Linux servers,
>>>>>>>>>               
>>>>> and
>>>>>       
>>>>>>>>> even if they did, neither staff nor students would be willing or
>>>>>>>>>               
>>>>> even
>>>>>       
>>>>>>>>> able to work with them. I guess this is not a unique situation, so
>>>>>>>>> this Windows port is really important. Moreover, a PostgreSQl
>>>>>>>>> implementation with full GIS and statistical functionality is
>>>>>>>>> something that doesn't exist in the commercial world as far as I
>>>>>>>>>               
>>>>> know.
>>>>>       
>>>>>>>>> An easy installable Windows version would IMO really be a showpiece
>>>>>>>>> for Open Source software. I would really appreciate if people in the
>>>>>>>>> know on both these lists would put their heads together to implement
>>>>>>>>> this. I don't really know much about Windows installers, but my
>>>>>>>>> feeling is that it is not enormously difficult.
>>>>>>>>>
>>>>>>>>> Regards,
>>>>>>>>>
>>>>>>>>> Jan Hartmann
>>>>>>>>>
>>>>>>>>> Dr. J. Hartmann
>>>>>>>>> Department of Geography
>>>>>>>>> University of Amsterdam
>>>>>>>>> _______________________________________________
>>>>>>>>> postgis-users mailing list
>>>>>>>>> [email-masked]
>>>>>>>>> http://postgis.refractions.net/mailman/listinfo/postgis-users
>>>>>>>>>
>>>>>>>>>               
>>>>>>>>             
>>>>> ___________________________________________________________________________
>>>>>
>>>>>       
>>>>>>>> Yahoo! Mail r?invente le mail ! D?couvrez le nouveau Yahoo! Mail
>>>>>>>>             
>>>>> et son
>>>>>       
>>>>>>>> interface r?volutionnaire.
>>>>>>>> http://fr.mail.yahoo.com <http://fr.mail.yahoo.com/>
>>>>>>>> _______________________________________________
>>>>>>>> postgis-users mailing list
>>>>>>>> [email-masked]
>>>>>>>> http://postgis.refractions.net/mailman/listinfo/postgis-users
>>>>>>>>
>>>>>>>>             
>>>>>>> _______________________________________________
>>>>>>> postgis-users mailing list
>>>>>>> [email-masked]
>>>>>>> http://postgis.refractions.net/mailman/listinfo/postgis-users
>>>>>>>
>>>>>>>           
>>>>>> _______________________________________________
>>>>>> postgis-users mailing list
>>>>>> [email-masked]
>>>>>> http://postgis.refractions.net/mailman/listinfo/postgis-users
>>>>>>
>>>>>>         
>>>>>
>>>>>
>>>>> ___________________________________________________________________________
>>>>>
>>>>> Yahoo! Mail rinvente le mail ! Dcouvrez le nouveau Yahoo! Mail et son
>>>>> interface rvolutionnaire.
>>>>> http://fr.mail.yahoo.com <http://fr.mail.yahoo.com/>
>>>>> _______________________________________________
>>>>> postgis-users mailing list
>>>>> [email-masked]
>>>>> http://postgis.refractions.net/mailman/listinfo/postgis-users
>>>>>
>>>>> ------------------------------------------------------------------------
>>>>>
>>>>> *The substance of this message, including any attachments, may be
>>>>> confidential, legally privileged and/or exempt from disclosure
>>>>> pursuant to Massachusetts law. It is intended solely for the
>>>>> addressee. If you received this in error, please contact the sender
>>>>> and delete the material from any computer. *
>>>>>
>>>>> ------------------------------------------------------------------------
>>>>>
>>>>> _______________________________________________
>>>>> postgis-users mailing list
>>>>> [email-masked]
>>>>> http://postgis.refractions.net/mailman/listinfo/postgis-users
>>>>>   
>>>>>       
>>>>     
>>>>
>>>>     
>>>>        
>>>> ___________________________________________________________________________
>>>> Yahoo! Mail r?invente le mail ! D?couvrez le nouveau Yahoo! Mail et son
>>>> interface r?volutionnaire.
>>>> http://fr.mail.yahoo.com
>>>> _______________________________________________
>>>> postgis-users mailing list
>>>> [email-masked]
>>>> http://postgis.refractions.net/mailman/listinfo/postgis-users
>>>>
>>>>     
>>>   
>>
>> 	
>>
>> 	
>> 		
>> ___________________________________________________________________________ 
>> Yahoo! Mail réinvente le mail ! Découvrez le nouveau Yahoo! Mail et son interface révolutionnaire.
>> http://fr.mail.yahoo.com
>> _______________________________________________
>> postgis-users mailing list
>> [email-masked]
>> http://postgis.refractions.net/mailman/listinfo/postgis-users
>>
>>
>> ------------------------------------------------------------------------
>>
>> Subject:
>> confirm 74c5c94d0c1c20667755a5f9c53f7678ad63a76f
>> From:
>> [email-masked]
>>
>>
>> If you reply to this message, keeping the Subject: header intact,
>> Mailman will discard the held message.  Do this if the message is
>> spam.  If you reply to this message and include an Approved: header
>> with the list password in it, the message will be approved for posting
>> to the list.  The Approved: header can also appear in the first line
>> of the body of the reply.

---

From: Josh Berkus <[email-masked]>
Date: Tue, 19 Jun 2007 09:03:51 -0700

Joe,

> this and other pending requests?

I haven't forgotten this.  I've just been in meetings, meetings, and more 
meetings.  Will fix it later today.

-- 
Josh Berkus
PostgreSQL @ Sun
San Francisco

---

From: Joe Conway <[email-masked]>
Date: Tue, 19 Jun 2007 09:04:29 -0700

> meetings.  Will fix it later today.

Thanks. Believe me, I can fully empathize with meetings, meetings, and 
more meetings ;-)

Joe