Subject: Re: Email not searchable in our archives

From: Bruce Momjian <[email-masked]>
Date: Tue, 11 Mar 2008 20:55:56 -0400 (EDT)

bruce wrote:
> Dave Page wrote:
> > On Tue, Mar 11, 2008 at 9:35 PM, Bruce Momjian <[email-masked]> wrote:
> > > bruce wrote:
> > >  > Would someone please fine out why the attached email from Heikki is not
> > >  > appearing in a search of our archives?  I tried the subject and a line
> > >  > from the email and neither came up as a hit:
> > >
> > >  OK, it has been 24 hours since I reported some emails are not being
> > >  archived and no one has even responded they are looking at the problem.
> > >
> > >  Are we unable to manage our own archive search?  If we can't, I will
> > >  start linking to another archive from the TODO list.  Right now, every
> > >  time I need a URL for the TODO list I have to troll through the archives
> > >  by date until I find the email.
> > 
> > The people that know that code well all have day jobs and limited
> > spare time. I don't think it's unreasonable for them to take more than
> > 24 hours to respond.
> > 
> > Google seems to work fine on our archives, so there is no need to link
> > elsewhere.
> 
> Does Google link _into_ our archives ---  ah, that does work and is a
> good work-around.  Thanks.

OK, now Google search isn't finding this email either:

	http://archives.postgresql.org/pgsql-hackers/2007-08/msg00055.php

See this search:

	http://www.google.com/search?hl=en&client=firefox-a&rls=com.ubuntu%3Aen-US%3Aofficial&hs=eqZ&q=Re%3A+clog_buffers+to+64+in+8.3+site%3Aarchives.postgresql.org&btnG=Search

It sees this email:

	http://archives.postgresql.org/pgsql-hackers/2007-09/msg00636.php

but not the emails from August on the same subject.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://postgres.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +

---

From: "Magnus Hagander" <[email-masked]>
Date: Wed, 12 Mar 2008 09:17:46 +0100

> > Perhaps I should just try without the subdir and see if it works.
> 
> I am wondering if we should bail out of Mhonarc all together. Do we
> actually need it? We have the actual mbox files right? Couldn't we
> build our own parser for whatever?

Let's not throw it out until we know that's where the problem is.  A lot of work has been but into our mhonarc instal over the years to make it fit with our website etc.

Dave has looked at the custom parser thing, but it's a lot more work than you'd initially think. There's a zillion corner-cases.

/Magnus