Subject: Devel docs build is stuck?

From: Tom Lane <[email-masked]>
Date: Thu, 20 Mar 2008 23:47:01 -0400

According to
http://developer.postgresql.org/pgdocs/postgres/buildlog.html
nothing has happened for a couple of days ...

			regards, tom lane

---

From: "Marc G. Fournier" <[email-masked]>
Date: Fri, 21 Mar 2008 01:46:24 -0300

looks like a stale lock file, removed it so should run shortly ...

- --On Thursday, March 20, 2008 23:47:01 -0400 Tom Lane <[email-masked]>
wrote:

> --
> Sent via pgsql-www mailing list ([email-masked])
> To make changes to your subscription:
> http://www.postgresql.org/mailpref/pgsql-www

- -- 
Marc G. Fournier        Hub.Org Hosting Solutions S.A. (http://www.hub.org)
Email . [email-masked]                              MSN . [email-masked]
Yahoo . yscrappy               Skype: hub.org        ICQ . 7615664

---

From: Alvaro Herrera <[email-masked]>
Date: Fri, 21 Mar 2008 12:51:25 -0300

Marc G. Fournier wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 

Should we get this build monitored too?

-- 
Alvaro Herrera                                http://www.CommandPrompt.com/
The PostgreSQL Company - Command Prompt, Inc.

---

From: "Marc G. Fournier" <[email-masked]>
Date: Sat, 22 Mar 2008 00:17:51 -0300 (ADT)

> Should we get this build monitored too?

At the very least, have the lock file written to /tmp so that its cleared 
on reboot?

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 22 Mar 2008 10:23:35 -0400 (EDT)

> At the very least, have the lock file written to /tmp so that its cleared 

Simplistically, the lockfile program that comes with procmail allows an
age to be specified --- if the lockfile is older than a certain amount
of time it is removed --- I used this feature often:

       If you specify a  locktimeout  then  a  lockfile  will  be
       removed  by  force  after  locktimeout seconds have passed
       since the lockfile was last modified/created (most  likely
       by  some  other program that unexpectedly died a long time
       ago, and hence could not clean up any leftover lockfiles).

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://postgres.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +