Subject: Another summerofcode.html update

From: Josh Berkus <[email-masked]>
Date: Tue, 25 Mar 2008 09:19:16 -0700

Guys,

Here it is in context patch format, to forstall confusion.  Please apply, 
thanks.

-- 
Josh Berkus
PostgreSQL @ Sun
San Francisco
*** summerofcode.html	2008-03-25 09:06:14.000000000 -0700
--- summerofcode_new.html	2008-03-25 09:15:13.000000000 -0700
***************
*** 45,50 ****
--- 45,51 ----
  <h3>Infrastructure</h3>
  <ul>
  <li><strong>Enhance Buildfarm to test external packages, patches, or performance</strong>: The PostgreSQL project maintains a public buildfarm that continuously communicates with several machines that checkout and build the PostgreSQL source on a regular basis. The idea behind this project is to extend the current buildfarm code to allow it download external modules and report back on their build status, to download unapplied patches and test them, or to run performance tests. </li>
+ <li><strong>Translation manager for www.postgresql.org</strong> create tools to manage translations of the core project web site.</li>
  </ul>
  
  <a id="extapps" name="extapps"></a>
***************
*** 61,66 ****
--- 62,69 ----
  <li><strong>Procedural Language Improvements</strong>: PostgreSQL provides support for more than a dozen different procedural languages, however the level of support varies depending on the language implementation. Enhancing support of these procedural languages might include fixing build issues, adding SPI support, adding trigger support, adding support for IN/OUT parameters and more.</li>
  <li><strong>Replication</strong>: PostgreSQL provides a wide range of replication solutions for varying types of replication needs. Many of these projects need assistance with building against different versions of PostgreSQL, installation and setup, administrative tools, and general bugfixing.</li>
  <li><strong>Teaching & Learning Tools</strong>: External tools to help in teaching the internals of PostgreSQL such as enhanced visual EXPLAIN, graphical models of the query engine, educational guides to the code, and interactive tools to demonstrate various query types.
+ <li><strong>PostGIS & GEOS</strong> add performance and feature enhancements to PostgreSQL's geographic data support.</li>
+ <li><strong>pgMemcached</strong> port pgMemcached to the new libmemcached, and update it for PostgreSQL 8.3, and/or add features.</li>
  </ul>
  <p>Additional projects may be found by browsing the <a href="http://projects.postgresql.org">PostgreSQL Development Projects</a> website.</p>
  
***************
*** 82,87 ****
--- 85,92 ----
  	<li>Julius Stroffek &lt;julius.stroffek @t gmail.com&gt;, Sun Microsystems, query engine and applications</li>
  	<li>Robert Treat &lt;xzilla @t users.sourceforge.net&gt;, OmniTI Inc., PHP-based projects and infrastructure</li>
  	<li>Zdenek Kotala &lt;zdenek.kotala @t sun.com&gt;, Sun Microsystems, file format and upgrade utilities</li>
+ 	<li>Tim Keitt &lt;tkeitt @t gmail.com&gt; and Paul Ramsey, PostGIS</li>
+ 	<li>Brian Aker &lt;brian @t tangent.org&gt;, Memcached & pgMemcached</li>
  </ul>
  
  <p>If your project is not selected for funding by Google, but you still think you have a

---

From: Robert Treat <[email-masked]>
Date: Tue, 25 Mar 2008 21:32:51 -0400

> Here it is in context patch format, to forstall confusion.  Please apply,

AFICT this was committed, but no follow-up was posted saying so... in the 
future let's all remember to follow-up when we apply. Thank you for your 
support. 

-- 
Robert Treat
Build A Brighter LAMP :: Linux Apache {middleware} PostgreSQL

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Wed, 26 Mar 2008 01:50:47 -0000

> future let's all remember to follow-up when we apply. Thank you for your

Isn't that what post-commit hooks automagically sending mail is for?

- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200803252150
http://biglumber.com/x/web?pk=2529DF6AB8F79407E94445B4BC9B906714964AC8

---

From: "Joshua D. Drake" <[email-masked]>
Date: Tue, 25 Mar 2008 18:53:56 -0700

On Wed, 26 Mar 2008 01:50:47 -0000
"Greg Sabino Mullane" <[email-masked]> wrote:

> > AFICT this was committed, but no follow-up was posted saying so...
> > in the future let's all remember to follow-up when we apply. Thank
> > you for your support.
> 

Yes. I am not sure which followup we are looking for. I received
notification today. Robert are you not on [email-masked]?

Sincerely,

Joshua D. Drake

-- 
The PostgreSQL Company since 1997: http://www.commandprompt.com/ 
PostgreSQL Community Conference: http://www.postgresqlconference.org/
Donate to the PostgreSQL Project: http://www.postgresql.org/about/donate
PostgreSQL SPI Liaison | SPI Director |  PostgreSQL political pundit

---

From: Robert Treat <[email-masked]>
Date: Wed, 26 Mar 2008 23:07:16 -0400

> notification today. Robert are you not on [email-masked]?
sure, but those messages are not threaded to original requests, and i'd 
suspect not everyone who submits a patch is subscribed there.

---

From: Magnus Hagander <[email-masked]>
Date: Thu, 27 Mar 2008 10:15:55 +0100

Robert Treat wrote:
> > > > AFICT this was committed, but no follow-up was posted saying
> > > > so... in the future let's all remember to follow-up when we
> > > > apply. Thank you for your support.
> > >
> sure, but those messages are not threaded to original requests, and
> i'd suspect not everyone who submits a patch is subscribed there. 

I agree with Robert here - having a quick "applied, thanks" note appear
in the proper thread makes it a *lot* easier to figure out which things
can be removed from the local shame-list of stuff that needs to be
applied.

//Magnus

---

From: "Joshua D. Drake" <[email-masked]>
Date: Mon, 31 Mar 2008 04:49:18 -0700

On Thu, 27 Mar 2008 10:15:55 +0100
Magnus Hagander <[email-masked]> wrote:

> I agree with Robert here - having a quick "applied, thanks" note
> appear in the proper thread makes it a *lot* easier to figure out
> which things can be removed from the local shame-list of stuff that
> needs to be applied.

With the infrequency of commits for www should we just point the commit
message to -www?

Joshua D. Drake

---

From: Magnus Hagander <[email-masked]>
Date: Mon, 31 Mar 2008 14:00:00 +0200

Joshua D. Drake wrote:
> With the infrequency of commits for www should we just point the
> commit message to -www?

I think not. It' just yet another reason that people would stay away
who're more interested in the other parts of the www discussion, and it
also does not solve the actual problem with the threading of the
message...

//Magnus