Subject: Minor change to community logon

From: "Dave Page" <[email-masked]>
Date: Wed, 11 Jun 2008 09:40:21 +0100

As far as I can see it's not documented anywhere, but until 5 minutes
ago it was possible to login to the community logon system using
either your email address or userid (and password of course). As this
can lead to a few subtle problems, I've modified the code to only
accept the userid & password.

So if anyone complains, please tell them to use their userid from now on.

-- 
Dave Page
EnterpriseDB UK: http://www.enterprisedb.com

---

From: Magnus Hagander <[email-masked]>
Date: Wed, 11 Jun 2008 10:47:40 +0200

> accept the userid & password.

Thanks for picking this one off my TODO :-)

//Magnus

---

From: Josh Berkus <[email-masked]>
Date: Wed, 11 Jun 2008 07:44:55 -0700

Guys,

Right now, I have 5 different logons for postgresql.org sites:

community logon
wiki
pgfoundry
admin
pugs

Any chance of unifying any of these?

-- 
Josh Berkus
PostgreSQL @ Sun
San Francisco

---

From: "Dave Page" <[email-masked]>
Date: Wed, 11 Jun 2008 15:47:24 +0100

> Right now, I have 5 different logons for postgresql.org sites:

They are one and the same anyway.

> pgfoundry

Probably, if one of the pgFoundry team cares to work on that once it's
been upgraded.

> admin

Nope, that will not be using the same database.

> pugs

Dunno - can Drupal handle external auth Selena?

---

From: Magnus Hagander <[email-masked]>
Date: Wed, 11 Jun 2008 16:49:43 +0200

> Dunno - can Drupal handle external auth Selena?

It's on my todo to work on that with Selena, since w'ell be needing it
for thyings like the EU site as well. AFAIK it does handle external auth
modules, but one needs to be developed for our system.

//Magnus

---

From: "Selena Deckelmann" <[email-masked]>
Date: Wed, 11 Jun 2008 07:50:18 -0700

> Dunno - can Drupal handle external auth Selena?

There's support for LDAP and for OpenID, so in a general sense, yes :)

I'll work on it with Magnus.

-selena

-- 
Selena Deckelmann
United States PostgreSQL Association - http://www.postgresql.us
PDXPUG - http://pugs.postgresql.org/pdx
Me - http://www.chesnok.com/daily

---

From: "Dave Page" <[email-masked]>
Date: Wed, 11 Jun 2008 15:54:27 +0100

> I'll work on it with Magnus.

Cool. I just fixed the last of his bugs in the community logon system
(I hope), so that''ll give me something else to do :-p

---

From: "Joshua D. Drake" <[email-masked]>
Date: Wed, 11 Jun 2008 09:22:46 -0700

> Dunno - can Drupal handle external auth Selena?

It can use pam which would allow this. It can use OpenID too but I don't
know enough about OpenID to know if that would be a good idea.

Joshua D. Drake