Subject: Re: [Pgweb] r2149 - in trunk/archives/html: . includes

From: Magnus Hagander <[email-masked]>
Date: Mon, 30 Jun 2008 15:25:30 +0200

What's the reason for this? :-)

Keeping it on the main website gets you the global distribution for
faster access, and also better caching for people... Is there any reason
not to use that?

//Magnus

[email-masked] wrote:
> Author: alvherre
> Date: 2008-06-30 06:19:50 -0700 (Mon, 30 Jun 2008)
> New Revision: 2149
> 
> Modified:
>    trunk/archives/html/
>    trunk/archives/html/includes/top_config.php
> Log:
> Use a svn:external property to have the layout files in place instead of
> referring to www.postgresql.org.
> 
> 
> 
> Property changes on: trunk/archives/html
> ___________________________________________________________________
> Name: svn:externals
>    + layout/css              https://pgweb.postgresql.org/svn/trunk/portal/layout/css
> layout/js               https://pgweb.postgresql.org/svn/trunk/portal/layout/js
> layout/images           https://pgweb.postgresql.org/svn/trunk/portal/layout/images
> 
> 
> 
> Modified: trunk/archives/html/includes/top_config.php
> ===================================================================
> --- trunk/archives/html/includes/top_config.php	2008-06-30 11:56:31 UTC (rev 2148)
> +++ trunk/archives/html/includes/top_config.php	2008-06-30 13:19:50 UTC (rev 2149)
> @@ -1,9 +1,10 @@
> +    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
>      <link rel="shortcut icon" href="/favicon.ico" />
>  
> -    <style type="text/css" media="screen" title="Normal Text">@import url("http://www.postgresql.org/layout/css/blue/fixed.css");</style>
> -    <link rel="alternate stylesheet" media="screen" href="http://www.postgresql.org/layout/css/blue/fixed_large.css" type="text/css" title="Large Text" />
> -    <script type="text/javascript" src="http://www.postgresql.org/layout/js/styleswitcher.js"></script>
> -    <script type="text/javascript" src="http://www.postgresql.org/layout/js/geckostyle.js"></script>
> +    <style type="text/css" media="screen" title="Normal Text">@import url("/layout/css/blue/fixed.css");</style>
> +    <link rel="alternate stylesheet" media="screen" href="/layout/css/blue/fixed_large.css" type="text/css" title="Large Text" />
> +    <script type="text/javascript" src="/layout/js/styleswitcher.js"></script>
> +    <script type="text/javascript" src="/layout/js/geckostyle.js"></script>
>  
>  
>      <script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script><script type="text/javascript">_uacct = "UA-1345454-2";urchinTracker();</script>
> @@ -39,20 +40,20 @@
>          <div id="pgHeader">
>  	  <h2 class="pgBlockHide">Header And Logo</h2>
>            <div id="pgHeaderLogoLeft">
> -            <a href="http://www.postgresql.org/" title="PostgreSQL"><img src="http://www.postgresql.org/layout/images/hdr_left.png" width="230" height="80" alt="PostgreSQL" /></a>
> +            <a href="http://www.postgresql.org/" title="PostgreSQL"><img src="/layout/images/hdr_left.png" width="230" height="80" alt="PostgreSQL" /></a>
>            </div>
>            <div id="pgHeaderLogoRight">
>              <span class="txtOffScreen">|</span>
> -            <a href="http://www.postgresql.org/" title="The world's most advanced open source database."><img src="http://www.postgresql.org/layout/images/hdr_right.png" width="210" height="80" alt="The world's most advanced open source database." /></a>
> +            <a href="http://www.postgresql.org/" title="The world's most advanced open source database."><img src="/layout/images/hdr_right.png" width="210" height="80" alt="The world's most advanced open source database." /></a>
>            </div>
>          </div>
>    	<h2 class="pgBlockHide">Site Navigation</h2>
>          <div id="pgTopNav">
>            <div id="pgTopNavLeft">
> -            <img src="http://www.postgresql.org/layout/images/nav_lft.png" width="7" height="23" alt="" />
> +            <img src="/layout/images/nav_lft.png" width="7" height="23" alt="" />
>            </div>
>            <div id="pgTopNavRight">
> -            <img src="http://www.postgresql.org/layout/images/nav_rgt.png" width="7" height="23" alt="" />
> +            <img src="/layout/images/nav_rgt.png" width="7" height="23" alt="" />
>            </div>
>            <ul id="pgTopNavList">
>    <li>
> 
> _______________________________________________
> Pgweb mailing list
> [email-masked]
> http://community1.commandprompt.com/cgi-bin/mailman/listinfo/pgweb

---

From: Alvaro Herrera <[email-masked]>
Date: Mon, 30 Jun 2008 09:34:22 -0400

> faster access, and also better caching for people... Is there any reason

Yes -- one of the .css files references another one by relative path, so
it gets a 404 when loaded from archives.

I guess another solution would be to fix all the relative paths in
there.

-- 
Alvaro Herrera                                http://www.CommandPrompt.com/
PostgreSQL Replication, Consulting, Custom Development, 24x7 support

---

From: Alvaro Herrera <[email-masked]>
Date: Mon, 30 Jun 2008 09:52:12 -0400

> faster access, and also better caching for people... Is there any reason

Also, in order to fix the hardcodedness of lists in the archives pages, 
I need a templating system; and what better idea than to just reuse the
PgPage stuff?  So I was considering using svn:externals to get
portal/system/global and pearlib/ into trunk/archives, so that a
checkout of archives gets the needed files.

The downside is that if somebody checks out pgweb:trunk/ then he will
get those files twice.  Is that too much of a problem for anyone?

(Before anybody complains about the extra load, I'm not planning to use
the templating stuff for every page load -- only to generate some
includes when the list of lists changes.  This probably means that it
will be cheaper than the current code, because most of it will be plain
HTML instead of having some embedded PHP.)

-- 
Alvaro Herrera                                http://www.CommandPrompt.com/
The PostgreSQL Company - Command Prompt, Inc.

---

From: Magnus Hagander <[email-masked]>
Date: Mon, 30 Jun 2008 15:54:08 +0200

> checkout of archives gets the needed files.

Ah, so there's an ulterior motive :-)

> get those files twice.  Is that too much of a problem for anyone?

Shouldn't be, they're tiny.

> HTML instead of having some embedded PHP.)

Check. I absoluteliy don't mind getting it folded into using the
standard stuff.

//Magnus

---

From: Magnus Hagander <[email-masked]>
Date: Mon, 30 Jun 2008 17:37:02 +0200

> it gets a 404 when loaded from archives.

Hmm. Yuck. That does make sense though :-)

> I guess another solution would be to fix all the relative paths in

Probably not a bad idea, to at least retain the ability. Care to submit
a patch? ;)

//Magnus