Subject: Wiki editor request

From: Jared Brogan <[email-masked]>
Date: Mon, 6 Feb 2023 13:05:22 -0600

To whom it may concern,

I would like to request the ability to edit and/or have someone edit on my
behalf in order to update the Quickstart section of the Apt wiki page.

   - https://wiki.postgresql.org/wiki/Apt

During some very tedious troubleshooting while trying to install postgresql
using the provided repository link, I ran into http 400 errors (`apt
update` would produce these, for example). After scouring various forums, I
was able to resolve the issue to my problem by simply changing http to
https within the /etc/apt/sources.list.d/pgdg.list file. I'd recommend
either changing that suggested command to create said file to include
https. An alternative to that, since it apparently doesn't impact all
machines the same way, would be to include a note below the command stating
that users may need to utilize https instead if connection errors arise.

Please let me know if you have any questions or concerns.

Thanks,
Jared Brogan

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 6 Feb 2023 13:34:23 -0800

On 2/6/23 11:05, Jared Brogan wrote:
> To whom it may concern,
> 
> I would like to request the ability to edit and/or have someone edit on 
> my behalf in order to update the Quickstart section of the Apt wiki page.
> 
>   * https://wiki.postgresql.org/wiki/Apt
>     <https://wiki.postgresql.org/wiki/Apt>
> 
> 
> During some very tedious troubleshooting while trying to install 
> postgresql using the provided repository link, I ran into http 400 
> errors (`apt update` would produce these, for example). After scouring 
> various forums, I was able to resolve the issue to my problem by simply 
> changing http to https within the /etc/apt/sources.list.d/pgdg.list 
> file. I'd recommend either changing that suggested command to create 
> said file to include https. An alternative to that, since it apparently 
> doesn't impact all machines the same way, would be to include a note 
> below the command stating that users may need to utilize https instead 
> if connection errors arise.
> 

Or follow the instructions from the actual download site:

https://www.postgresql.org/download/linux/ubuntu/

or

https://www.postgresql.org/download/linux/debian/

-- 
Adrian Klaver
[email-masked]

---

From: Jared Brogan <[email-masked]>
Date: Mon, 6 Feb 2023 15:40:33 -0600

Adrian,

I did follow those instructions, it didn't work, otherwise I wouldn't have
taken the effort of sending the original email.

Regards,
Jared

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 6 Feb 2023 13:46:47 -0800

On 2/6/23 13:40, Jared Brogan wrote:
> Adrian,
> 
> I did follow those instructions, it didn't work, otherwise I wouldn't 
> have taken the effort of sending the original email.

Hmm, a working example of pgdg.list:

cat /etc/apt/sources.list.d/pgdg.list

deb http://apt.postgresql.org/pub/repos/apt focal-pgdg main
deb https://apt-archive.postgresql.org/pub/repos/apt focal-pgdg-archive main

sudo apt update
[sudo] password for aklaver:

Hit:1 http://mirrors.linode.com/ubuntu focal InRelease
Hit:2 http://mirrors.linode.com/ubuntu focal-updates InRelease 

Hit:3 http://mirrors.linode.com/ubuntu focal-backports InRelease 

Hit:4 http://apt-longview.linode.com focal InRelease 

Hit:5 https://apt-archive.postgresql.org/pub/repos/apt 
focal-pgdg-archive InRelease
Get:6 http://security.ubuntu.com/ubuntu focal-security InRelease [114 
kB]
Hit:7 http://apt.postgresql.org/pub/repos/apt focal-pgdg InRelease
Get:8 http://security.ubuntu.com/ubuntu focal-security/main amd64 c-n-f 
Metadata [12.0 kB]

So what was the exact problem you got?

> 
> Regards,
> Jared
> 
> On Mon, Feb 6, 2023 at 3:34 PM Adrian Klaver <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>      >     <https://wiki.postgresql.org/wiki/Apt
>     <https://wiki.postgresql.org/wiki/Apt>>
>      >
>      >
>     <https://www.postgresql.org/download/linux/ubuntu/>
> 
>     or
> 
>     <https://www.postgresql.org/download/linux/debian/>
> 
>     [email-masked] <mailto:[email-masked]>
>

---

From: Jared Brogan <[email-masked]>
Date: Mon, 6 Feb 2023 15:52:47 -0600

Here's the output before changing to https and then afterwards:

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 6 Feb 2023 14:09:49 -0800

On 2/6/23 13:52, Jared Brogan wrote:
> image.png

That looks like DNS issues  from Azure to me.

In a browser I can do:

http://72.32.157.246:80/pub/repos/apt/

and get to the repo.

And if in a browser I do:

http://apt.postgresql.org/pub/repos/apt/

I end up at:

https://apt.postgresql.org/pub/repos/apt/

---

From: Jared Brogan <[email-masked]>
Date: Mon, 6 Feb 2023 16:13:27 -0600

Yeah, I'm not denying something like that may be happening. I mentioned in
my original message that this does not happen on every system, so if
anything a simple note could be appended to the current doc stating it
could resolve the issue.
If you (and presumably the rest of the wiki admins/contributors) deem this
not necessary, then I will not fight that. Just trying to help the larger
audience.

Thanks,
Jared Brogan

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 6 Feb 2023 14:34:47 -0800

On 2/6/23 14:13, Jared Brogan wrote:
> Yeah, I'm not denying something like that may be happening. I mentioned 
> in my original message that this does not happen on every system, so if 
> If you (and presumably the rest of the wiki admins/contributors) deem 
> this not necessary, then I will not fight that. Just trying to help the 
> larger audience.

1) I am not a site admin, so I don't have a say in this.

3) My comment would be that this is the equivalent of 'fixing' a car 
engine knock by turning up the radio. There is an underlying issue of 
which access to the Postgres repo may only be one part. It would seem to 
be the effort should be to fix that underlying issue.

> 
> Thanks,
> Jared Brogan
> 
> On Mon, Feb 6, 2023 at 4:09 PM Adrian Klaver <[email-masked] 
>     <http://72.32.157.246:80/pub/repos/apt/>
> 
>     and get to the repo.
> 
>     <http://apt.postgresql.org/pub/repos/apt/>
> 
>     I end up at:
> 
>     <https://apt.postgresql.org/pub/repos/apt/>
> 
>     -- 
>     Adrian Klaver

---

From: Magnus Hagander <[email-masked]>
Date: Tue, 7 Feb 2023 16:37:05 +0100

> That looks like DNS issues  from Azure to me.

I don't think it looks like DNS at all, it appears to resolve fine. It
looks more like an outbound firewall blocking traffic on port 80.

-- 
 Magnus Hagander
 Me: https://www.hagander.net/ <http://www.hagander.net/>
 Work: https://www.redpill-linpro.com/ <http://www.redpill-linpro.com/>

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 7 Feb 2023 08:14:44 -0800

> looks more like an outbound firewall blocking traffic on port 80.

Yeah, that makes more sense.