Subject: Clock skew with PG CVS repository?

From: Tom Lane <[email-masked]>
Date: Mon, 16 Jul 2007 17:17:49 -0400

I've noted a couple of cases recently that seem to indicate the CVS
machine's clock is a few seconds ahead of mine, eg just now I did
"cvs commit" and then immediately "make", and got this:

$ make
make: *** Warning: File `lock.c' has modification time in the future (2007-07-16 17:09:50 > 2007-07-16 17:09:43)
gcc -O1 -Wall -Wmissing-prototypes -Wpointer-arith -Winline -fno-strict-aliasing -g -I../../../../src/include -D_XOPEN_SOURCE_EXTENDED   -c -o lock.o lock.c
gcc -O1 -Wall -Wmissing-prototypes -Wpointer-arith -Winline -fno-strict-aliasing -g -I../../../../src/include -D_XOPEN_SOURCE_EXTENDED   -c -o proc.o proc.c
/usr/ccs/bin/ld -r -o SUBSYS.o lmgr.o lock.o proc.o deadlock.o lwlock.o spin.o s_lock.o
make: warning:  Clock skew detected.  Your build may be incomplete.
$

Manually issuing "date" on cvs.postgresql.org seems to confirm it's
about ten seconds fast compared to here.  Now NTP swears up and down
that I'm synced within a few milliseconds of three different reference
machines, so I think the problem is at that end.  Is cvs.postgresql.org
supposed to be running NTP?  'Cause I don't see any such daemon there.

I haven't noticed this type of problem before, so your machine usually
keeps good time, but right now it isn't.

			regards, tom lane

---

From: "Marc G. Fournier" <[email-masked]>
Date: Mon, 16 Jul 2007 21:39:36 -0300

- --On Monday, July 16, 2007 17:17:49 -0400 Tom Lane <[email-masked]> wrote:

> make: *** Warning: File `lock.c' has modification time in the future
> (2007-07-16 17:09:50 > 2007-07-16 17:09:43) gcc -O1 -Wall
> -Wmissing-prototypes -Wpointer-arith -Winline -fno-strict-aliasing -g
> -I../../../../src/include -D_XOPEN_SOURCE_EXTENDED   -c -o lock.o lock.c gcc
> -O1 -Wall -Wmissing-prototypes -Wpointer-arith -Winline -fno-strict-aliasing
> -g -I../../../../src/include -D_XOPEN_SOURCE_EXTENDED   -c -o proc.o proc.c
> /usr/ccs/bin/ld -r -o SUBSYS.o lmgr.o lock.o proc.o deadlock.o lwlock.o
> spin.o s_lock.o make: warning:  Clock skew detected.  Your build may be
> incomplete.
> $
>

Looking into it ...

- ----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email . [email-masked]                              MSN . [email-masked]
Yahoo . yscrappy               Skype: hub.org        ICQ . 7615664

---

From: "Marc G. Fournier" <[email-masked]>
Date: Mon, 16 Jul 2007 21:59:25 -0300

Fixed ...

- ----