Subject: Re: Search machine is ready

From: "John Hansen" <[email-masked]>
Date: Mon, 13 Mar 2006 01:25:31 +1100

Yay, it's now up and running...

Joshua, as I'm unfamilar with the ubuntu init scripts,. Could you please write one to start:

 searchd -D -R /usr/local/aspseek/etc/search.d/searchd_pg.conf

on startup, after postgresql.

For the time being,. I will run the update script manually, until I'm satisfied it runs glitch-free.
After that, it will need to be run as a cron job hourly.

It's '/usr/local/aspseek/etc/update-archives'

Kind Regards,

John

> -----Original Message-----
> From: Joshua D. Drake [mailto:[email-masked]] 
> Sent: Monday, March 06, 2006 6:49 AM
> To: John Hansen
> Cc: Dave Page
> Subject: Re: [pgsql-www] Search machine is ready
> 
> Good lord one a pain in the ass :)
> 
> I got it compiled and installed ;) it is all in /usr/local/aspseek...
> 
> 
> 
>

---

From: "John Hansen" <[email-masked]>
Date: Mon, 13 Mar 2006 01:29:16 +1100

Ohh,

I presume someone will need to update DNS now....
I will leave this side of it running until I see no more traffic.
Shouldn't be more than a few days, a week tops.

... John

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of John Hansen
> Sent: Monday, March 13, 2006 1:26 AM
> To: Joshua D. Drake
> Cc: Dave Page; [email-masked]
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 9: In versions below 8.0, the planner will ignore your desire to
>        choose an index scan if your joining column's datatypes do not
>        match
> 
>

---

From: "John Hansen" <[email-masked]>
Date: Mon, 13 Mar 2006 01:46:07 +1100

Works for me... 

> From: Magnus Hagander [mailto:[email-masked]] 
> Sent: Monday, March 13, 2006 1:43 AM
> To: John Hansen; Joshua D. Drake
> Subject: RE: [pgsql-www] Search machine is ready
> 
> How about we set up a temporary "search2" or sometihng and 
> have people pound on it for a couple of days before we switch over? 
> 
> //Magnus
> 
> > Ohh,
> > 
> > > For the time being,. I will run the update script manually,
> > until I'm
> > > satisfied it runs glitch-free.
> > TIP 1: if posting/reading through Usenet, please send an appropriate
> >        subscribe-nomail command to [email-masked] so that 
> > your
> >        message can get through to the mailing list cleanly
> > 
> 
>

---

From: "John Hansen" <[email-masked]>
Date: Mon, 13 Mar 2006 10:16:47 +1100

Joshua D. Drake Wrote:
> That is probably a good idea. Lets make sure the machine can 
> handle it.

Searches are not going to be a problem on this box :)

It's the indexing that is pretty resource intensive....

---

From: "John Hansen" <[email-masked]>
Date: Mon, 13 Mar 2006 15:40:09 +1100

Okay folks...

http://search2.postgresql.org/ is now ready for testing...

Please report any issues you may find,..

Kind Regards,

John Hansen

---

From: "Dave Page" <[email-masked]>
Date: Mon, 13 Mar 2006 08:36:45 -0000

> Sent: 13 March 2006 04:40
> To: [email-masked]

"Firefox can't find the server at search2.postgresql.org"

:-(

/D

---

From: "Magnus Hagander" <[email-masked]>
Date: Mon, 13 Mar 2006 09:44:48 +0100

> "Firefox can't find the server at search2.postgresql.org"

That would be that thing called DNS caching with timeout... Be patient!

//MAgnus

---

From: "Dave Page" <[email-masked]>
Date: Mon, 13 Mar 2006 08:47:36 -0000

> Sent: 13 March 2006 08:45
> To: Dave Page; John Hansen; [email-masked]

I wasn't aware that non-existence of records was cached.

/D

---

From: "John Hansen" <[email-masked]>
Date: Mon, 13 Mar 2006 20:00:02 +1100

Hmmm,.... Odd

The expire timeout for the SOA record is 5 hrs.
It was added way longer ago than that.

My own DNS has picked it up, but I know my ISP's DNS hasn't,. 
(and hence I can't test it myself yet, as they do transparent proxying)

Would most ISP's be conservative and specify a minimum TTL for ALL records, regardless of what they have been configured to?

... John

> Sent: Monday, March 13, 2006 7:45 PM

---

From: "John Hansen" <[email-masked]>
Date: Mon, 13 Mar 2006 20:03:02 +1100

> But actually - it's not on the lerctr.org servers. Perhaps 
> they don't respond to NOTIFYs or something?

Well, that would explain why my ISP hasn't picked it up yet, since lerctr.org are primary for the domain.

---

From: "John Hansen" <[email-masked]>
Date: Mon, 13 Mar 2006 23:11:30 +1100

Okay,

Can’t wait for this DNS business to clean itself up, so, I've made search2.postgresql.org the default site for the server, at least then you can connect on the IP as 

http://207.173.203.163/archives.search

That should be enough for testing purposes...

... John

---

From: "Dave Page" <[email-masked]>
Date: Mon, 13 Mar 2006 12:32:28 -0000

> Sent: 13 March 2006 12:12
> Can't wait for this DNS business to clean itself up, so, I've 
> made search2.postgresql.org the default site for the server, 
> at least then you can connect on the IP as 
> 

Yay, now that's speedy. It does seem to be left justified for some
reason though.

/D

---

From: "John Hansen" <[email-masked]>
Date: Mon, 13 Mar 2006 23:40:02 +1100

Dave Page Wrote:

> Yay, now that's speedy. 

Yea,. Faster connection makes a difference, tho it is a fraction slower than my box, but we're talking milliseconds on the initial query, microseconds on subsequent queries....

> It does seem to be left justified for some reason though.

What do you mean by 'left justified'?

Is it any different than http://search.postgresql.org ?

I seem to get the same look from both?

... John

---

From: "Dave Page" <[email-masked]>
Date: Mon, 13 Mar 2006 12:46:02 -0000

> From: John Hansen [mailto:[email-masked]] 
> Sent: 13 March 2006 12:40
> To: Dave Page; [email-masked]
> Yea,. Faster connection makes a difference, tho it is a 
> fraction slower than my box, but we're talking milliseconds 
> on the initial query, microseconds on subsequent queries....
> 

The page content is not in the middle, like www.postgresql.org.

> Is it any different than http://search.postgresql.org ?

No, that seems to be borked as well :-(

/D

---

From: "John Hansen" <[email-masked]>
Date: Mon, 13 Mar 2006 23:49:00 +1100

> No, that seems to be borked as well :-(

Well, there you go,...
The templates are in /usr/local/aspseek/htdocs if you wanna have a fiddle...

... John

---

From: "Dave Page" <[email-masked]>
Date: Mon, 13 Mar 2006 12:50:01 -0000

> Sent: 13 March 2006 12:49

'k

/D

---

From: "John Hansen" <[email-masked]>
Date: Tue, 14 Mar 2006 04:47:25 +1100

Guys,

The indexing part of things seems to be running smoothly.
I've done a bit of testing myself, and searches seems fast enough.

Nothing more for me to do, so I'm quite happy to switch over at this stage.

... John