Subject: Re: Search machine is ready

From: "Magnus Hagander" <[email-masked]>
Date: Mon, 13 Mar 2006 09:57:40 +0100

> > > > Okay folks...
> > > > 
> > > > 
> > > > http://search2.postgresql.org/ is now ready for testing...
> > > > 
> > > > Please report any issues you may find,..
> > > 
> > > "Firefox can't find the server at search2.postgresql.org"
> > > 
> > > :-(
> > 
> > That would be that thing called DNS caching with timeout... 
> > Be patient!
> 
> I wasn't aware that non-existence of records was cached.

Not on the client (actually they are, but generally just for a minute or
five), but I bet the whole zone is cached at your resolver...

If you point to a hub.org DNS server it's there.

But actually - it's not on the lerctr.org servers. Perhaps they don't
respond to NOTIFYs or something?

//Magnus

---

From: "Larry Rosenman" <[email-masked]>
Date: Mon, 13 Mar 2006 09:10:43 -0600

Magnus Hagander wrote:
> Not on the client (actually they are, but generally just for a minute
> or five), but I bet the whole zone is cached at your resolver...
> 
Am I pointing at the wrong master:
Mar 12 22:59:41 lerami named[1352]: zone postgresql.org/IN: refused notify
from non-master: 200.46.208.251#2330
Mar 12 22:59:50 lerami named[1352]: client 200.46.204.254#4289: received
notify for zone 'postgresql.org'

//PostgreSQL Global Development Group/Marc Fornier ([email-masked])
zone "postgresql.org" {
        type slave;
        file "cache/postgresql.org";
        masters {
                200.46.204.2;
        };
};
zone "mirrors.postgresql.org" {
        type slave;
        file "cache/mirrors.postgresql.org";
        masters {
                62.65.68.81;
        };
};
-- 
Larry Rosenman                     http://www.lerctr.org/~ler
Phone: +1 512-248-2683                 E-Mail: [email-masked]
US Mail: 430 Valona Loop, Round Rock, TX 78681-3893

---

From: "Marc G. Fournier" <[email-masked]>
Date: Mon, 13 Mar 2006 12:37:59 -0400 (AST)

>        file "cache/postgresql.org";

Ya, master has been 200.46.204.13 for awhile now ...

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: "Larry Rosenman" <[email-masked]>
Date: Mon, 13 Mar 2006 10:51:07 -0600

Marc G. Fournier wrote:
>>> Not on the client (actually they are, but generally just for a
>>> minute or five), but I bet the whole zone is cached at your
>>> resolver... 
>>> 
>>> But actually - it's not on the lerctr.org servers. Perhaps they
>>> don't respond to NOTIFYs or something?
>>> 
>>> //Magnus
>> Mar 12 22:59:41 lerami named[1352]: zone postgresql.org/IN: refused
>> notify from non-master: 200.46.208.251#2330
>> Mar 12 22:59:50 lerami named[1352]: client 200.46.204.254#4289:
>> received notify for zone 'postgresql.org'
>> 
> Marc G. Fournier           Hub.Org Networking Services
> (http://www.hub.org) Email: [email-masked]           Yahoo!:
> yscrappy              ICQ: 7615664 

Updated, and refreshed.

Ya gotta tell me these things.....

LER