Subject: Re: Todo for 'portal', programmers perspective

From: "Dave Page" <[email-masked]>
Date: Fri, 16 Jan 2004 08:18:39 -0000

> -----Original Message-----
> From: Jeroen Ruigrok/asmodai [mailto:[email-masked]] 
> Sent: 16 January 2004 05:33
> To: Peter Eisentraut
> Cc: Dave Page; Alexey Borzov; [email-masked]
> Subject: Re: [pgsql-www] Todo for 'portal', programmers perspective
> 
> -On [20040116 00:03], Peter Eisentraut ([email-masked]) wrote:
> >In fact I would propose, for a future iteration perhaps, to put each 
> >file in a separate directory and name them index.lang.{html,php} and 
> >only publish the directory based URLs.  Compare the links at
> 
> For the one configuring the httpd.conf, using Peter's 
> suggestion, make sure to have:
> 
> DirectoryIndex	index
> 
> since it needs to match: index + .lang + .extension

Hmm, that will cause pain. Currently we rely on the line:

DirectoryIndex	index.html index.php

The extensions (and their order) are part of the way the whole system
works.

Regards, Dave.

---

From: Jeroen Ruigrok/asmodai <[email-masked]>
Date: Fri, 16 Jan 2004 09:26:23 +0100

>The extensions (and their order) are part of the way the whole system

Then you'd need to go the file.html.lang route.

-- 
Jeroen Ruigrok van der Werven <asmodai(at)wxs.nl> / asmodai / kita no mono
PGP fingerprint: 2D92 980E 45FE 2C28 9DB7  9D88 97E6 839B 2EAC 625B
http://www.tendra.org/   | http://diary.in-nomine.org/
Don't try to find the Answer where there ain't no Question here...