Subject: Re: Server unreliability

From: "Dave Page" <[email-masked]>
Date: Thu, 30 Sep 2004 08:16:12 +0100

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Devrim GUNDUZ
> Sent: 29 September 2004 18:26
> To: Bruce Momjian
> Cc: PostgreSQL WWW Mailing List; PostgreSQL advocacy
> Subject: Re: [pgsql-www] Server unreliability
> 
> :-) A Google search box could be better sometimes...

Not now they've stopped archiving the largest chunk of our sites -
namely the lists.

/D

---

From: "Dave Page" <[email-masked]>
Date: Thu, 30 Sep 2004 08:17:53 +0100

> [mailto:[email-masked]] On Behalf Of Marc G. Fournier
> Sent: 29 September 2004 18:53
> To: Bruce Momjian
> Cc: PostgreSQL www; PostgreSQL advocacy
> We've also added in hot failover as an option ... I've posted 
> to -www asking about putting www.postgresql.org onto it, but 
> so far, the only responses back have been along the lines of 
> 'how are you doing it?' ...

Err, no. I checked what's on WWW and told you it wasn't a problem, go
ahead.

Regards, Dave.

---

From: "Dave Page" <[email-masked]>
Date: Thu, 30 Sep 2004 08:30:13 +0100

> [mailto:[email-masked]] On Behalf Of Bruce Momjian
> Sent: 29 September 2004 21:18
> To: Devrim GUNDUZ
> Yes, but how far is it from the image I saw to the completed 
> site?  

http://wwwdevel.postgresql.org/

> I have no idea, and why has there been so little 
> progress in the past few years?

The current site is only a little over 18 months old iirc. I'd hardly
call that little progress in years...

Regards, Dave

---

From: "Dave Page" <[email-masked]>
Date: Thu, 30 Sep 2004 08:32:35 +0100

> Sent: 29 September 2004 23:03
> To: Bruce Momjian
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> Hi,
> 
> On Wed, 29 Sep 2004, Bruce Momjian wrote:
> 
> > Yes, except Google has decided to stop archiving our groups since 
> > September 16.  We reported this on the www list, I think.  I think 
> > they had the best archive interface, and now it is gone.  
> Take a look:
> >
> > 	
> > 
> http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&c2coff=1&group=comp
> > .databases.postgresql.hackers
> 
> Dave has contacted with Google, and I'm sure that they'll 
> solve this problem. See:

It's not looking good. I think we're going to need a mass of complaints
form the users.

Regards, Dave

---

From: "Dave Page" <[email-masked]>
Date: Thu, 30 Sep 2004 08:51:43 +0100

> [mailto:[email-masked]] On Behalf Of Alexey Borzov
> Sent: 29 September 2004 22:38
> To: Bruce Momjian
> Cc: PostgreSQL WWW Mailing List
> As for the "past few years" --- I've no idea. I volunteered 
> only this year and had to overcome some resistance when I 
> said that the current site is inadequate.

Err, yes. Well that wasn't so much resistance to it being changed as I'm
sure you remember. Thankfully that's all behind us now though...

Regards Dave

---

From: "Dave Page" <[email-masked]>
Date: Thu, 30 Sep 2004 08:54:55 +0100

> Sent: 29 September 2004 20:13
> To: Darcy Buskermolen
> Cc: Bruce Momjian; [email-masked]; 
> [email-masked]
> Subject: Re: [pgsql-www] [pgsql-advocacy] Server unreliability
> 
> On Wed, 29 Sep 2004, Darcy Buskermolen wrote:
> 
> >> I think you are the only 'known to work site' ... so, if I setup a 
> >> round robin between the Panama and Canadian location for 
> >> www.postgresql.org, would you be okay with the extra load? 
> :)  If so, 
> >> I'll get to work on the coding changing required for the DNS ...
> >
> > I have no issues with that being setup now, I'll keep na eye on the 
> > bandwith and let you know if it becomes problematic.
> 
> 'k, will play with the DNS code tonight then ...

*Before* you do anything, make sure there is a www-master.postgresql.org
DNS/Vhost for the main server, and any HTML forms are recoded to submit
data to there.

Cheers, Dave.

---

From: "Dave Page" <[email-masked]>
Date: Thu, 30 Sep 2004 14:36:07 +0100

> From: Alvaro Herrera [mailto:[email-masked]] 
> Sent: 30 September 2004 14:33
> To: Marc G. Fournier
> Subject: Re: [pgsql-advocacy] [pgsql-www] Server unreliability
> 
> On Wed, Sep 29, 2004 at 06:20:37PM -0400, Alvaro Herrera wrote:
> 
> > Now that people are talking about www and archives, please 
> take a look 
> > at a problem I've pointed a couple of times in the past and had no
> > answer: the pgsql-es-ayuda list is not on the left column.  
> It's also 
> > not listed on the " Search in: " combo box at the top either.
> 
> Oh, another one:  Here
> 
> http://search.postgresql.org/archives.search?cs=utf-8&fm=on&st
> =20&dt=back&q=llave+foranea&ul=http%3A%2F%2Farchives.postgresq
> l.org%2Fpgsql-es-ayuda%2F%25&dp=0&o=0&ps=10&s=date
> 
> the pgsql-es-ayuda is not in the upper combo box.  This is 
> the page that's presented as result from a search (it was 
> originally restricted to pgsql-es-ayuda).
> 
> It seems really weird to have two lists of lists, one at the 
> top when you are looking at plain archives, and other when 
> you are looking at search results.  Most certainly they 
> should be identical!  Why aren't they one and the same?

They're on different servers. The plain archives are at CommandPrompt,
and the search engine is in Australia.

John, can you fix the template at your end please?

Cheers, Dave.

---

From: "John Hansen" <[email-masked]>
Date: Thu, 30 Sep 2004 23:42:55 +1000

> 
> They're on different servers. The plain archives are at 
> CommandPrompt, and the search engine is in Australia.
> 

Done,

.. John