Subject: Re: Alternate PostgreSQL.org Design

From: "Dave Page" <[email-masked]>
Date: Fri, 12 Nov 2004 17:01:36 -0000

> -----Original Message-----
> From: Gavin M. Roy [mailto:[email-masked]] 
> Sent: 12 November 2004 16:51
> To: Dave Page
> Cc: Robert Treat; Omar Kilani; [email-masked]
> Subject: Re: [pgsql-www] Alternate PostgreSQL.org Design
> 
> Since this design is "drop-in" ready requiring only minor 
> changes, perhaps we should resurrect the idea of a vote 

Yes, sounds fine to me.

> (maybe on Advocacy).  Any thoughts on that?

Not on -advocacy. That list does not, and has never contributed directly
to the web stuff. That's what we have -www for.

Regards, Dave

---

From: "Gavin M. Roy" <[email-masked]>
Date: Fri, 12 Nov 2004 10:37:54 -0800

>Not on -advocacy. That list does not, and has never contributed directly to the web stuff. That's what we have -www for.
>
>Regards, Dave
>
The idea here, and I know that people don't agree, but websites are the public marketing front for projects like this.  Advocacy has as much to do with that as the people on www that make it happen.  While documentation and such are important, one can argue that those are marketing tools, since users would be less apt to use PgSQL if the website didn't have the info.  The website is one of the things that new users evaluate, even subconsciously, before making a decision.  The more professional we look in web presence, the more comfortable users will be with PgSQL at an Enterprise level.

Ultimately I also think we need to take the vote out of the hands of the implementors and into the hands of a potential test market as they will be more representative of user impression.  I would even go as far as to suggest the radical idea of offering the vote to pgsql-general and letting the active community at large decide.
</marketing_hat>

Gavin

---

From: "Joshua D. Drake" <[email-masked]>
Date: Fri, 12 Nov 2004 11:17:58 -0800

>>
> The idea here, and I know that people don't agree, but websites are the 
> public marketing front for projects like this.  Advocacy has as much to 
> do with that as the people on www that make it happen.  While 
> documentation and such are important, one can argue that those are 
> marketing tools, since users would be less apt to use PgSQL if the 
> website didn't have the info.  The website is one of the things that new 
> users evaluate, even subconsciously, before making a decision.  The more 
> professional we look in web presence, the more comfortable users will be 
> with PgSQL at an Enterprise level.
> 
> Ultimately I also think we need to take the vote out of the hands of the 
> implementors and into the hands of a potential test market as they will 
> be more representative of user impression.  I would even go as far as to 
> suggest the radical idea of offering the vote to pgsql-general and 
> letting the active community at large decide.
> </marketing_hat>

This is absolutely correct.

Sincerely,

Joshua D. Drake

> 
> Gavin
> 
> 
> ---------------------------(end of broadcast)---------------------------
> TIP 2: you can get off all lists at once with the unregister command
>    (send "unregister YourEmailAddressHere" to [email-masked])

-- 
Command Prompt, Inc., home of PostgreSQL Replication, and plPHP.
Postgresql support, programming shared hosting and dedicated hosting.
+1-503-667-4564 - [email-masked] - http://www.commandprompt.com
Mammoth PostgreSQL Replicator. Integrated Replication for PostgreSQL

---

From: Robert Treat <[email-masked]>
Date: 12 Nov 2004 14:37:57 -0500

On Fri, 2004-11-12 at 13:37, Gavin M. Roy wrote:
> 
> >Not on -advocacy. That list does not, and has never contributed
directly to the web stuff. That's what we have -www for.
> >
> >Regards, Dave
> >
> The idea here, and I know that people don't agree, but websites are
> the public marketing front for projects like this.  Advocacy has as 
> much to do with that as the people on www that make it happen.  While 
> website didn't have the info.  The website is one of the things that 
> new users evaluate, even subconsciously, before making a decision.  
> The more professional we look in web presence, the more comfortable 
> users will be with PgSQL at an Enterprise level.
> 

I don't necessarily disagree with you on these items, but the same
argument could be said for including ODBC/JDBC Drivers, PgAdmin Gui
Tool, or Slony, into the main postgresql product. Database customers
generally "expect" those things to be include in their software package,
yet no one seems to be up in arms over -core's decision to toss those
things out of the main code base. 

Besides, of the folks heavily involved in advocacy (of which I happen to
be one), the majority of those folks follow this list, so there concerns
are not being ignored.    

> Ultimately I also think we need to take the vote out of the hands of 
> the implementors and into the hands of a potential test market as they
> will be more representative of user impression.  I would even go as 
> far as to suggest the radical idea of offering the vote to 
> pgsql-general and letting the active community at large decide.
> </marketing_hat>
> 

Sorry, but the site has goals of things it needs to accomplish and that
goes beyond "looking cool". I've worked in usability and information
architecture and know the things that need to be accomplished with an
organizations main website and if you leave it up to the general public
your looking for trouble. 

Robert Treat
-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL

---

From: "Gavin M. Roy" <[email-masked]>
Date: Fri, 12 Nov 2004 11:47:59 -0800

>your looking for trouble. 
Appearance and usability are both important factors.  Are you saying 
that people outside of -www are not capable of judging both?

Gavin

---

From: "Marc G. Fournier" <[email-masked]>
Date: Fri, 12 Nov 2004 16:10:01 -0400 (AST)

On Fri, 12 Nov 2004, Gavin M. Roy wrote:

> Appearance and usability are both important factors.  Are you saying that 
> people outside of -www are not capable of judging both?

The wider the audience, the harder it becomes to come to a consensus ... 
those that are interested in the web site developments have/should join 
the -www list, just like you did, and put in their 2 cents ...

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: "Gavin M. Roy" <[email-masked]>
Date: Fri, 12 Nov 2004 12:17:02 -0800

I'm not talking about opening it to input and design suggestions, i'm 
talking about a vote:

A if you like the design at url1
B if you like the design at url2

Not open ended, not allowing for people to say "yeah but do this or do that"

Gavin

Marc G. Fournier wrote:

> The wider the audience, the harder it becomes to come to a consensus 
> ... those that are interested in the web site developments have/should 
> join the -www list, just like you did, and put in their 2 cents ...
>
> ----
> TIP 9: the planner will ignore your desire to choose an index scan if 
> your
>      joining column's datatypes do not match

---

From: Robert Treat <[email-masked]>
Date: 12 Nov 2004 15:36:17 -0500

Actually all of this call for a vote seems a little premature IMHO. We
have problems with both designs that need to be addressed. Let's see
what shakes out from that discussion before we put it up for a vote,
after all we just might form a consensus anyway. 

Robert Treat

On Fri, 2004-11-12 at 15:17, Gavin M. Roy wrote:
> TIP 7: don't forget to increase your free space map settings

---

From: Oleg Bartunov <[email-masked]>
Date: Fri, 12 Nov 2004 23:39:53 +0300 (MSK)

Hi there,

there will be many waves of 'new/alternative' design, so I propose
voluntary approach  but with requirement of presence of "mandatory" part.
"mandatory" part should be available via http/rsync/ftp for mirroring.
I'd be happy to mirror on www.pgsql.ru, for example, pg announcements,
catalog of links to pg resources, documentations.
Having such mandatory parts/pieces of information it's easy to
to have design 1,2,3 as Gavin proposed. cookies could store preferences,
so no different url required.

 	Oleg
On Fri, 12 Nov 2004, Gavin M. Roy wrote:

> I'm not talking about opening it to input and design suggestions, i'm talking 
> about a vote:
>
>> those that are interested in the web site developments have/should join the 
>> -www list, just like you did, and put in their 2 cents ...
>> 
>> ----
>> TIP 9: the planner will ignore your desire to choose an index scan if your

 	Regards,
 		Oleg
_____________________________________________________________
Oleg Bartunov, sci.researcher, hostmaster of AstroNet,
Sternberg Astronomical Institute, Moscow University (Russia)
Internet: [email-masked], http://www.sai.msu.su/~megera/
phone: +007(095)939-16-83, +007(095)939-23-83

---

From: Josh Berkus <[email-masked]>
Date: Fri, 12 Nov 2004 13:16:53 -0800

Folks,

> B if you like the design at url2

Personally, I have one and only one criterion:  which one will get done first?

-- 
--Josh

Josh Berkus
Aglio Database Solutions
San Francisco