Subject: Re: Alternate PostgreSQL.org Design

From: "Magnus Hagander" <[email-masked]>
Date: Fri, 12 Nov 2004 10:10:37 +0100

> Hi Again,
> 
> We would like to put forward an alternate design to the 
> current wwwdevel design.
> 
> It is available at: http://postgresql.tinysofa.com/
> 
> We believe that it is clean, professional and simple. And it 
> makes the release of 8.0 actually... exciting. :)
> 
> It is a *drop-in* replacement for the current pgweb design. 
> No additional work is required to retrofit the current 
> wwwdevel design. 
> It's already done!

Not quite. My pet-peeve is back :-) I managed to get Alexey to change
About to Overview. It just seems very weird to find things like
"Interfacing postgresql with other software" under "About". Just my
opinion of course, and since things seem to drop back into About now and
then, perhaps I'm the only one with it.

> It validates. It is designed for 800x600 and up. And it looks 
> pretty. :)

It indeed looks very good. But is there any reason why it can't be made
to use the full width of a browser window if it's large? It seems to
just center in the browser now...

> Of course, we're willing to help out with the content if our 
> design is used. :)

Only with that design? :P I'm sure there are a lot of help needed with
content regardless of design, and since content and design aren't locked
together...

//Magnus

---

From: "Dave Page" <[email-masked]>
Date: Fri, 12 Nov 2004 22:41:23 -0000

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Bruce Momjian
> Sent: 12 November 2004 22:26
> To: Alexey Borzov
> Cc: Josh Berkus; [email-masked]; Omar Kilani; 
> [email-masked]
> Subject: Re: [pgsql-advocacy] [pgsql-www] Alternate 
> PostgreSQL.org Design
> 
> Alexey Borzov wrote:
> > Hi,
> > 
> > Bruce Momjian wrote:
> > > Is the new website going to be rolled out in time for the 8.0 
> > > release, which could be in the next few weeks?
> > 
> > No.
> 
> OK, fair enough.  Now can someone explain how we can put out 
> a release evrery 8-12 months with 200-300 changes, some very 
> complex, and we can't get a group together to update a web site?

Because despite lots of noise, virtually no-one ever actually helps out.
Marc, Robert, Devrim and I do what we can on the main sites, but as you
know, we all have fingers in many other pies. People like John Hansen,
Chris Ryan and Andrew Dunstan have kindly taken on projects like search,
gborg and pgfoundry, but these sites are obviously more specialised. The
only person working totally on the portal is Alexey, and the only
material contributions from others have been designs (from Gavin, Lukasz
and Tinysofa), and a couple of patches from Gavin S.

Apologies for any other regulars I might have forgotten, but you get my
point!

Regards Dave.

---

From: "Dave Page" <[email-masked]>
Date: Fri, 12 Nov 2004 22:47:11 -0000

> Sent: 12 November 2004 22:33
> To: [email-masked]
> Cc: [email-masked]; Alexey Borzov; Omar 
> Kilani; [email-masked]
> Well, even if you take out the paid folks, PostgreSQL would 
> be doing a lot more than the www site is.  Remember we had no 
> paid guys for the first few years.

People have far more motivation to work on the server - that want to use
it's features. Most of us don't actually need to use the website.

> I am suggesting that we are not properly harnessing the 
> talent we have.
> That is a big part of the success in the code portion of the project.

<mutters>don't mention odbc, don't mention odbc, don't mention
odbc</mutters>

Seriously though, yes, I agree. We have more than enough talent here. As
Marc says, it just isn't glamourous work, or work that is liekly to
directly benefit any volunteers, other than perhaps the designers who
put their names at the bottom.

Regards, Dave.

---

From: "Dave Page" <[email-masked]>
Date: Fri, 12 Nov 2004 23:03:54 -0000

> From: Bruce Momjian [mailto:[email-masked]] 
> Sent: 12 November 2004 22:59
> To: Dave Page
> Cc: Marc G. Fournier; Alexey Borzov; Josh Berkus; 
> [email-masked]; Omar Kilani; [email-masked]
> > > Maybe my dancing elephant image would help in this area.  :-)
> > 
> > Nah, the colour scheme is all wrong. Can you get a blue one?
> 
> OK, fixed:
> 
> 	http://candle.pha.pa.us/tmp/dancing-elephant.jpg
> 
> Now, who said web development wasn't fun?

:-)

/D

---

From: "Dave Page" <[email-masked]>
Date: Sat, 13 Nov 2004 12:18:25 -0000

> From: Robert Treat [mailto:[email-masked]] 
> Sent: 13 November 2004 05:44
> To: Gavin M. Roy
> Cc: Dave Page; Bruce Momjian; Alexey Borzov; Josh Berkus; 
> Subject: Re: [PASCAL-advocacy] [PASCAL-www] Alternate 
> PostgreSQL.org Design
> 
> Gavin, you are on the -www list aren't you? It's been posted 
> there many times. 
> Just in case not, it's at http://wwwdevel.postgresql.org/todo

It was posted with some other URLs you might find useful earlier in this
very thread :-)

Web CVS: http://gborg.postgresql.org/project/pgweb/cvs/cvs.php/portal
Commiter list: http://gborg.postgresql.org/pipermail/pgweb-commits/

> > Alexey posted a tarball of his source, but after my last 
> contribution 
> > via email to the current  Lucaz design went completely 
> unnoticed and 
> > didnt even receive a no-thanks, we'd rather keep it the way 
> it is, I'm 
> > a bit out of the loop on what it takes to actually get 
> something done.
> 
> Huh?  IIRC the last patch I saw you send in was applied by 
> Dave a couple days later?

Wrong Gavin! I don't recall seeing anything from you, Gavin (M Roy). Can
you resend it please - maybe my spam filters were bored that day.

> > >I realise I'm probably one of the people you accuse of 
> being rude and 
> > >shooting down ideas (and if I have been rude to anyone, 
> please excuse 
> > >me
> >
> > To be honest, I can only come up with a few people off hand and you 
> > werent one of them Dave ;).  That's not to say.. well never mind.

I'm not entirely sure how to take that!

> This is generally true only if it is a rehash of something we 
> have been over dozens of times.  Kind of like when people 
> pop-up on -hackers and say "I'm ready to start coding up a 
> threaded back-end, which files should I be looking 
> at"    

Wow, that's exactly the analagy I was going to use`

> Otherwise my experience has been more of people asking 
> what they can 
> do to help and us responding with "look at the todo/look at 
> the portal code" 
> and then people either disappear or people point out they 
> were hoping to implement some CMS or other radical whizbang 
> code and then they disappear after we we don't get 
> enthusiastic about it. 

That's almost precisely my view of the situation.

> You have to realize that this is at least the 5th design we 
> have seen for the new site, none of which get us any closer 
> to getting the new site launched if for no other reason that 
> each of these designs seems to spur another round of website 
> flaming.  Also, for the record, I ask the tinysofa people if 
> they would be interested in submitting some updated banners 
> and/or buttons for our propaganda page and got no response.  
> That's another example of us trying to find ways for people 
> to get involved and people not bothering when it's not on 
> their personal agenda. 

Would they still want to do it if there was no link to their website at
the bottom of each page? Incidently, Lukasz' design didn't originally
have such a link. We suggested he put one there by way of thanks.

Just a thought...

Regards, Dave.