Subject: [PATCH] Events Reorganization

From: Omar Kilani <[email-masked]>
Date: Tue, 16 Nov 2004 00:45:24 -0500

Hello,

Patches and table dumps pertinent to this email are at:

http://postgresql.tinysofa.com/files/patches/01-event/

Database Dumps
==============

000-events.dump
---------------

Dump of 'events' table, with:

* New field additions: city, state, country.
* All entries assigned a city, state (if applicable) and country.
* All entries with proper start and end dates.

001-events_text.dump
--------------------

Dump of 'events_text' table, with:

* Entries edited to remove redundant information addressed by above 
changes to 'events'.
* Any translations found in archived entries has been properly inserted 
as a translation (see our pgweb, go to the events archive, and switch to 
"Turkish" to see some of Devrim's entries translated.)

002-countries.dump
------------------

Dump of new 'countries' (note: plural names for tables are bad) table, with:

* Fields: id, country, tld
* Information is taken from the CIA World Facts book.

Patches
=======

01-pgweb-ts-events-admin-template.patch
---------------------------------------

* Change the events output in the admin system to show location.

02-pgweb-ts-events-admin.patch
------------------------------

* Change the events edit screen to allow entry of city, state and country.
* Add templating function 'format_location' to... format location.

03-pgweb-ts-events-system.patch
-------------------------------

* Change user event submission form to feature city, state and country.
* Add 'fetch_countries_list' to database functions.
* Provide a 'location' template variable to the events templates.

04-pgweb-ts-events-template.patch
---------------------------------

* Change event-related templates to show a "Location".
* Fix event detail screen to show proper posted_by.

Omar

---

From: "Dave Page" <[email-masked]>
Date: Tue, 16 Nov 2004 10:05:16 -0000

Hi Omar,

Thanks for this - however, now we have a problem...

At the moment, the new portal is running from a new database that is
periodically refreshed by dumping the current live database and running
an update script to convert it into the new format (see
tools/update.sql). Because of the continuing updates to the current
database (new news etc) we need to be able to refresh in this way until
we put the new site live.

So, sorry to be a pita, but can you please resubmit database updates as
changes to update.sql?

Regards, Dave

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Omar Kilani
> Sent: 16 November 2004 05:45
> To: [email-masked]
> Subject: [pgsql-www] [PATCH] Events Reorganization
> 
> Hello,
> 
> * Entries edited to remove redundant information addressed by 
> above changes to 'events'.
> * Any translations found in archived entries has been 
> properly inserted as a translation (see our pgweb, go to the 
> events archive, and switch to "Turkish" to see some of 
> Devrim's entries translated.)
> 
> 002-countries.dump
> ------------------
> 
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 1: subscribe and unsubscribe commands go to 
> [email-masked]
>