Subject: Primary webserver move

From: "Dave Page" <[email-masked]>
Date: Tue, 16 Nov 2004 22:37:34 -0000

Earlier this evening, Marc & I finished moving the primary front end web
server to a box in the US. This machine is very lightly loaded, running
only 3 VMs, 2 of which are postgresql.org ones. All pages remain built
on svr2.postgresql.org, which also processes any interactive pages
through it's new hostname, scripts.postgresql.org.

If anyone notices any problems, please let us know.

Regards, Dave.

---

From: Gavin Sherry <[email-masked]>
Date: Wed, 17 Nov 2004 09:57:03 +1100 (EST)

> If anyone notices any problems, please let us know.

I get a 404 for index.php when I go to the front page.

>
> Regards, Dave.
>
> ---------------------------(end of broadcast)---------------------------
> TIP 3: if posting/reading through Usenet, please send an appropriate
>       subscribe-nomail command to [email-masked] so that your
>       message can get through to the mailing list cleanly
>

---

From: Michael Fuhr <[email-masked]>
Date: Tue, 16 Nov 2004 17:44:20 -0700

> If anyone notices any problems, please let us know.

My DNS server still has "www.postgresql.org. CNAME svr2.postgresql.org."
in its cache and that machine gives 404 for the following images:

/images/gif/pgsqlicon2.gif
/images/jpg/lily001top.jpg
/images/jpg/lily001bottom.jpg

Those images do get served up if I hit http://svr2.postgresql.org/
instead of http://www.postgresql.org/.  My proxy logs show that
both requests go to the same address (200.46.204.209).

It looks like the new CNAME record points to svr4.postgresql.org
(66.98.251.159).  I tried to hit http://svr4.postgresql.org/ and
got a redirect to http://www.svr4.postgresql.org, which doesn't
exist.  It might be useful if that server could be configured
to work for http://svr4.postgresql.org/.

-- 
Michael Fuhr
http://www.fuhr.org/~mfuhr/

---

From: Justin Clift <[email-masked]>
Date: Wed, 17 Nov 2004 11:46:35 +1100

Michael Fuhr wrote:
<snip>
> /images/jpg/lily001bottom.jpg

Hmmm, not sure if it's helpful, but from memory those two files are from 
the Advocacy website.

?

Regards and best wishes,

Justin Clift

---

From: Michael Fuhr <[email-masked]>
Date: Tue, 16 Nov 2004 17:49:12 -0700

> in its cache and that machine gives 404 for the following images:

I just checked again and svr2 is really foobar now -- little content
and 404s for the style sheet and the icons.

---

From: "Marc G. Fournier" <[email-masked]>
Date: Tue, 16 Nov 2004 21:06:11 -0400 (AST)

> and 404s for the style sheet and the icons.

But ... we never changed anything on the old server for this, only changed 
the DNS to point to the new IP ...

Am working on it though ... will post a follow up once I figure out what 
went wrong, since Dave and I both tested from our browsers after the DNS 
change :(

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: Michael Fuhr <[email-masked]>
Date: Tue, 16 Nov 2004 18:32:23 -0700

> the DNS to point to the new IP ...

The page I'm seeing is identical to http://www.mirrorservice.org/
except that the images are broken.  Possibly a virtual hosting
config issue that depended on the old DNS record?

---

From: "Marc G. Fournier" <[email-masked]>
Date: Tue, 16 Nov 2004 21:34:14 -0400 (AST)

'k, fixed for now ... Dave tested everything before we switch the DNS 
over, but I think he missed the build script itself ... not 100%, but I 
just changed DNS back again for tonight, and Robert/I just fixed the build 
script so that the proper site is building ...

the rest I leave for Dave in the morning ...

On Tue, 16 Nov 2004, Michael Fuhr wrote:

> TIP 5: Have you checked our extensive FAQ?
>
>               http://www.postgresql.org/docs/faqs/FAQ.html
>

----

---

From: Michael Fuhr <[email-masked]>
Date: Tue, 16 Nov 2004 18:34:50 -0700

On Tue, Nov 16, 2004 at 06:32:23PM -0700, Michael Fuhr wrote:

> except that the images are broken.

I lied -- the pages aren't identical but they do appear to be related.