Subject: Re: Infrastructure monitoring

From: "John Hansen" <[email-masked]>
Date: Sat, 14 Jan 2006 20:22:09 +1100

>  In the case of search ... John would be better at answering that, but when 
>  he and I talked this past week, he mentioned that he was moving it all
>  over to two new servers, which I changed the DNS for on Wednesday ...
 
Yea, hardware is being monitored, and I get SMS notification,. 
I am however often on the road for 12 hours or more, and am thus unable to respond until I get home.

.... John

---

From: "John Hansen" <[email-masked]>
Date: Sat, 14 Jan 2006 22:36:52 +1100

> 
> > In the case of search ... John would be better at answering that, but 
> > when he and I talked this past week, he mentioned that he was moving 
> > it all over to two new servers, which I changed the DNS for on Wednesday ...
> 
> What I think would be good in cases like this is just 
> information - AFAIK nobody on the web team knew hte servers 
> were being moved. (I may be wrong here - I know I didn't know 
> and I also spoke to Dave about it, but those are the only 
> ones I polled. Anyway, -www should know)
> 
> That would also make it possible to do the standard fiddling 
> with DNS TTLs to make the problem much smaller.
> 

Right, I should have posted to -www that they were being moved, but forgot in the rush.
It has been under way for some time now, tho unofficially, but became urgent due to a crash.

My Apologies.

Kind Regards,

John

---

From: "John Hansen" <[email-masked]>
Date: Sun, 15 Jan 2006 17:03:45 +1100

> - the only other oddity that I can recall is that ASPSeek must be compiled with 
> gcc 2.95 due to some changes in the hashing functions in the STL in 
> later versions which cause index bloat.

I've managed to get around that, by removing some compiler optimizations....

... John

---

From: "Dave Page" <[email-masked]>
Date: Sun, 15 Jan 2006 10:03:42 -0000

-----Original Message-----
From: John Hansen [mailto:[email-masked]]
Sent: Sun 1/15/2006 6:03 AM
To: Joshua D. Drake; Dave Page
Cc: Guido Barosio; Marc G. Fournier; Josh Berkus; [email-masked]; Jim C. Nasby
Subject: RE: [pgsql-www] Infrastructure monitoring
 
> I've managed to get around that, by removing some compiler optimizations....

Oh, nice work. The only other issue I had when I tried to build it a few days ago stemmed from the box having a too-new version of autoconf, but that should be easy to resolve.

/D

---

From: "John Hansen" <[email-masked]>
Date: Sun, 15 Jan 2006 21:44:07 +1100

> Oh, nice work. The only other issue I had when I tried to 
> build it a few days ago stemmed from the box having a too-new 
> version of autoconf, but that should be easy to resolve.

Don't you mean automake,autoheader, etc.
It seems to like -1.4 of those.

Have you attempted running it on a 64bit box?

... John

---

From: "John Hansen" <[email-masked]>
Date: Mon, 16 Jan 2006 08:08:53 +1100

Joshua D. Drake [mailto:[email-masked]] 
> O.k. hardware requirements are no sweat. We can put together 
> a 6 drive scsi array for the database and I will put the os 
> on a couple of ide with raid 1.

That's cool, this damp piece of string could use the freed up bandwidth :)
 
> Why do we "need" a separate server for the cgi's? Are they 
> that hard on the webserver?

Not separate, just separate from this server, and it's not a requirement, but my recommendation.
You can add search.postgresql.org as a vhost to any other machine(s).
Most of the time spent on searches, are spent in executing the cgi (provided of course, that the backend is fast).

Currently, I have the load spread evenly among 3 webservers (I use a reverse proxy load balancer for this), which at peak puts the load to somewhere between 3 and 4.

Also, as I was about to mention on IRC, you might want to consider porting the apache module to apache2 or use it on apache1, which is much faster than the cgi.

With 4 gig of ram however, you would probably be fine running it all on the one host.

... John

---

From: "Dave Page" <[email-masked]>
Date: Mon, 16 Jan 2006 08:21:33 -0000

> Sent: 15 January 2006 10:44
> To: Dave Page; Joshua D. Drake

Ah.

> Have you attempted running it on a 64bit box?

Nope. You?

Regards, Dave

---

From: "Dave Page" <[email-masked]>
Date: Mon, 16 Jan 2006 08:26:32 -0000

> From: Joshua D. Drake [mailto:[email-masked]] 
> Sent: 15 January 2006 20:47
> To: John Hansen
> Cc: Dave Page; Guido Barosio; Marc G. Fournier; Josh Berkus; 
> [email-masked]; Jim C. Nasby
> Subject: Re: [pgsql-www] Infrastructure monitoring
> 
> Hello,
> 
> O.k. hardware requirements are no sweat. We can put together a 6 drive
> scsi array for the database and I will put the os on a couple of ide 
> with raid 1.

OK, that's great, thanks Joshua. Please setup a couple of user accounts
for John & I when it's ready, and grant us 'sudo su -' permission.

Regards, Dave