Subject: Re: Infrastructure monitoring

From: "John Hansen" <[email-masked]>
Date: Sun, 15 Jan 2006 16:40:59 +1100

> -----Original Message-----
> From: Dave Page [mailto:[email-masked]] 
> Sent: Sunday, January 15, 2006 8:41 AM
> To: John Hansen; Joshua D. Drake
> Cc: Guido Barosio; Marc G. Fournier; Josh Berkus; 
> [email-masked]; Jim C. Nasby
> Subject: Re: [pgsql-www] Infrastructure monitoring
> 
> 
> 
> 
> On 14/1/06 21:37, "John Hansen" <[email-masked]> wrote:
> 
> > Joshua D. Drake [mailto:[email-masked]] Wrote
> > 
> >> Sure we could help and we are happy to. John what types of 
> machines 
> >> are we talking about here?
> > 
> > You will need an x86-32 (Preferably SMP) with at least 2G of ram 
> > running linux.
> > (Gentoo is known to work).
> > ASPseek currently uses 11G of HD space for the search.
> 
> What sort of storage are you currently running? How many spindles etc?
> 
> Regards, Dave.
> 

4x80G Seagate IDE (PATA ST380011A) Software Raid0 on 2 x Promise Ultra100 Controllers in 66Mhz slots.

The system has another 4x80 Seagate IDE (PATA ST380021A) but they are slower models, in Software Raid5, used for backup.

Pgbench reports ~800tps with: pgbench -i -s50 test; reboot; pgbench -s50 -c25 -t1000 test;
(Reboot done to completely flush any cached data)

Systained thruput on the disk sybsystem is roughly 130Mbytes/second in both directions.

LVM on top of software raid, XFS filesystems.

... John

---

From: "Joshua D. Drake" <[email-masked]>
Date: Sun, 15 Jan 2006 12:47:16 -0800

Hello,

O.k. hardware requirements are no sweat. We can put together a 6 drive
scsi array for the database and I will put the os on a couple of ide 
with raid 1.

Why do we "need" a separate server for the cgi's? Are they that hard on 
the webserver?

Joshua D. Drake

-- 
The PostgreSQL Company - Command Prompt, Inc. 1.503.667.4564
PostgreSQL Replication, Consulting, Custom Development, 24x7 support
Managed Services, Shared and Dedicated Hosting
Co-Authors: PLphp, PLperl - http://www.commandprompt.com/

---

From: Tino Wildenhain <[email-masked]>
Date: Sun, 15 Jan 2006 22:04:20 +0100

Joshua D. Drake schrieb:
> ...

Maybe not using cgi would help?  You can run webapp and postgres on the
same server but putting them on separate servers really helps with
having performance high. But it really depends on the application.