Subject: Re: Gborg still down

From: "Dave Page" <[email-masked]>
Date: Sat, 22 Apr 2006 20:18:27 +0100

-----Original Message-----
From: "Jim C. Nasby"<[email-masked]>
Sent: 22/04/06 19:20:03
To: "Dave Page"<[email-masked]>
Cc: "Joshua D. Drake"<[email-masked]>, "Magnus Hagander"<[email-masked]>, "Marc G. Fournier"<[email-masked]>, "[email-masked]"<[email-masked]>, "[email-masked]"<[email-masked]>
Subject: Re: [pgsql-www] Gborg still down

> ISTM it wouldn't be that difficult if whatever updated the archives
> stuffed the current time in a file somewhere once it was finished...

That would prove that the mhonarc script ran and the rsync to the webserver, but it wouldn't prove that messages on all lists were actually getting there in the first place, or subsequently being indexed for searching.

Still, it wouldn't hurt to start with the easier stuff...

Regards Dave

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Mon, 24 Apr 2006 15:09:04 -0000

> As we already said, we do monitor them. However, we monitor that they are
> running - ie. Do we get a response from Apache, ssh, rsyncd or whatever.
> Checking whether the archives/search are serving up to date content would be
> a whole other (difficult) problem altogether.

Well, with regards to what started this whole thread, the cvs server on
gborg was completely down (e.g. not accepting connections) so that is one
service that should definitely be added. The web server itself was up, but
only displaying a "undergoing maintanence" message. It should be simple enough
to have the monitor script download the main page and make sure that a static
string is on the page (e.g. "Welcome to Gborg!"). I agree that the archive / search
is a whole 'nother matter. I'm willing to help out on any of it though if needed,
just point me in the right direction.

- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200604241106
http://biglumber.com/x/web?pk=2529DF6AB8F79407E94445B4BC9B906714964AC8