Subject: Fwd: borg.postgresql.org daily run output

From: "Gavin M. Roy" <[email-masked]>
Date: Tue, 13 Jun 2006 10:09:06 -0700

If I'm reading the df output correctly for the vm drive on borg, it's  
out of disk space and probably needs a little bit of pruning,  
specifically:

> /dev/aacd0s1h        26345632 24137956  100026   100%    /vm

Gavin

Begin forwarded message:

> From: Charlie Root <[email-masked]>
> Date: June 13, 2006 3:01:41 AM PDT
> To: [email-masked]
> Subject: borg.postgresql.org daily run output
>
>
> Removing stale files from /var/preserve:
>
> Cleaning out old system announcements:
>
> Removing stale files from /var/rwho:
>
> Backup passwd and group files:
>
> Verifying group file syntax:
>
> Backing up mail aliases:
>
> Disk status:
> Filesystem          1K-blocks     Used   Avail Capacity  Mounted on
> /dev/aacd0s1a          257998    47850  189510    20%    /
> /dev/aacd0s1e          128990        8  118664     0%    /tmp
> /dev/aacd0s1f         5161198  3084162 1664142    65%    /usr
> /dev/aacd0s1g         1032142     7028  942544     1%    /var
> /dev/aacd0s1h        26345632 24137956  100026   100%    /vm
> procfs                      4        4       0   100%    /proc
> procfs                      4        4       0   100%    /vm/186/ 
> svr2.postgresql.org/proc
> <below>:/vm/.t2/usr  52691264 50483588  100026   100%    /vm/186/ 
> svr2.postgresql.org/usr
> procfs                      4        4       0   100%    /vm/186/ 
> wwwmaster.postgresql.org/proc
>
> Last dump(s) done (Dump '>' file systems):
>
> UUCP status:
>
> Network interface status:
> Name    Mtu Network       Address              Ipkts Ierrs    Opkts  
> Oerrs  Coll
> fxp0   1500 <Link#1>    00:b0:d0:e1:a0:02 19783853     0  
> 17207245     0     0
> fxp0   1500 65.19.161/25  borg            15994471     -  
> 31571905     -     -
> fxp0   1500 fe80:1::2b0 fe80:1::2b0:d0ff:        0     -         
> 2     -     -
> fxp0   1500 65.19.161.25/ wwwmaster       68815226     -  
> 58028755     -     -
> fxp0   1500 65.19.161.90/ svr2             6501226     -   
> 2825775     -     -
> bge0*  1500 <Link#2>    00:b0:d0:e1:a0:03        0     0         
> 0     0     0
> ppp0*  1500 <Link#3>                             0     0         
> 0     0     0
> sl0*    552 <Link#4>                             0     0         
> 0     0     0
> faith  1500 <Link#5>                             0     0         
> 0     0     0
> lo0   16384 <Link#6>                      80071612     0  
> 80071612     0     0
> lo0   16384 localhost   ::1                4846706     -   
> 4846706     -     -
> lo0   16384 fe80:6::1   fe80:6::1                0     -         
> 0     -     -
> lo0   16384 your-net      localhost           3450     -      
> 3450     -     -
>
> Local network system status:
> borg          up  37+11:19,     0 users,  load 0.00, 0.01, 0.01
>
> Mail in local queue:
> /var/spool/mqueue is empty
> 		Total requests: 0
>
> Mail in submit queue:
> /var/spool/clientmqueue is empty
> 		Total requests: 0
>
> Security check:
>     (output mailed separately)
>
> Checking for rejected mail hosts:
>
> Checking for denied zone transfers (AXFR and IXFR):
>
> -- End of daily output --

---

From: "Jim C. Nasby" <[email-masked]>
Date: Tue, 13 Jun 2006 13:41:26 -0500

> >/dev/aacd0s1h        26345632 24137956  100026   100%    /vm

If there's nothing else monitoring this it'd be worth at least setting
up http://jim.nasby.net/code/dfmon/ and having it email someplace.

The irc monitor stuff is a bot we have setup to send alerts to some IRC
channels; if there's interest in setting that up for PostgreSQL, I can
provide that code.
-- 
Jim C. Nasby, Database Architect                [email-masked] 
Give your computer some brain candy! www.distributed.net Team #1828

Windows: "Where do you want to go today?"
Linux: "Where do you want to go tomorrow?"
FreeBSD: "Are you guys coming, or what?"

---

From: "Gavin M. Roy" <[email-masked]>
Date: Tue, 13 Jun 2006 11:44:48 -0700

There's a nightly email that is sent.  I'm looking into having it  
sent to a list so more people can get their eyes on it.

Gavin

---

From: "Jim C. Nasby" <[email-masked]>
Date: Tue, 13 Jun 2006 13:49:49 -0500

> sent to a list so more people can get their eyes on it.

Yeah, I'm familiar with the nightly FBSD emails, but there's two issues:

1) They only come out once a day
2) You have to actively dig to see if there's an issue

ISTM it'd be better to find out about a pending out-of-space issue
beforehand and not rely on someone noticining it in an email. And if you
do hit 100%, it'd be really good to find out sooner than that night.

Though I will say that it's a good thing to have multiple people looking
at the nightly run output...
-- 
Jim C. Nasby, Database Architect                [email-masked] 
Give your computer some brain candy! www.distributed.net Team #1828

---

From: "Joshua D. Drake" <[email-masked]>
Date: Tue, 13 Jun 2006 12:20:57 -0700

> at the nightly run output...

Happy to run a disk free via nagios if given the perms.

-- 

    === The PostgreSQL Company: Command Prompt, Inc. ===
Sales/Support: +1.503.667.4564 || 24x7/Emergency: +1.800.492.2240
    Providing the most comprehensive  PostgreSQL solutions since 1997
              http://www.commandprompt.com/