Subject: Search out of sync

From: Adrian Klaver <[email-masked]>
Date: Sun, 27 Aug 2006 11:10:33 -0700

I am seeing the same behavior as reported in the  message below.
http://archives.postgresql.org/pgsql-www/2006-08/msg00105.php

Is there a fix in the works?

Thank you,
-- 
Adrian Klaver	
[email-masked]

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 28 Aug 2006 20:10:04 -0400 (EDT)

> Is there a fix in the works?

I just tested "index bloat" and I can confirm that the second returned
result is incorrect if you click on it.  Is anyone addressing this?

-- 
  Bruce Momjian   [email-masked]
  EnterpriseDB    http://www.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +

---

From: "Joshua D. Drake" <[email-masked]>
Date: Mon, 28 Aug 2006 17:53:09 -0700

> result is incorrect if you click on it.  Is anyone addressing this?

No.

Sincerely,

Joshua D. Drake

-- 

    === The PostgreSQL Company: Command Prompt, Inc. ===
Sales/Support: +1.503.667.4564 || 24x7/Emergency: +1.800.492.2240
    Providing the most comprehensive  PostgreSQL solutions since 1997
              http://www.commandprompt.com/

---

From: Tom Lane <[email-masked]>
Date: Mon, 28 Aug 2006 22:08:22 -0400

> No.

Why not?  The search index needs to be rebuilt following Marc's
re-reconstruction of the archives.  It didn't take too long to do
it after the first reconstruction, what's the holdup this time?

			regards, tom lane

---

From: "Joshua D. Drake" <[email-masked]>
Date: Mon, 28 Aug 2006 19:13:31 -0700

> it after the first reconstruction, what's the holdup this time?

I have restarted the search engine daemons.

The hold up is simple:

1. Our search sucks.
2. I have zero idea how our search works beyond stop/start
3. Our search sucks.

Joshua D. Drake

--

---

From: Tom Lane <[email-masked]>
Date: Mon, 28 Aug 2006 22:23:34 -0400

"Joshua D. Drake" <[email-masked]> writes:
> I am willing to put man and money resources behind our search engine, if 
> I felt that our search engine was going to be productive :) but I never, 
> ever use it.

It works well for me and for a lot of other people (at least when the
data is up-to-date).  If you can't be bothered to maintain it, however,
I guess we need to find another host.

Any volunteers out there?

			regards, tom lane

---

From: "Joshua D. Drake" <[email-masked]>
Date: Mon, 28 Aug 2006 19:29:56 -0700

> I guess we need to find another host.

I guess it depends on what you are looking for, but it rarely works for me.

> Any volunteers out there?

Uhh, who said I was ever the maintainer? I am the host and have never 
claimed to be maintainer. I am not the only one that has root on that 
machine to help maintain that box. Dave Page, Applejack and Devrim all 
have root on this machine.

Please see my next post on this thread.

Sincerely,

Joshua D. Drake

--

---

From: "Joshua D. Drake" <[email-masked]>
Date: Mon, 28 Aug 2006 19:43:12 -0700

>> I felt that our search engine was going to be productive :) but I never, 

/me digs around in the install and finds a suspicious scripts called:

update-archives

Reading the script, it updates some date statistics in the database 
which appears to in theory cause the indexer to re-fire against 
archives, pgfoundry and gborg..

So time will tell. Where is that wiki so I can document this, since I am 
spending my time on it, I might as well make sure someone can come 
behind me.

Sincerely,

Joshua D. Drake

--

---

From: "John Hansen" <[email-masked]>
Date: Tue, 29 Aug 2006 17:21:46 +1000

Index resync started, no new messages will be indexed until it's finished. 

I missed the email about the archives was regenerated, and have spent hours trying to work out what had happened.

This problem would have resolved itself tho, as the archives are reindexed every 30 days anyways.

Kind regards,

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Bruce Momjian
> Sent: Tuesday, August 29, 2006 10:10 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [pgsql-www] Search out of sync
> 
> Adrian Klaver wrote:
> I just tested "index bloat" and I can confirm that the second 
> returned result is incorrect if you click on it.  Is anyone 
> addressing this?
> 
> -- 
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 3: Have you checked our extensive FAQ?
> 
>                http://www.postgresql.org/docs/faq
>

---

From: "Dave Page" <[email-masked]>
Date: Tue, 29 Aug 2006 08:35:57 +0100

> [mailto:[email-masked]] On Behalf Of Joshua D. Drake
> Sent: 29 August 2006 03:30
> To: Tom Lane
> Cc: Bruce Momjian; [email-masked]; [email-masked]

Works well for me <shrug>.

> have root on this machine.

Unfortunately I've been on holiday. And doesn't Devrim work for you? :-)

/D

---

From: Devrim GUNDUZ <[email-masked]>
Date: Tue, 29 Aug 2006 17:19:06 +0300

Hello,

> Unfortunately I've been on holiday. And doesn't Devrim work for

Do we have a text about how search engine works? I have zero idea about
that.

... and having root does not mean that I know a lot about the search
engine :-)

Regards,
-- 
The PostgreSQL Company - Command Prompt, Inc. 1.503.667.4564
PostgreSQL Replication, Consulting, Custom Development, 24x7 support
Managed Services, Shared and Dedicated Hosting
Co-Authors: plPHP, plPerlNG - http://www.commandprompt.com/

---

From: "Joshua D. Drake" <[email-masked]>
Date: Tue, 29 Aug 2006 07:25:53 -0700

> Unfortunately I've been on holiday. And doesn't Devrim work for you? :-)

Yes, Devrim works for me :)

Joshua D. Drake

--

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 29 Aug 2006 11:55:33 -0400 (EDT)

John Hansen wrote:
> I missed the email about the archives was regenerated, and have spent
> hours trying to work out what had happened.
> 

It still does not work.  If you search "index bloat", the second item is
"Constraints" and there is no mention of index bloat there.  Before the
reindex, the second item said index bloat, but pointed to the
"Constraints" email.  Could this be caused by Marc fixing the indexes
based on pre-post July 2006 indexing needs.

---

From: "John Hansen" <[email-masked]>
Date: Wed, 30 Aug 2006 03:33:13 +1000

Bruce Momjian Wrote:

> It still does not work.  If you search "index bloat", the 
> second item is "Constraints" and there is no mention of index 
> bloat there.  Before the reindex, the second item said index 
> bloat, but pointed to the "Constraints" email.  Could this be 
> caused by Marc fixing the indexes based on pre-post July 2006 
> indexing needs.

No, the archives are being reindexed, and the indexer is still running.
While it's running, results will be somewhat screwed, until the reverse index is updated, which doesn't occur till it's been thru all of the pages. (some 500.000+ of them)

Be patient please.

Kind Regards,

John

---

From: "Joshua D. Drake" <[email-masked]>
Date: Tue, 29 Aug 2006 11:45:16 -0700

> based on pre-post July 2006 indexing needs.

Who knows :). I have no idea why the constraints email would show up at 
all frankly.

Sincerely,

Joshua D. Drake

> ---------------------------(end of broadcast)---------------------------
> TIP 9: In versions below 8.0, the planner will ignore your desire to
>        choose an index scan if your joining column's datatypes do not
>        match
> 

--

---

From: "John Hansen" <[email-masked]>
Date: Wed, 30 Aug 2006 11:19:32 +1000

Search is now in sync.

... John

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 29 Aug 2006 22:05:41 -0400 (EDT)

> Search is now in sync.

Yes, I can confirm.  Thanks for the fix.