Subject: backup infrastructure

From: "Dan Langille" <[email-masked]>
Date: Wed, 06 Sep 2006 15:30:35 -0400

Gidday folks,

One way I can contribute my services to the project is in the form of 
backup services. You tell me what files need to be backed up from 
what servers, and it'll be done on the frequency required.

Restores can be arranged for those that have admin access.  We can 
keep a designated number of backups online, for immediate access.  
Older backups will be stored offline.

Bacula is my tool of choice.  Let me know how I can help.

-- 
Dan Langille : Software Developer looking for work
my resume: http://www.freebsddiary.org/dan_langille.php

---

From: "Dan Langille" <[email-masked]>
Date: Wed, 13 Sep 2006 15:11:40 -0400

On 6 Sep 2006 at 15:30, Dan Langille wrote:

> backup services. You tell me what files need to be backed up from what
> servers, and it'll be done on the frequency required.
> 

Is the lack of response a verification that no help is required or 
did I pick a bad time?

---

From: "Gavin M. Roy" <[email-masked]>
Date: Wed, 13 Sep 2006 12:55:57 -0700

Probably timing, and people probably want to digest the idea a bit.   
I'd not be detoured.  I think it's an excellent idea.  It raises  
issues of availability of restoration and access to things that you  
may not otherwise have access to though... (No idea if that's  
actually the case, just pointing out a possibility).

Gavin

On Sep 13, 2006, at 12:11 PM, Dan Langille wrote:

>> what
> ---------------------------(end of  
> broadcast)---------------------------
> TIP 6: explain analyze is your friend

---

From: Tom Lane <[email-masked]>
Date: Wed, 13 Sep 2006 16:39:00 -0400

> Probably timing, and people probably want to digest the idea a bit.   

I believe Marc is still in process of moving ... so until he's settled
in, I doubt very much is going to happen.  It's an important issue though.

			regards, tom lane

---

From: "Marc G. Fournier" <[email-masked]>
Date: Wed, 13 Sep 2006 18:27:48 -0300 (ADT)

> Is the lack of response a verification that no help is required or

What is needed on the vServer side of things?  A client, I assume?  And 
how much data is it safe to backup?  postgresql.org is up to 24G in size, 
and growing ... :)

We're in the process of setting up a full backup to a remote server *just 
in case*, but that will include *all* files, so that we could fail over as 
required ... so I'm not sure whether or not there would be a benefit to 
'per file backups', but I'm not against it either if others here feel that 
this would help ...

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email . [email-masked]                              MSN . [email-masked]
Yahoo . yscrappy               Skype: hub.org        ICQ . 7615664

---

From: "Dan Langille" <[email-masked]>
Date: Thu, 14 Sep 2006 11:06:52 -0400

> how much data is it safe to backup?  postgresql.org is up to 24G in size, 

Yes, it is a client.  In the FreeBSD ports tree, it is 
sysutuils/bacula-server.

I can just as easily mirror static data as opposed to backing up 
dynamic data.

> 'per file backups', but I'm not against it either if others here feel that 

Once your current rush subsides, and there is slight pause, let me 
know.