Subject: Ordering bug in site search results

From: Sergiy Vyshnevetskiy <[email-masked]>
Date: Wed, 31 Jan 2007 18:15:15 +0200 (EET)

Do a website search ordered by _date_. The first page you see is fine, but 
if you try to switch between result pages it gives the results ordered by 
_rank_. Looks like URLs of search result pages miss "s=d" part.

Also, right under the search form it says:

Pages <something>-<something> of <something>.

That should be read:

Results <something>-<something> of <something>.

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 31 Jan 2007 11:29:28 -0500 (EST)

I can confirm I have seen the date->rank bug myself.

---------------------------------------------------------------------------

Sergiy Vyshnevetskiy wrote:
> ---------------------------(end of broadcast)---------------------------
> TIP 7: You can help support the PostgreSQL project by donating at
> 
>                 http://www.postgresql.org/about/donate

-- 
  Bruce Momjian   [email-masked]
  EnterpriseDB    http://www.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +

---

From: Magnus Hagander <[email-masked]>
Date: Sat, 03 Feb 2007 14:09:49 +0100

Sergiy Vyshnevetskiy wrote:
> Do a website search ordered by _date_. The first page you see is fine,
> but if you try to switch between result pages it gives the results
> ordered by _rank_. Looks like URLs of search result pages miss "s=d" part.

Thanks, fixed.

> Results <something>-<something> of <something>.

Good point, also changed.

//Magnus