Subject: Second try for roadmap.html

From: "Joshua D. Drake" <[email-masked]>
Date: Tue, 27 Feb 2007 11:08:12 -0800

-- 

      === The PostgreSQL Company: Command Prompt, Inc. ===
Sales/Support: +1.503.667.4564 || 24x7/Emergency: +1.800.492.2240
Providing the most comprehensive  PostgreSQL solutions since 1997
             http://www.commandprompt.com/

Donate to the PostgreSQL Project: http://www.postgresql.org/about/donate
PostgreSQL Replication: http://www.commandprompt.com/products/

Index: roadmap.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/en/developer/roadmap.html,v
retrieving revision 1.8
diff -c -r1.8 roadmap.html
*** roadmap.html	19 Oct 2006 01:32:36 -0000	1.8
--- roadmap.html	27 Feb 2007 19:05:28 -0000
***************
*** 5,19 ****
  <h1>Roadmap</h1>
  
  <p>PostgreSQL is a non-commercial, all volunteer, free software project, and as such there is no formal list of 
! feature requirements required for development. We really do follow the mantra of letting developers scratch their own itches.</p>
  
- <p>That said, there is an informal list of items that have been agreed upon by the PostgreSQL developers as things that need to 
- worked upon, known as the <a href="/docs/faqs.TODO.html">TODO</a> list. Items on the list can be marked as
- completed in development, "claimed" by a developer and being activly worked on, or unmarked meaning that the item is likely not 
- being activly worked on. </p>
- 
- <p>There are also two lists for "unapplied patches" that have been submitted for inclusion into PostgreSQL,
- one for the <a href="http://momjian.postgresql.org/cgi-bin/pgpatches">patches saved for the current release</a> and one for 
- <a href="http://momjian.postgresql.org/cgi-bin/pgpatches_hold">patches saved for the next release</a>. Once a patch has been submitted 
- and saved in the queue, it is a good bet that the particular feature will make it into the appropriate release.</p> 
  
--- 5,23 ----
  <h1>Roadmap</h1>
  
  <p>PostgreSQL is a non-commercial, all volunteer, free software project, and as such there is no formal list of 
! feature requirements required for development. However, we do try to adhere to a reasonable release schedule.</p>
! 
! <h2>Release Schedule</h2>
! <ul>
!   <li>March 31, 2007 - Feature Freeze</li>
!   <li>May-June 2007 - Beta begins</li>
!   <li>July-August 2007 - 8.3 Released</li>
!   <li>September 2007 - 8.4 development begins</li>
!   <li>March 31, 2008  Feature freeze for 8.4 (tentative)</li>
! </ul>
! 
! 
! 
!

---

From: Josh Berkus <[email-masked]>
Date: Tue, 27 Feb 2007 16:06:53 -0800

Josh,

> !   <li>March 31, 2008  Feature freeze for 8.4 (tentative)</li>

I don't think those release dates are realistic.   8.3 release would be August 
at the earliest, and more likely September or October.  There's no reason to 
confuse people with false expectations.

-- 
Josh Berkus
PostgreSQL @ Sun
San Francisco

---

From: "Joshua D. Drake" <[email-masked]>
Date: Tue, 27 Feb 2007 16:21:15 -0800

> confuse people with false expectations.

If that is the case, we have likely solved nothing with our movement of
the dates to have 8.3 be a short cycle release.

I thought the whole goal was to try and release around july.

Joshua D. Drake

--

---

From: Josh Berkus <[email-masked]>
Date: Tue, 27 Feb 2007 17:33:48 -0800

Josh,

> the dates to have 8.3 be a short cycle release.

The point was to move the ingration/patch review period, which we have.  Any 
move-up of the actual release date is incidental. 

> I thought the whole goal was to try and release around july.

No, what gave you that idea?  When have we *ever* done a 1-month beta?

If there are absolutely no beta issues we can do another 8.1 and release at 
OSCON or something.   But with invasive changes like HOT a probable 
submission for 8.3, a short beta seems very optimistic. 

-- 
Josh Berkus
PostgreSQL @ Sun
San Francisco

---

From: Robert Treat <[email-masked]>
Date: Tue, 27 Feb 2007 21:06:10 -0500

On Tuesday 27 February 2007 20:33, Josh Berkus wrote:
> The point was to move the ingration/patch review period, which we have. 
> Any move-up of the actual release date is incidental.
>

If feature freeze is April 1st, and OSCon is July 24th, thats around 4 months 
to get the release done. Given how things like the buildfarm. and our theory 
that the new timeframe should help shorten the release process, I don't think 
this is that unrealistic. 

-- 
Robert Treat
Build A Brighter LAMP :: Linux Apache {middleware} PostgreSQL

---

From: "Joshua D. Drake" <[email-masked]>
Date: Tue, 27 Feb 2007 19:03:23 -0800

> this is that unrealistic. 

That is kind of what I thought.

Joshua D. Drake

--

---

From: Tom Lane <[email-masked]>
Date: Wed, 28 Feb 2007 01:09:42 -0500

>> If feature freeze is April 1st, and OSCon is July 24th, thats around
>> 4 months to get the release done. Given how things like the
>> buildfarm. and our theory that the new timeframe should help shorten
>> the release process, I don't think this is that unrealistic.

> That is kind of what I thought.

Josh is nowhere in line with what I thought the plan was.  We're busting
our butts to have a short release cycle, and then we're going to piss it
all away after feature freeze?  Nope.  I thought we were hoping for
release June-ish, or worst case July-ish.  A short devel cycle should
not need a slow test cycle.

			regards, tom lane

---

From: "Joshua D. Drake" <[email-masked]>
Date: Tue, 27 Feb 2007 22:36:31 -0800

> not need a slow test cycle.

O.k. good, that is what I thought as well. I have actually been kind of
betting on a 8.3 release for OSCON.

Sincerely,

Joshua D. Drake

--

---

From: Magnus Hagander <[email-masked]>
Date: Mon, 5 Mar 2007 14:07:00 +0100

> Index: roadmap.html
<snip>

I assume these changes are either incorporated in or obsoleted by the
stuff that xzilla committed?

(the developer parts, that is)

//Magnus

---

From: Robert Treat <[email-masked]>
Date: Mon, 05 Mar 2007 08:43:35 -0500

> (the developer parts, that is)

I think my update incorporates most of the ideas mention in the various 
threads, though I'd still like to see the write up on how the postgresql 
development process works.  I'd probably add that under the main developer 
section though.

---

From: "Joshua D. Drake" <[email-masked]>
Date: Mon, 05 Mar 2007 17:15:18 -0800

> (the developer parts, that is)
Well except that the dates on the current (xzilla's commit) are wrong.

Joshua D. Drake

> //Magnus
>
> ---------------------------(end of broadcast)---------------------------
> TIP 5: don't forget to increase your free space map settings
>
>

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 5 Mar 2007 20:31:46 -0500 (EST)

> Well except that the dates on the current (xzilla's commit) are wrong.

Yep, I see that now.  Please use only this:

      <LI>March 1, 2007 - Initial community review of all major feature patches</LI>
      <LI>April 1, 2007 -  Feature freeze, all patches must be submitted for review and application</LI>
      <LI>mid-May, 2007 - All patches applied, beta testing begins</LI>
      <LI>July, 2007 - Release of 8.3.0</LI>

I am a little disturbed people feel free to make up dates with no
discussion.

-- 
  Bruce Momjian  <[email-masked]>          http://momjian.us
  EnterpriseDB                               http://www.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +

---

From: "Joshua D. Drake" <[email-masked]>
Date: Mon, 05 Mar 2007 17:35:13 -0800

> I am a little disturbed people feel free to make up dates with no

So there is no confusion, it is my understanding that this has always 
been the plan.

Sincerely,

Joshua D. Drake

---

From: Robert Treat <[email-masked]>
Date: Tue, 06 Mar 2007 14:30:16 -0500

On Monday 05 March 2007 20:35, Joshua D. Drake wrote:
> >       <LI>March 1, 2007 - Initial community review of all major feature
> > patches</LI> <LI>April 1, 2007 -  Feature freeze, all patches must be
> > submitted for review and application</LI> <LI>mid-May, 2007 - All patches
> > applied, beta testing begins</LI> <LI>July, 2007 - Release of 8.3.0</LI>
> >

Quite frankly I'm a little upset that you would bandy about such statements so 
casually.  If that was directed at me, may I politley suggest you sod off.

> So there is no confusion, it is my understanding that this has always

So there is even less confusion, let people be aware that I copy/pasted those 
dates from the email that Joshua sent originally: 
http://archives.postgresql.org/pgsql-www/2007-02/msg00278.php.  In the thread 
that follows no one offers a specific corrected timeline and Tom even wieghs 
in with what would appear to be acceptence of the timeline Joshua presented. 

I've corrected the timeline in cvs and it will appear in the next site update, 
hopefully we can all move on...

---

From: "Joshua D. Drake" <[email-masked]>
Date: Tue, 06 Mar 2007 14:02:10 -0800

> casually.  If that was directed at me, may I politley suggest you sod off.
I don't think it was directed at you.

> in with what would appear to be acceptence of the timeline Joshua presented. 
I think you are confusing my timelime with JoshB's timeline. My timeline 
showed us releasing in June or July.

Sincerely,

Joshua D. Drake

---

From: Robert Treat <[email-masked]>
Date: Tue, 06 Mar 2007 17:59:02 -0500

...fights... urge... to... respond...
<fails>

On Tuesday 06 March 2007 17:02, Joshua D. Drake wrote:
> Robert Treat wrote:
> > So there is even less confusion, let people be aware that I copy/pasted
> > those dates from the email that Joshua sent originally:
> > http://archives.postgresql.org/pgsql-www/2007-02/msg00278.php.  In the
> > thread that follows no one offers a specific corrected timeline and Tom
> > even wieghs in with what would appear to be acceptence of the timeline
> > Joshua presented.
>

Here is a link to the patch you posted:
http://archives.postgresql.org/pgsql-www/2007-02/msg00278.php

Here is my commit which includes those same dates:
http://gborg.postgresql.org/cgi-bin/cvsweb.cgi/portal/template/en/developer/roadmap.html.diff?r1=1.8;r2=1.9;cvsroot=pgweb

Here is you saying that what I committed was incorrect:
http://archives.postgresql.org/pgsql-www/2007-03/msg00008.php

Not sure what else to add to this...

---

From: "Joshua D. Drake" <[email-masked]>
Date: Tue, 06 Mar 2007 16:56:30 -0800

> Not sure what else to add to this... 
Heh nothing. I think what I "read" was JoshB's dates which were clearly 
wrong. I apologize if that is the case. I am out of town and thus
may not be paying as close attention as I should. The current update 
looks good, thanks Robert.

Joshua D. Drake

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 20 Mar 2007 15:30:53 -0400 (EDT)

> looks good, thanks Robert.

Now that I am back from vacation, I wanted to clarify my "concern" on
this issue.  I wasn't worried about any individuals involved.  I know
everyone is doing the best they can.

I was concerned whether we had an adequate process in place.  For
example, should we be supplying patches to the www team so the changes
we want are clearer?  I certainly would not make complex changes to the
C code based on instructions like "Add a variable to the top of function
X".

Anyway, it seems the people involved feel we don't need to change the
process, so I will go back to not being concerned.