Subject: Re: Website's french translation

From: Magnus Hagander <[email-masked]>
Date: Tue, 17 Apr 2007 21:34:18 +0200

Guillaume Lelarge wrote:
> Guillaume Lelarge a écrit :
>> Guillaume Lelarge a écrit :
>> [...] OK, I've found what happens. I'll send you quickly a new patch.
>>
> 
> I still need to work on my new patch but I found some issues that we
> probably need to get fixed before.
> 
> * Some graphics contain text that can't be translated as is.

That's indeed a problem we have to deal with. From what I can tell, we
do have subdirectories set up for several of them, but the location is
hardcoded. Need some logic around that.

> * There are some texts that are not enclosed in the func_lang function.
>   I can send you a patch for this.

Please do, they should be.

> * I don't think the portal.pot is up to date.
>   Are strings extract each time a change is done ?

No.

//Magnus

---

From: Guillaume Lelarge <[email-masked]>
Date: Sun, 22 Apr 2007 17:53:42 +0200

Magnus Hagander a écrit :
> [...]

You'll find a patch attached. Note that it doesn't change any admin file 
despite that stringextract seems to extract strings from those files 
too. I don't know if we really need to localize these pages.

The french .po file is updated with the new strings but I need to check 
them on my local www-postgresql-org website before sending it.

>>   Are strings extract each time a change is done ?

It will become necessary really soon. At least, I hope :)

Regards.

-- 
Guillaume.
http://www.postgresqlfr.org
http://docs.postgresqlfr.org
Index: template/common-docs.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/common-docs.html,v
retrieving revision 1.24
diff -r1.24 common-docs.html
26c26
< 	<label for="q">func_lang("Search Documentation:")&nbsp;</label><input type="text" id="q" name="q" size="20" onfocus="if( this.value==this.defaultValue ) this.value='';" value="Search" /><input id="submit" type="submit" value="func_lang('Search')" />
---
> 	<label for="q">func_lang("Search Documentation:")&nbsp;</label><input type="text" id="q" name="q" size="20" onfocus="if( this.value==this.defaultValue ) this.value='';" value="func_lang('Search')" /><input id="submit" type="submit" value="func_lang('Search')" />
Index: template/common.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/common.html,v
retrieving revision 1.41
diff -r1.41 common.html
12,15c12,15
<     <link rel="alternate" type="application/rss+xml" title="PostgreSQL news" href="/news.rss" />
<     <link rel="alternate" type="application/rss+xml" title="PostgreSQL events" href="/events.rss" />
<     <link rel="alternate" type="application/rss+xml" title="PostgreSQL latest versions" href="/versions.rss" />
<     <link rel="alternate" type="application/rss+xml" title="Planet PostgreSQL" href="http://www.planetpostgresql.org/rss20.xml" />
---
>     <link rel="alternate" type="application/rss+xml" title="func_lang('PostgreSQL news')" href="/news.rss" />
>     <link rel="alternate" type="application/rss+xml" title="func_lang('PostgreSQL events')" href="/events.rss" />
>     <link rel="alternate" type="application/rss+xml" title="func_lang('PostgreSQL latest versions')" href="/versions.rss" />
>     <link rel="alternate" type="application/rss+xml" title="func_lang('Planet PostgreSQL')" href="http://www.planetpostgresql.org/rss20.xml" />
18c18
<     <link rel="alternate stylesheet" media="screen" href="/layout/css/blue/fixed_large.css" type="text/css" title="Large Text" />
---
>     <link rel="alternate stylesheet" media="screen" href="/layout/css/blue/fixed_large.css" type="text/css" title="func_lang('Large Text')" />
33,34c33,34
<       <span class="txtOffScreen"><a href="#pgContent" title="Skip site navigation" accesskey="1">Skip site navigation</a> (1)</span>
<       <span class="txtOffScreen"><a href="#pgContentWrap" title="Skip section navigation" accesskey="2">Skip section navigation</a> (2)</span>
---
>       <span class="txtOffScreen"><a href="#pgContent" title="func_lang('Skip site navigation')" accesskey="1">func_lang("Skip site navigation")</a> (1)</span>
>       <span class="txtOffScreen"><a href="#pgContentWrap" title="func_lang('Skip section navigation')" accesskey="2">func_lang("Skip section navigation")</a> (2)</span>
40c40
<           <input id="q" name="q" type="text" size="20" maxlength="255" onfocus="if( this.value==this.defaultValue ) this.value='';" value="Search" accesskey="s" /><input name="a" type="hidden" value="1"/><input id="submit" name="submit" type="submit" value="Search" />
---
>           <input id="q" name="q" type="text" size="20" maxlength="255" onfocus="if( this.value==this.defaultValue ) this.value='';" value="func_lang('Search')" accesskey="s" /><input name="a" type="hidden" value="1"/><input id="submit" name="submit" type="submit" value="func_lang('Search')" />
65c65
<             <a href="/" title="The world's most advanced open source database."><img src="/layout/images/hdr_right.png" width="210" height="80" alt="The world's most advanced open source database." /></a>
---
>             <a href="/" title="func_lang('The world\'s most advanced open source database.')"><img src="/layout/images/hdr_right.png" width="210" height="80" alt="func_lang('The world\'s most advanced open source database.')" /></a>
Index: template/community-docs.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/community-docs.html,v
retrieving revision 1.3
diff -r1.3 community-docs.html
5c5
< This page is user contributed documentation. See the bottom of the page for information about the author.
---
> func_lang("This page is user contributed documentation. See the bottom of the page for information about the author.")
26c26
<    <td class="colFirstT">Updated:</td>
---
>    <td class="colFirstT">func_lang("Updated"):</td>
30c30
<    <td class="colFirstT">Author:</td>
---
>    <td class="colFirstT">func_lang("Author"):</td>
35c35
<    <td class="colFirstT">Version history:</td>
---
>    <td class="colFirstT">func_lang("Version history"):</td>
46,47c46,47
<    <td class="colFirstT">Operations:</td>
<    <td class="colLastT"><a href="{master_server}/community/docedit.{page_id}">Edit</a> <a href="{master_server}/community/docadd.{page_id}">Create subpage</a> (Requires <a href="/community/signup">community login</a>)</td>
---
>    <td class="colFirstT">func_lang("Operations"):</td>
>    <td class="colLastT"><a href="{master_server}/community/docedit.{page_id}">func_lang("Edit")</a> <a href="{master_server}/community/docadd.{page_id}">func_lang("Create subpage")</a> (func_lang("Requires") <a href="/community/signup">func_lang("community login")</a>)</td>
Index: template/download.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/download.html,v
retrieving revision 1.11
diff -r1.11 download.html
2c2
< Choose a Mirror
---
> func_lang("Choose a Mirror")
24,25c24
< <p>Your download will start automatically from this mirror in 5 seconds unless you select
< another mirror in the list below.</p>
---
> <p>func_lang("Your download will start automatically from this mirror in 5 seconds unless you select another mirror in the list below.")</p>
Index: template/index.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/index.html,v
retrieving revision 1.90
diff -r1.90 index.html
23c23
<                     <h2><img src="/layout/images/en/hdr_featureduser.png" width="104" height="10" alt="Featured User" /></h2>
---
>                     <h2><img src="/layout/images/en/hdr_featureduser.png" width="104" height="10" alt="func_lang('Featured User')" /></h2>
27c27
<                         <img src="/layout/images/blt_blu_arrow.png" width="6" height="5" alt="" /><a href="/about/casestudies">func_lang("Case Studies")</a><span class="txtDivider">|</span><a href="/about/users" title="See more featured users">func_lang("More Featured Users")</a>
---
>                         <img src="/layout/images/blt_blu_arrow.png" width="6" height="5" alt="" /><a href="/about/casestudies">func_lang("Case Studies")</a><span class="txtDivider">|</span><a href="/about/users" title="func_lang('See more featured users')">func_lang("More Featured Users")</a>
38c38
<             <h2><img src="/layout/images/en/hdr_latestreleases.png" width="120" height="10" alt="Latest Releases" /></h2>
---
>             <h2><img src="/layout/images/en/hdr_latestreleases.png" width="120" height="10" alt="func_lang('Latest Releases')" /></h2>
41c41
<              <b>{version}:</b> <a href="/ftp/source/v{version}">Source</a> &middot; <a href="/ftp/binary/v{version}">Binary</a> &middot; <a href="/docs/{majorver}/static/{relnotes}">Notes</a>
---
>              <b>{version}:</b> <a href="/ftp/source/v{version}">func_lang("Source")</a> &middot; <a href="/ftp/binary/v{version}">func_lang("Binary")</a> &middot; <a href="/docs/{majorver}/static/{relnotes}">func_lang("Notes")</a>
45c45
<             <div id="pgFrontLatestReleasesNote"><a href="/versions.rss" title="func_lang('Versions RSS Feed')"><img class="pgRSSImage" src="/layout/images/ico_rss.png" width="28" height="13" alt="func_lang('Versions RSS Feed')" /></a> | <a href="/support/versioning">Why should I upgrade?</a></div>
---
>             <div id="pgFrontLatestReleasesNote"><a href="/versions.rss" title="func_lang('Versions RSS Feed')"><img class="pgRSSImage" src="/layout/images/ico_rss.png" width="28" height="13" alt="func_lang('Versions RSS Feed')" /></a> | <a href="/support/versioning">func_lang("Why should I upgrade?")</a></div>
48c48
<             <h2><img src="/layout/images/en/hdr_shortcuts.png" width="85" height="10" alt="Shortcuts" /></h2>
---
>             <h2><img src="/layout/images/en/hdr_shortcuts.png" width="85" height="10" alt="func_lang('Shortcuts')" /></h2>
76c76
<             <h2><img src="/layout/images/en/hdr_supportus.png" width="81" height="10" alt="Support Us" /></h2>
---
>             <h2><img src="/layout/images/en/hdr_supportus.png" width="81" height="10" alt="func_lang('Support Us')" /></h2>
86c86
<            <img src="/layout/images/en/hdr_latestnews.png" width="90" height="10" alt="Latest News" />
---
>            <img src="/layout/images/en/hdr_latestnews.png" width="90" height="10" alt="func_lang('Latest News')" />
106c106
<             <img src="/layout/images/en/hdr_planetpg.png" width="140" height="10" alt="Planet PostgreSQL" />
---
>             <img src="/layout/images/en/hdr_planetpg.png" width="140" height="10" alt="func_lang('Planet PostgreSQL')" />
128c128
<            <img src="/layout/images/en/hdr_upcomingevents.png" width="123" height="10" alt="Upcoming Events" />
---
>            <img src="/layout/images/en/hdr_upcomingevents.png" width="123" height="10" alt="func_lang('Upcoming Events')" />
132c132
<            <img src="/layout/images/en/hdr_upcomingtraining.png" alt="Upcoming training" />
---
>            <img src="/layout/images/en/hdr_upcomingtraining.png" alt="func_lang('Upcoming training')" />
Index: template/search.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/search.html,v
retrieving revision 1.4
diff -r1.4 search.html
8,9c8,9
<     <td class="colFirstR">Search for:</td>
<     <th class="colLast"><input type="text" name="q" value="{searchfor}" /> <input type="submit" value="Search" /></th>
---
>     <td class="colFirstR">func_lang("Search for"):</td>
>     <th class="colLast"><input type="text" name="q" value="{searchfor}" /> <input type="submit" value="func_lang('Search')" /></th>
14c14
<     <td class="colLast"><input type="checkbox" name="a" value="1" {comsites}/>Include community sites</td>
---
>     <td class="colLast"><input type="checkbox" name="a" value="1" {comsites}/>func_lang("Include community sites")</td>
19c19
<     <td class="colFirstR">List:<input type="hidden" name="m" value="1" /></td>
---
>     <td class="colFirstR">func_lang("List"):<input type="hidden" name="m" value="1" /></td>
26c26
<     <td class="colFirstR">Post date:</td>
---
>     <td class="colFirstR">func_lang("Post date"):</td>
33c33
<     <td class="colFirst" align="right">Sort by:</td>
---
>     <td class="colFirst" align="right">func_lang("Sort by"):</td>
47c47
< Based on your search term, we recommend the following links:
---
> func_lang("Based on your search term, we recommend the following links"):
55c55
< <p>Your search for <b>{searchfor}</b> returned no hits.</p>
---
> <p>func_lang("Your search for <b>{searchfor}</b> returned no hits").</p>
58,60c58,60
< <h2>Results {firsthit}-{lasthit} of {totalhits}.</h2>
< <p>Searching in {searchpages} pages took {searchtime} seconds.
< Site search powered by <a href="http://www.postgresql.org">PostgreSQL 8.2</a>.</p>
---
> <h2>func_lang("Results {firsthit}-{lasthit} of {totalhits}.")</h2>
> <p>func_lang("Searching in {searchpages} pages took {searchtime} seconds.")
> func_lang("Site search powered by <a href="http://www.postgresql.org">PostgreSQL 8.2</a>.")</p>
62c62
< Result pages: {page_links}<br/><br/>
---
> func_lang("Result pages"): {page_links}<br/><br/>
72c72
< Posted {arch_date} by {arch_author}.<br/>
---
> func_lang("Posted {arch_date} by {arch_author}.")<br/>
78c78
< Result pages: {page_links}<br/><br/>
---
> func_lang("Result pages"): {page_links}<br/><br/>
Index: template/about/event.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/about/event.html,v
retrieving revision 1.4
diff -r1.4 event.html
2c2
< Events: {title_event} in {title_location}
---
> func_lang("Events: {title_event} in {title_location}")
Index: template/about/eventarchive.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/about/eventarchive.html,v
retrieving revision 1.3
diff -r1.3 eventarchive.html
2c2
< Events
---
> func_lang("Events")
Index: template/about/events-loop.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/about/events-loop.html,v
retrieving revision 1.4
diff -r1.4 events-loop.html
9c9
<     func_lang("Location:") <B>{event_location}</b><br />
---
>     func_lang("Location:") <b>{event_location}</b><br />
Index: template/about/news.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/about/news.html,v
retrieving revision 1.2
diff -r1.2 news.html
2c2
< News: {title_headline}
---
> func_lang("News"): {title_headline}
Index: template/about/newsarchive.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/about/newsarchive.html,v
retrieving revision 1.2
diff -r1.2 newsarchive.html
2c2
< News
---
> func_lang("News")
Index: template/about/quotes.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/about/quotes.html,v
retrieving revision 1.1
diff -r1.1 quotes.html
2c2
< Quote: {title_headline}
---
> func_lang("Quote"): {title_headline}
Index: template/about/quotesarchive.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/about/quotesarchive.html,v
retrieving revision 1.1
diff -r1.1 quotesarchive.html
2c2
< Quotes
---
> func_lang("Quotes")
Index: template/community/survey.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/community/survey.html,v
retrieving revision 1.1
diff -r1.1 survey.html
2c2
< Community: Survey Results: {page_title}
---
> func_lang("Community: Survey Results:") {page_title}
Index: template/navigation/about.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/navigation/about.html,v
retrieving revision 1.10
diff -r1.10 about.html
10c10
<   <li class="last-child"><a href="/about/servers">Servers</a></li>
---
>   <li class="last-child"><a href="/about/servers">func_lang("Servers")</a></li>
Index: template/navigation/community.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/navigation/community.html,v
retrieving revision 1.12
diff -r1.12 community.html
18,19c18,19
<         <li><a href="{master_server}/community/profile">Profile</a></li>
<         <li class="last-child"><a href="/community/lostpwd">Lost password</a></li>
---
>         <li><a href="{master_server}/community/profile">func_lang("Profile")</a></li>
>         <li class="last-child"><a href="/community/lostpwd">func_lang("Lost password")</a></li>
Index: template/navigation/download.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/navigation/download.html,v
retrieving revision 1.12
diff -r1.12 download.html
4c4
< <li><a href="/download/#other">Community Software</a>
---
> <li><a href="/download/#other">func_lang("Community Software")</a>

---

From: Guillaume Lelarge <[email-masked]>
Date: Sun, 22 Apr 2007 18:39:43 +0200

> too. I don't know if we really need to localize these pages.

There's an error on this previous patch. Take this one.

Sorry about this.

18c18
33,34c33,34
40c40
65c65
26c26
30c30
35c35
46,47c46,47
24,25c24
27c27
38c38
41c41
45c45
48c48
76c76
86c86
106c106
128c128
132c132
14c14
19c19
26c26
33c33
47c47
55c55
58,60c58,60
> func_lang("Site search powered by") <a href="http://www.postgresql.org">PostgreSQL 8.2</a>.</p>
62c62
72c72
78c78

---

From: Guillaume Lelarge <[email-masked]>
Date: Sun, 22 Apr 2007 19:21:34 +0200

> them on my local www-postgresql-org website before sending it.

The french translation (template files and .po file) is available here :
   http://www.lelarge.info/~guillaume/frenchwebsite2.tar.bz2

Regards.

---

From: Guillaume Lelarge <[email-masked]>
Date: Mon, 30 Apr 2007 15:06:58 +0200

Hi all,

> too. I don't know if we really need to localize these pages.

Did someone took a look at this patch ? Thanks.

Regards.